Z600 installer screen won`t appear


#1

Hi new here just wondered if anyone can help with my install problem

My hardware is as follows

HP z600 Workstation 2x xeon x5660 cpus
32gb of ram
Nividia Geforce GTX 1060 6gb

The Dvd boots fine until the point that the graphical installer is away to load and then im left with a black screen a huge cursor in the middle of the screen and a white box in the top left corner all I can do at that point is force power off

I see messages about NVidia cant be loaded etc , is the gtx1060 incompatibly with true os
I have a macpro 3,1 which boots to the install without a problem , it has a gtx680 inside .
Hope someone knows what this is thanks


#2

Which trueos? 1803 or 1806?

Both are based on FreeBSD 12-CURRENT


#3

It’s 18.03 full DVD install


#4

Also mentions something about screen 0 not found not at my computer at the moment as working


#5

What doing a web search concerning your video card and FreBSD?

If you want a newer desktop, checkout either

www.project-trident.org

or

www.ghostBSD

Trueos has stopped being a desktop OS


#6

Yeah been fighting with FreeBSD and ghostBSD trying to install the NVidia driver gnome3 etc even following instructions I have the same issue , startx loads the 3 windows but gnome is a no go just a black screen that cant be escaped from except holding in the power button , have an old NVidia quadro nvs295 same problem I`ve used linux in the past thought I would try bsd out but the display problems are making me tear my hair out :roll_eyes:


#7

searched around cant really find anything helpful


#8

If you are having issues with FreeBSD, then you’ll have problems Trueos/Project Trident.

Take a look at this thread. It ‘may’ be of assitance


#9

Bit confused about the link on printing


#10

so was I :slight_smile:

this thread on discourse


#11

Ty for trying to help


#12

damn, I am really out of it today

my bad


#13

You should not have issues installing your 1060 GTX in FreeBSD, TrueOS or Trident as long as you use OFFICIAL NVIDIA driver:

https://www.nvidia.com/Download/driverResults.aspx/126580/en-us

During initial install of TureOS or Trident there is an option to select the driver. In FreeBSD you need to install the driver with pkg. In my present FreeBSD-11.2 with and 260GTX I use:

nvidia-driver-340-340.107_1 NVidia graphics card binary drivers for hardware OpenGL rendering
with:
CPU: Intel(R) Xeon(R) CPU X5650 @ 2.67GHz (2660.05-MHz K8-class CPU)
in:
uname -a
FreeBSD fb112 11.2-RELEASE-p4 FreeBSD 11.2-RELEASE-p4 #0: Thu Sep 27 08:16:24 UTC 2018 root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC amd64

If OS install of TrueOS or Trident can’t automagically configure your 1060GTX GPU, then you can always select vesa, or the install will do that for you if the proper video driver was not automatically detected.
Then, after installation, in terminal, as su or sudo do:

pkg install nvidia-driver
pkg install nvidia-xconfig
pkg install nvidia-settings

Note: The installation of the nvidia-driver should update (add) your /etc/rc.conf with proper entry to laod the nividia kernel module.

reboot
then do:

nvidia-xconfig

Do: kldstat to see if nvidia.ko module is loaded

And, you should be good with basic X driver configuration for X session login


#14

I don’t even get to the installer on the DVD it’s the point where the gui is displayed for installing the os all I have is a large cursor and a white square in the to left corner

Also have a macpro 3,1 it gets to the installer without a hitch using a gtx 680 , only difference I can see is the z600 is bios driven and the macpro is uefi totally stumped with it


#15

I don’t know z600, my DELL-T5500 is old daddy BIOS chip only too.
z600 must have some chip inside that modern *NIX kernels don’t know about and can’t deal with it, I guess
:frowning:
If you can install FreeBSD, then you should be able to poke around in B&W terminal to see what’s going on and if you can try to install nvidia driver there.


#16

Is that it?

That looks pretty normal for the type of workstation. Nothing unusual there. Grab TrueOS server ISO or FreeBSD and go from there in B&W


#17

I ran TrueOS for over a year, tested Trident Beta3 (2 dyas ago), both with 960GTX.
Now, I run FreeBSD-11.2 with 260GTX - all of those without issues, on my Dell Precision T5500 which is very similar to the z600.


#18

Yeah it’s a complete mystery to me tried vesa mode but it’s a no go too don’t know if having 2 pci-e x16 slots would make a difference I only have one card installed . Linux Ubuntu etc run without a hitch on it so not sure what’s going on
Messed with a lot of different os’s over the last 20 od years and this has me stumped


#19

I would go FreeBSD first, if you can get in with any video output to install. Then, you can at least find out what the issue is with the1060GTX Pascal GPU, but to install OFFICIAL nvidia driver for my 260GTX in FreeBSD
I had to take extra steps.
First Linux support in kernel, don’t know why :frowning:

/boot/loader.conf
kern.geom.label.disk_ident.enable="0"
kern.geom.label.gptid.enable="0"
zfs_load="YES"
nvidia_load="YES"
linux_enable="YES"

Reboot

Then
pkg install xorg
Next
pkg install nvidia-driver-340-340.107_1 (this driver is for 260GTX series GPU you need the latest for 1060GTX)
pkg install nvidia-driver-390.87 (This one is for the newest GPUs the FreeBSD supports)

pkg install nvidia-xconfig
pkg install nvidia -settings

Nothing was needed for nvidia in /etc/rc.conf because I placed nvidia_load=“YES” in /boot/loader.conf.
Reboot
Next do:

nvidia-xconfig

Now you should be able to startx


#20

I’ll give it a try m8 cheers, think the load linux is a compatibility layer because it’s actually a linux driver if I’m not mistaken don’t think there is a native freebsd nvidia driver but I might be wrong