XSane not starting in Trident


#1

Hi, first of all I have to tell you that did not even work previously on Trueos 18.03.
However, running it by command line it gives the answer here below, and maybe someone could help me to solve:

trident-4020% xsane

(process:20138): Gdk-WARNING **: 08:33:36.918: locale not supported by C library

(process:20138): Gtk-WARNING **: 08:33:36.926: Locale not supported by C library.
Using the fallback ‘C’ locale.
process 20138: arguments to dbus_connection_send() were incorrect, assertion “connection != NULL” failed in file dbus-connection.c line 3310.
This is normally a bug in some application using the D-Bus library.
D-Bus not built with -rdynamic so unable to print a backtrace
zsh: abort xsane

thank you


#2

do you have dbus running?

that’s what the error looks like


#3

can you please indicate how to open a task showing running applications?


#4

start menu -> control panel -> Service Manager -> Running Tasks


#5

Dbus service is not running (false-false)


#6

Then it needs started


#7

ok, something has moved.
If I run Xsane as user, this is what I get (device not found)

then if I run it as Root it opens, it shows my scanner, but cannot start any scanning-preview session, error message is “Cannot start scanner. An I/O error has occourred on the device”


#8

now, just upgraded tu U7, the HPLIP device utility has appeared in the tray, when right-clicked it shows "HP scan device scanner (1.1.1.1) with a yellow triangle icon, but when the setup/detection software is opened, it does not detect any device


#9

and if you open a terminal, and type top, you will see python using 80+% of your CPU time


#10

it seems not doing that, resources are ok while HPLIP (and something else meantime) is running:

the problem appears to me as a bidirectional communication port problem, since when XSane starts it shows on the top side my scanner name, meaning it has been detected, but then it can’t communicate with it when starting a preview or a scanning session.
Also, my Canon Lide 100 scanner behaviour in Windows and Linux, consists in a short gear noise as plugged in, giving a presence signal, which is missing when plugged in Trident (and Trueos before)


#11

ok, I see that this topic is going to terminate with no other suggestions for solving, and repeat, I feel it could be a permission problem but would need help on it, so I try to switch on a workaround side, same here before opening a new topic :
I could use the network scanner functionality of the MFP device already registered as printer in CUPS , it is a Samsung Expression C460 , needless to say that such network scanner is used in Windows, Ubuntu and MacOs Sierra . I there a way to set it for working?
Thank you