Wireless not working?


#1

So this isn’t necessarily a TrueOS issue - it could be something lower-level than that. Basically, when I scan for internet networks, nothing appears. When I type the network I want to connect to manually (as a hidden network), it still does not appear. I’m using Qualcomm Atheros AR9 but I don’t know if there is some kind of driver problem, or how I would install the drivers.

I would be happy to provide any additional information if you may find it helpful.


#2

from 2013 --> https://forums.freebsd.org/threads/how-to-get-atheros-ar9485-wifi-working.41554/


#3

Neither matches my problem exactly, but I might as well try updating the bios.
I have a Dell Inspiron 11 computer, how would I go about doing this?


#4

Step 1: Check driver detection

dmesg | grep ath

Step 2: Connect to BSSID, not ESSID (because ‘hidden’)

Edit: And read these:

$ ls /usr/share/man/man4/ath*
/usr/share/man/man4/ath_ahb.4.gz
/usr/share/man/man4/ath_hal.4.gz
/usr/share/man/man4/ath_pci.4.gz
/usr/share/man/man4/ath.4.gz


#5

Driver detection returns that the cards are detected and [ath_rate] [ath_dfs] and [ath] are loaded. I would paste it in, but I have no internet connection.

What does it mean to connect to BSSID?
I read the manual pages but I’m still not sure what exactly to do.


#6

BSSID is WiFi network name.


#7

No, it isn’t.

7.1.3.3.3 BSSID field
The  BSSID  field  is  a  48-bit  field  
of  the  same  format as an IEEE 802 MAC address.  

This  field  uniquely identifies each BSS. 

The value of this field, in an infrastructure BSS, is 
the MAC address currently in use by the STA in the AP of the BSS. 

The value of this field in an IBSS a 
locally administered IEEE MAC address formed from a 46-bit random number 
generated according to the procedure defined in 11.1.3. 

The individual /group bit of the address is set to 0. 
The universal/local bit of the address is set to 1. 

This mechanism is used to provide a high probability of 
selecting a unique BSSID.

The  value  of  all  1s  is  used  to indicate  the  wildcard  BSSID.  
A  wildcard  BSSID  shall  not  be  used  in  the BSSID field 
except for management frames of subtype probe request.

Source:


#8

Thanks mate


#9

Thanks for the help. I tried Fedora and found that the problem was indeed with my BIOS. I’ll have to reset it to get the wifi card to work.


#10

Hi Neil… I’m also trying to setup an Inspiron 11 (P24T) and have the same issue… Did you get it to work? How did you reset the BIOS? thanks in advance!


#11

This thread describes solutions:

I was able to get my computer to work using the accepted solution.