Windows 7 installer not seeing the disk in bhyve


#1

I’ve installed windows 7 in bhyve before (using iohyve and vnc), and it’s worked. However, when I try to do it now, when it gets to the part of the installation where you partition the disk, it doesn’t see any hard drives. Since it used to work, presumably, something has changed since the last time I tried it (which was either earlier this year or late last year). If I try the Windows 10 disk that I have, then it works, but I want to install Windows 7, not 10. Has anyone else seen anything like this? I can’t find anywhere online where anyone describes this particular problem, let alone how to solve it.


#2

I don’ know the bhyve and the iohyve, but the Windows can see directly only the NTFS and FAT formatted volumes and the unformatted volumes. Maybe is this the problem?


#3

Are you passing the disks as paravirtualized (virtio) devices or via IDE or SCSI?
IIRC Wirdows 7 still only supports IDE out of the box - anything else requires manually loading additional drivers.


#4

It’s given access to an unformatted zvol that was created specifically for the VM, so that wouldn’t be the problem.

bhyve takes disks via AHCI, which is what it’s always done, and that worked just fine with Windows 7 previously. I’m pretty sure that that’s how my actual hardware is set up as well, and it installs Windows 7 just fine, since I set that up to dual boot.

Given that this worked previously, it seems likely that something with bhyve changed since the last time I did this. And given the fact that it I’ve had FreeBSD and Linux VMs suddenly start failing to boot, with the bhyve UEFI stuff not loading their bootloaders, I suspect that either bhyve has some serious problems at the moment (at least with what I currently have set up), or my machine has issues of some kind that it didn’t have before. bhyve seems incredibly flaky for me right now in a way that it wasn’t at the end of last year.


#5