Why is there no data in my hard drive?


#1

I have a Seagate 1Terra Byte drive, and another Seagate 4TerraByte drive. They were both formatted using the PC-BSD disk manager utility in PCBSD10.3 GPT, and freebsd-ufs.

I have not had much use for the TerraByte drive so it’s been sitting there unused, until I wanted to read “Storage Essentials” a book that I bought from Tilted Windmill press some time ago and stored it on the Terrabyte External. Although the book didn’t cost much I did not want to pay another 10 bucks for something I already bought.

Plugged that baby in and zero files, and zero folders where in there. Plug it in a different laptop, and desktop, and same result empty drive. I’m panicking. A whole Terra Byte of data is gone. Plug the 4TB external drive and it says the same thing zero files, I run fsck -y and I get my files back on the 4TB plug in the 1TB and run fsck -y and still zero files. I had an old PCBSD disk, I installed it, and the 1TB is read without a problem under KDE.

I managed to get the file I wanted from PCBSD10.3, but why does it not display my files in TrueOS?

I even tried an ls under /media and also under autofs and they all come up blank. Go back to PCBSD and it comes right up with all my files without a problem the 4TB works in PCBSD also, but for some reason not on TrueOS.

Can anyone shed some light on this?

@beanpole135
Will Lumina use a “file system marked dirty” in future releases or is this something you are trying to avoid?


#2

i think i heard of an earlier post with the same issue, flash drive / cd-rom wouldn’t show files.


#3

Disclaimer: I ran a quick search on “wont show files” and nothing showed up… Rod, Was there any suggestions on the earlier post, on how to get our files to show?


#4

dang man, do I have to do everything for you? :wink:

wasn’t here, on discourse. here’s the link


#5

Not everything, just most of it. :star_struck:

Interesting most of them are on the Unstable train. I’m on Stable, and have the same issue. It’s just weird how it does it for some USB drives and not for others.


#6

saw your github post.

i knew i saw it, but couldn’t remember where.


#7

Yeah, I don’t like bothering the Devs too much, but this seemed like something that really needs their attention.


#8

I’m going to repost Ken’s response in the ticket here, in case anyone needs the manual fix:

"Fixed in source - looks like the “large” flag in the msdosfs mounting routine got removed recently and that is causing the autofs mounting routine to fail.

If you want to fix it on your system right now, you can just remove that flag from “/etc/autofs/special_autmount” (you can copy the file from here[1] if you like - look at line 46).

[1] https://github.com/trueos/freebsd/blob/drm-next/etc/autofs/special_automount"


#9

Tested it yesterday and it works great. For those having a localisation other than default: you can also add the -L option.

E.g. for German:

"msdosfs") 
          echo "-fstype=${_fstype},nosuid,async,-L=de_DE.UTF-8,-M=777,-o=longnames :/dev/${_p}"

#10

Isn’t German standard?


#11

You are right, what I meant was “default” (edited the post).


#12

I know it says “msdosfs” in there, so my question is. Will this help me with my freebsd-ufs formatted drive?


#13

Did not work for me. My drive doesn’t show up on autofs at all now.


#14

@Groot : UFS formatted drives fall under a different rule:
“msdosfs” is the “FAT” filesystem from Windows - so that will not apply to UFS formatted disks.
If you want to adjust the rule for UFS, you can either create a section with ufs) in the script, or just adjust the fallback routine *) which is what being used to mount UFS right now.`


#15

@beanpoloe135 Theoretically… What if I don’t have the expertise required to add a section to the script, or even know where to begin looking for the fallback routine? :flushed:


#16

Can you tell the file system of your both drives, please.


#17

both of them are formatted freebsd-ufs.


#18

So basically both drives won’t work with TrueOS. As for Autofs what I know it’s only mounting NTFS and FAT partition. How exactly you mount UFS? Is it showing device, mount point and space usage in “df”?


#19

Only one drive won’t work. The 1TB drive formatted freebsd-ufs will not work on TrueOS, but it will work on PC-BSD the 4TB formatted freebsd-ufs does work.