What program(s) needed to be added


#1

this is not a discussion thread, per se.

What program(s) have you used in te past, that we are not shipping at the moment?

We will look at build logs, and freshports.org, to see what we can do to fix things

edit:
check freshports.org first, to make sure it has been ported to freebsd

edit: 20190222

this is what I show so far

iocage - should be fixed in U6

komposer - depreciated in 2013

PlayOnBSD - python issue. maintainer issue

GhostWriter - Available in AppCafe U5

Jitsi - AppCafe, last updated 2016

Xiphos - is marked as broken: fails to compile: /usr/include/c++/v1/type_traits:1116:29: recursive template instantiation exceeded maximum depth of 25

rkhunter - AppCafe U5

spice-gtk - cannot install: Unknown component ssl. a trueos issue or port maintainer issue

ncrack - checking whether OpenSSL’s headers match the library… no
configure: error: Your OpenSSL headers do not match your
library. Check config.log for details.
If you are sure your installation is consistent, you can disable the check
by running “./configure --without-openssl-header-check”.
Also see contrib/findssl.sh for help identifying header/library mismatches.

configure: error: ./configure failed for opensshlib
===> Script “configure” failed unexpectedly.
Please report the problem to lx@FreeBSD.org [maintainer] and attach the
“/wrkdirs/usr/ports/security/ncrack/work/ncrack-0.6.0/config.log” including
the output of the failure of your make command. Also, it might be a good idea
to provide an overview of all packages installed on your system (e.g. a
/usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1


#2

BlueGriffon http://www.bluegriffon.org

I’ve used it and similar programs (like Frontpage) in the past, but not on any FreeBSD based OS’s (PC-BSD/TrueOS/Trident) since it/they haven’t been available.


#3

not ported to FreeBSD


#4

iocage?..


#5

https://builds.ixsystems.com/poseidon/data/trident-master-current/2019-02-05_17h29m32s/logs/errors/py36-iocage-1.1.log


#6

I saw that error when I tried to update a jail to 12.0 when I was still using 11.2 as the host. This was on Vanilla FreeBSD though, and probably unrelated. Still interesting to see the same error in the build though.


#7

told be @beanpole135, its a port issue.

i know trueos just re-synced ports a day or so ago. Having said that, U4 won’t have that fix then.

we need, all of us, to start filing bug reports in the appropriate github.org/trueos repo


#8

Does that mean that U4 will be released (relatively) soon?..


#9

once a week. gives the devs time to test, and make sure

that only really applies when syncing with ports, not minor upgrades, like U3 & U4

FYI, anyone can find the build server status, and package progress. all you have to do is start at the www.Project-Trident.org web page


#10

I’ve been following iocage on github, that skarekrow guy seems to be really active and it seems like in the last few months they were really active with new features and bug fixes.
With the weekly synking of ports does that mean that we will get those bug fixes and new features (if available) weekly?

One feauture that I’ve been really waiting for is a nuke a single jail option… That probably wont happen anytime soon, but if it does do we get it within a week?


#11

Yes I know, but it seems to be on the way https://wiki.freebsd.org/WantedPorts - https://github.com/therealglazou/bluegriffon

But how about Kompozer while we wait? https://svnweb.freebsd.org/ports/head/www/kompozer/?pathrev=314898
It’s obviously outdated, but it used to be on AppCafe some years ago.


#12

@groot it depends on if skarekrow is also the FreeBSD port maintainer for iocage. Most of the time the “owner” of a project is not the maintainer of the port. Port maintainer is usually someone that decides they want the program in FreeBSD and do the work to fit it into the ports framework.

What we have here with TrueOS/Trident is basically: they forked FreeBSD ports, so they run a little behind FreeBSD ports tree (weekly resync means they stay close) and the FreeBSD ports run a little behind “original project”. So new feature in original project, unknown how long to get it into FreeBSD ports tree, but TrueOS/Trident should have it within a week or two after it hits the FreeBSD ports tree.


#13

you need to check freshports.org first

kompozer is not listed anymore


#14

playonbsd for junior-- maybe I could convince him not to use W10 this way.
wine(-devel) is working anyway on Trident U3…

wxWidgets, but don’t know what the problem with py36 is… Last build-server log:

===> playonbsd-4.2.10_4 depends on file: /usr/local/lib/python3.6/site-packages/wx-2.8-gtk2-unicode/wx/init.py - not found


#15

having the devs look at PlayOnBSD today


#16

ghostwriter, my favorite Markdown editor. Yes, it is on fresh ports. https://www.freshports.org/editors/ghostwriter/


#17

funny thing about that program. It’s listed on fresports, but not on the build server

posted this to the trident devs, and we’ll see what happens


#18

Markdown editors? You mean ed and roff are good enough? :slight_smile:


#19

Good to be back on BSD! The only program that I can’t find from my PCBSD days is xiphos… There are several programs (such as Jitsi, rkhunter, etc) in the App Cafe that don’t run out of the box on my ThinkPad, but hacking on things that dont quite work is half the fun for me! :wink: I’ll pass along any fixes…


#20

xiphos
is marked as broken: fails to compile: /usr/include/c++/v1/type_traits:1116:29: recursive template instantiation exceeded maximum depth of 25

Jitsi
Maintainer: [tzabal@it.teithe.gr]
Last Update: 2016-03-26 16:u5272:

rkhunter:
Maintainer: [lukasz@wasikowski.net]
Last Update:* 2017-07-16 23:39:04