What about the NVIDIA driver?


It appears the correct drivers are installed. I added the two lines. I sudo’d and used ee. Now system stops at login. Not the pcdm login. I noted on reboot alot of errors with rc.conf. I tried to edit to remove those two lines. But I get unable to create file etc/rc.conf.


@mer I love you XD
I was on the desktop and there i done what you wrote without stopping the pcdm. after reboot there was no bar at the bottom of the screen, i load the default for the bar and there is the bar. now i can enjoy my TrueOS with my gtx 1080. Thank you very very much for your time and for YOU work to fix MY problems.


@daFrank thanks for the feedback, glad we got it working for you. Now to get @rrod working…

@rrod, I haven’t forgotten, just trying to think of what else to try next. Can you walk through the same steps as daFrank? When you say it stops a the login, but not pcdm, do they keys work and can you log in as your user?


Boot stops as soon as you see login…where you would login as root or user name. Lots of errors. Nvidia-modesetting_enable=yes not found. I tried to undo the two lines beanpole had me add, but. Cannot.


@rrod if i understand right you have an rc.conf error at boot and a read only fs. i fix this with an fresh install of TrueOS. i know it’s possible to bring back read/write fs in freebsd but i don’t kno how. i had the same errors


Thanks. At that point, keys don’t work, you can’t log in? If that is correct, we’ll probably wind up stopping at the bootloader and booting into single user mode and doing a few things. That should let us fix things (or break them worse? :wink: )

Let me have a day to look things up and figure it out.


@rrod @mer i found this video, it’s in german and for freebsd but the screen is in english. after min 38 he show how you can fix the read only problem with using nano. he write mount -urw / and change the rc.conf. i hope that will be helpful


Think I will reinstall. I did not l9k at video because I cannot install packages. Sudo unable to open var/run/sudo/ts/user


be aware, the installer & nvidia are broke.

they are attempting to get a new ISO out sometime this week


Mer. Please do not waste time. I am going to perform a fresh install. I need to work some things out. Like maybe figure out how to manually create a BE, see if I can taken advantage of snap shots. My external HD is dying, I need one for backups. Then I may return to this subject.

Current Update Hosed My System

Thanks. Does that mean a fresh install when the iso is out?


Hopefully it means they have fixed the nvidia driver and a few other issues being you fixed.

I know Joe is working on getting things running correctly and building correctly before it’s released.

FreeBSD has changed a few things upstream and it’s causing build issues


Thanks for the heads up.


Ok. Get the hardware and ISO sorted out, if you need help we’ll give it a shot.
Manually creating BE and doing snapshots is easy, even from the command line.
Awesome because you break something, just boot into a working one and blow the bad one away.
System recovery the way it was meant to be.


I’ve tried an shorter way to install TrueOS with nvidia-driver: Install TrueOS then sudo pkg install nano nvidia-driver nvidia-xconfig. reboot. Then sudo nvidia-xconfig and sudo nano /etc/rc.conf add the line kldload-nvidia=“nvidia-modeset nvidia” save and reboot. it works :slight_smile: but after this i must load the Lumina default settings. Good luck

Dell E6410 Video issues

“Optimus technology” Rod :wink:


Yeah, yeah, that’s it :wink: