What about the NVIDIA driver?


Hi, just wondering what the status is on Nvidia driver. How do I get it installed?

Vulkan API support?

If you had an nvidia card in when you first install TrueOS or added one after and selected it as the primary device in BIOS, the Nvidia driver should have been installed for you.
from a terminal window:
pkg info | grep -i nvid
will show if it’s installed
the command
will show if it’s being used (look for the X11 driver line).
The only potential issue would be if you have older hardware that is not supported by the current version (375.26). There should be older versions available from the AppCafe (ports), likely versions 304 and 340.

Current Update Hosed My System

Yes, @mer is correct in that the NVIDIA drivers work perfectly fine on TrueOS, you just need to make sure you have the proper one installed for your card. Every so often NVIDIA releases a new “generation” of driver, and older cards may need one of the older generation drivers (340 or 304).

Here are the package names/versions, and links to the NVIDIA site which lists which cards are supported by each driver:
nvidia-driver (included on TrueOS Installation Media), currently version 375.26

nvidia-driver-340, currently version 340.101

nvidia-driver-304, currently version 304.134

If you need one of the older drivers, you just need to install the package listed above and reboot, then at the login manager click the bottom-right button and choose the “Change Video Driver” option (or something to that effect) and choose the “nvidia” driver.

HP EliteBook 8540p notebook

Ah yea, you’re right, it is working well!


I was wondering if it would be too much of a hassle for devs to include all three types of drivers for nvidia on install medium. After several years of poking around with PCBSD and now TrueOS, I find it quite unpleasant, to have to install 340 version manually to make my olderish 9800 GT card to work. This problem alone, made my path of understanding how system works, great opportunity to learn many new things. But some dad, trying to re-purpose older machine for his son to try out opensource games might not be that “lucky” (does not have time or motivation). He might go trough the install process, but upon reboot the feel of sluggish response and video teardown will not make them stay on this distro.

Other possible scenario to consider why including all drivers on install medium is a good thing is for situations where you don’t have internet access during install, but you need system in workable condition.

I know downside is that so many people will increase download bandwidt on something that has no use for them, but since install medium size dropped significantly since KDE and alike are gone, that driver size is not big issue at all.


I think all 3 drivers are not available on the install media because they all conflict with each other. The automatic driver detection routine might be updated to load/install each nvidia driver in order of newest/oldest, but that presents it’s own special issues and will need to be worked out very, very carefully.


I have no doubt this is not easy to implement, but would greatly improve first impression of OS, at least for users with nvidia cards.


As my personal experience has shown, it never works out properly. I dont even know of a linux distro that’s been able to get all three drivers on an ISO to work properly. It’s either Intel, latest Nvidia, or Vesa.
Part of the problem is that in some cases the 340 driver will lock the system, and then now allowed the 304 to be attempted. Another problem is on legacy systems that have multiple GPUs (like my older Quadro Cards), sometimes the presence of a 2nd GPU (even if its on the same PCB) will cause the system to lock or not detect the graphics card at all if you attempt a newer driver than legacy.


Furthermore, the drivers are pretty big. That’s my only concern regarding
this. I think hardware support will win us a lot of users otherwise!


Hello, im new in TrueOS and my English is not good.

I have a Nvidia gtx 1080 witch not autodetected in the TrueOS-Installation.
After the TrueOS-Installation i install nvidia-driver (375.26), nvidia-settings and nvidia-xconfig via AppCaffe.

If i run nvidia-xconfig via Terminal and reboot the System than it boot in Textmode.

If i click in the login manager the bottom-right button and choose the “Change Video Driver” than i have a black Screen and nothing works.

What is the right Way to configure my System for nvidia-driver (375.26) with gtx 1080?


@daFrank in the text mode, can you type characters in, does the keyboard work?
if so, the output of the following will help us:
pciconf -lv | grep -B 4 -A 1 display

I think that it should be using 375, but want to make sure.
If the text mode works see if there is an xorg.conf in /etc/X11/. nvida-xdonfig should have created or modifed one.
If there is edit it (as root) change the driver to say nvidia.
The “modesetting” driver should work and give you an X environment, that would be a start.


@mer Yes the keyboard work in text mode. Here is the output of pciconf -lv | grep -B 4 -A 1 display, Xorg.0.log and the current xorg.conf. I hope it’s helpful. THX


@daFrank, is this a laptop or a desktop with an extra card in it? The pciconf output shows 2 devices, the Intel integrated graphics and the Nvidia card. If that is what you have, can you see if you can turn off the integrated graphics device from the BIOS?


if it’s the dual card laptop, you’ll need to disable the nvidia card within bios, and use the intel card

I forget the name of the dual card systems


I am having trouble with my screen. Since I performed a fresh install from the latest stable iso, my screen resolution no longer fills my monitor. I installed the nvidia 375 driver. When I use “about” x11 driver shows"nv.dv.so. “pciconf -lv | grep -B 4 -A1 display” shows my card. “pkg search nvidia” shows all three nvidia drivers. I tried changing the driver at the login, x keep saying previous attempt failed. I looked, there is no xorg.conf in /etc/x11. I do not know how to run nvidia-xconfig. Tried nvidia-xconfig at the terminal, but return says no command found. When I try man nvidia-xconfig, return is no manual entry.


@rrod: Just follow these steps:

  1. install the nvidia-driver pkg (running pkg info | grep nvidia should list it if it is installed. pkg search is used for searching the remote repository - not your locally installed packages)
  2. Edit /etc/rc.conf and add these two lines:

This will load the nvidia and nvidia-modesetting kernel modules on next boot.

  1. Reboot the system: shutdown -r now or use the graphical interface
  2. On the login screen - click on the lower-right “system” button and click the option to change your graphical driver. That should let you pick the “nvidia” driver for your system and continue on.


@mer It’s a desktop with an extra card. I don’t know why the intel card was not turned off, but that was the Problem. Very thanks for this Tip :slight_smile:
Now I’ve installed TrueOS with nvidia only and the card is detected in Installer.
Than i follow the steps witch beanpole135 wrote, but this crash the system after step 3: rc.cong error and read only fs…
What is the right way to activate the nvidia-driver?


Well, two steps forward, one step back :slight_smile: If the nvidia is detected in the installer, it should have done the right things like putting the nvidia lines in rc.conf for you.
editing /etc/rc.conf you have to either sudo or su to write it
output of grep -i nvidia /etc/rc.conf lets make sure there’s only one there
output of kldstat | grep -i nvidia (that will show us what modules are loaded)
Is there an /etc/X11/xorg.conf?


@mer I wrote sudo nano /etc/rc.conf for editing.
oh, i installed a fresh TrueOS after my last post.
grep -i nvidia /etc/rc.conf show nothing, kldstat | grep -i nvidia show nothing, /etc/X11 is empty.


Hmm. that rc.conf did not have any nvidia lines in it?
So you have a fresh install, the intel is disabled.
And you are just sitting at a text console?
lets make sure the pcdm service (login dialog) is not running.
service pcdm stop
rc-update delete pcdm

pkg info | grep nvidia does this show “nvidia-driver”? We want to see nvidia-driver-375.26_1
if not then sudo pkg install nvidia-driver
After that gets installed or is already installed, lets check /boot/modules for them.
ls -l /boot/modules
we should see nvidia-modeset.ko and nvidia.ko
Lets try loading them by hand:
sudo kldload -n -v nvidia-modeset nvidia Look for any errors.
If we’re ok to this point, lets try creating an xorg file
sudo cp /usr/local/share/trueos/cardDetect/XF86Config.modesetting /etc/X11/xorg.conf
edit the xorg.conf look for the line that says Driver “modesetting” and change modesetting to nvidia and save it.
In my rc.conf I have a line that says:
kldload_nvidia="nvidia-modeset nvidia"
try adding that to your rc.conf.
Now lets try and start x or the lumina desktop, with the command:

Hopefully you are up in Lumina, using the nvidia card.