VirtualBox not working properly 3-30-17 snapshot



Since the 3-30-17 update VirtualBox isn’t launching my VMs. Tried this with FreeBSD 8.4, Windows 8 and Windows 7. Worked fine previously.

Error I get is:

RTR3InitEx failed with rc=-8 (rc=-8)

Please try reinstalling VirtualBox.

where: supR3HardenedMainInitRuntime what: 4 VERR_NO_MEMORY (-8) - Memory allocation failed. 

Anyone else having this type of issue?

And yes, I did try reinstalling VirtualBox.


I have the same issue, and I have no idea what’s really wrong or how to work around it. Unfortunately, in my experience, virtualbox seems to be one of those things that just randomly breaks on updates on pretty much any OS. It’s too bad that bhyve doesn’t have a proper graphical front-end so that it’s a viable replacement for running Windows. It at least has vnc now, but the mouse doesn’t line up worth anything with it, and it has no sound. So, virtualbox is the best we have, and it goes and does something like this on us yet again… :frowning:


Well, glad it’s not just me!


Same pbm for mee too.


the TrueOS devs found that the build server was introducing errors in the build process, which will probably be the cause of many issues.

New hardware is on the way and they will move the TrueOS build server will be swapped over


I have the same problem :frowning:


Sadly this isnt the only cause of the problem. There are issues with VirtualBox itself. VirtualBox isn’t running on Macs right now as well. Certain Intel Chips are not supported right now by VirtualBox in their latest version.

We talked today about making a legacy VirtualBox package that will be the previous version for all those that require VirtualBox to work. I’m not 100% sure that’s the path we are going to take, but there’s little else we can do about it.

Issues within VirtualBox itself are not something we can resolve.


I’m not sure how often they’re something that Oracle can resolve. :expressionless:



Always nice to see FractalSponge’s work show up in various places on the internet.


Hi TrueOS friends.
Coming back after a while because of installation of Debian Jessie on my laptop.
As you know i need Virtualbox on my laptop for professional reasons and the unability to run VB leads me back to Linux (for the moment).
Any news of a VB version “TrueOS tuned” ?