User Account WIPED OUT in Control Panel


#1

I had just figure out that to change the default shell, I had to go to Control Panel, System Management, User and change it there. (Command line change had no effect, desktop being used was lxde.)

I did so and then clicked on Save. No message that it had saved, maybe I didn’t click hard enough.
So I clicked “Save” again.

Message: “Unknown user”.

I rebooted and the login choice is Charlie &. I log in with my root password thinking I can go to control panel/lifesaver and do a snapshot restore. No such luck - the control panel windows opens and then closes immediately.

User jimserac apparently no longer exists. Please don’t tell me this is normal behavior, it can’t be.

Surprising fragility for such an important part of the system.

Is there a way to restore my user or is it reinstall time ? The folders /usr/home/jimserac is still there.

Thanks
J.


#2

drop to terminal, and log in as root

type --> cat /etc/passwd | grep charlie (or how ever you spelled it)

if it is NOT there type–> pw useradd tom
someone will correct me if I’m wrong

that should recreate you account


#3

But it IS there. Shows as a root account Charlie &, So I did nothing.

Now what ?

Thanks !

J.


#4

create a new account

pw useradd test

sudo pkg install mc

run --> mc

see what file(s) are there and missing by comparing the 2 accounts. Your account on one side and the test account on the other.

Worse case scenario, copy from test into your account.

this “should” get you able to log back in. This by NO means is elegant or graceful. but it does work


#5

Charmingly devious.

I’ll try it now.

Thank !

J.


#6

Er…do I login in as “test” before install mc and, if so, what is “test”'s pasword ? None ?

Thank
J.


#7

either log in as you or root


#8

No go, the user shows as test & and won’t take any password at login

Reinstall ?

Thanks
J.


#9

An option. Copy everything into the "test account. log into that, and delete and recreate your account


#10

I can’t log in, at least not through Lumina cuz “test” accepts no password, even my root password, nor will it let me change “test &” to root and log in that way.

Is some way to log in to command line ?

J.


#11

do you have access to the web at all? Yes I know you are here, but triple checking

If so look here --> https://www.digitalocean.com/community/tutorials/how-to-add-and-remove-users-on-freebsd


#12

OK ! Get some rest and thanks for the help !!

J.


#13

OK just reinstalled, saving everyone a lot of trouble. Nothing lost, all data is on a seperate disk.

Idea: Create 2 user acocunts, one of which is backup that might be needed .

Problem: What music to listen to while re-installing: Ein Kleine Nachtmuik, Lulu, or Petula Clark.

Hmmm… perhaps all !

Ha ha ha ha !!

Thanks for assistance everyone, this is really fun…or I’m crazy…or both !!

J.


#14

You wrote:
I had just figure out that to change the default shell, I had to go to Control Panel, System Management, User and change it there. (Command line change had no effect, desktop being used was lxde.)

This is ultra-crazy!
Please, tell me: What did You do/try on the command line, which then didn’t work?

Edit:
https://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/shells.html

SubSection 3.9.1. Changing the Shell

And:
https://sysadm.us/handbook/client/sysadmclient.html#user-manager


#15

Comparing this thread with the one from @jhz (Apr 17) I think a warning sign is needed to call users attention to the risks of changing the default shell.


#16

I used the standard line that everyone gave me…I forget now, something like chsh -s /usr/local/bin/bash
then I logged out, then logged in and it appeared to have done nothing.

So what you suggest is that once do that command (as user, not as root, cuz I did it as user), it’s going to update the control panel user account setting automatically.


#17

I suspect that there is some kind of BEEG BUG in there if you click on “Save” button twice (in System Manager, User Account).

But when you click on it once, nothing seems to happen, no “Account Saved” or “Updated” message, so I clicked on it again.

One thing for the bug hunters, after clicking on it the save button the 2d time, the User ID field gets grayed out and a message appears statins something like “Unknown User”. So right then I knew I had been zonked.

J.


#18

Before “chsh -s /usr/local/bin/bash”,
this must be there:
$ cat /etc/shells | grep ‘/bash’
/usr/local/bin/bash

After “chsh -s /usr/local/bin/bash”,
this must be there:
$ getent passwd `whoami` | grep -o ‘[^:]+$’
/usr/local/bin/bash


#19

Getting back to the GUI, I can confirm that there is a BIG BUG in control panel, SYSTEM MANAGEMENT, Users.

Following advice from Rod, after this new install I created two users, jimserac and test.

I went to control panel, system management, Users and, while logged in as jimserac, changed the shell to /bin/bash.

Then hit the save button (just once !!).

All seemed well, getting nice pretty colors from ls when I opened terminal. All seemed good.
Upon reboot, user “test” shows up at the login !! No jimserac !!

It’s like “Stranger Things”, my user account has gone to another dimension !!

So, before I go to command line and follow your suggestions, can I ask what is the correct way to do it from GUI,?

Should I go AppCafe and make sure bash is installed first, then go to System Management, then Users and then change the shel to /binbash OR should it be /usr/local/jimserac/bin/bash (in the GUI) ?

OR is it reccomended to avoiding the GUI for now ?

OK, now I will try your suggestions on the command line way of doing it

I will create a new user jimserac1, while logged in as “test” and then log out and log in as jimserac1. Then I will try the command line way of switching to bash as my default shell.

I may need some background music, either Swan Lake or some Arnold Schoenberg (!!)

Thanks
J.


#20

It’s:
$ which bash
/usr/local/bin/bash

not:
/bin/bash