USB stick file names wrong encoding


#1

The USB stick is formatted for Windows. Illegal characters appear in file names. It seems it is mounted to get file names in UTF-8, though they are encoded for Windows (I suppose ISO-8859-1).

Is there a way to fix this:

  • to this single device?
  • to all devices of the same kind?
  • … perhaps a bug fix?

Thanks.


#2

Have you tried convmv? It’s in the AppCafe


#3

Thank you. I think I wasn’t clear enough.

I don’t want to fix the file names. I want to fix the mount settings.


#4

Yes I misunderstood that. Mounting foreign file formats with their own encoding is out of my league. Hopefully one of the devs can chime in.


#5

Hello!

I’m not sure, but give a chance and try to give for the rc.conf this: unicode=“YES”


#6

Manually mounting such devices, there are options to set the file names encoding. For Windows file systems, the default options seem correct to me (e. g. mount_msdosfs). But I’m afraid that autofs is setting UTF-8 as default. I’d like a way to know how to change/fix this setting.


#7

In case someone used German special characters on a MSDOSFS formatted USB stick I changed the according line in the file /etc/autofs/special_automount (as root) as follows (added ,-L=de_DE.UTF-8):

"msdosfs")
		echo "-fstype=${_fstype},nosuid,async,-L=de_DE.UTF-8,-M=777,-o=longnames	:/dev/${_p}" 

Be aware, though, that you have to change this file after most OS updates.


#8