Usb boot probleme on Acer aspire 3 a315-41


#1

Hello everyone! I try to boot Trident from usb, on this laptop, and it’s not working. I don’t have the option to boot from usb in boot menu. Bios is set to uefi and I don’t have any other option. The usb was made with win32imager and rufus in dd mode. GhostBSD is not working eighter. Only in Freebsd I have the option to boot. Please guide me if someone can. Thank you very much!

P.S.: Sorry for my bad english. I’m from Romania.


#2

from the old trueos handbook

https://www.trueos.org/handbook/install.html#burning-the-installation-media

If the beta ghostBSD is not working, the Project Trident will have the same issue(s).

What is it doing and / or not doing?


#3

If I press F12 (boot menu) I don’t have the option to boot from usb. Only windoze and few linux distro, witch I have instaled previously, appear. I can atach a picture if it helps.


#4

please do.

do the BIOS offer the ability to switch boot order? putting USB at the top?


#5


#6

If I make the stick with linux or windoze it will appear like this:


#7

do you have secure boot turned off?


#8

Yes. It’s disabled.


#9

we’re missing something, and I don’t know, nor see it.

best option I can offer. look through each BIOS menu and see it anything strikes out at you


#10

One more thing that I notice…the efi partition on usb stick is fat (I use partition wizard home edition). The efi partition on linux bootable is fat32. This is the only difference I found. I will reply if I found a solution. Thank you very much!!! Have a nice day!


#11

should not matter either way


#12

hello ovinet - i boot on usb drives exclusively. my system is a lenovo t530. my bios settings will likely differ from yours, but you might get some additional insight:

in bios i have: bios -> config -> usb

  • “usb uefi bios support” : enabled
  • “always on usb” " enabled
  • “usb 3.0 mode”: auto

then for bios -> security -> secure boot

  • “secure boot” : disabled

next for bios -> startup

  • “uefi/legacy boot” : both
    • “uefi/legacy boot priority”: uefi first

getting started with usb booting, i had to do this:

  1. download the iso (example trident.iso)
  2. prepare a usb “stick” drive that i will use to install trident:
  • insert the stick into a working bsd system
  • check dmesg to determine the device id for that stick (usually da0, but may be different on your system.) you must know the correct device id for the usb “stick”
  • prepare the usb “stick”. make sure you have the correct device id!
gpart destroy -F da0
gpart create  -s GPT da0
gpart add -t freebsd da0

now, copy the downloaded iso as follows:

dd if=trident.iso of=/dev/da0 bs=4m

the dd command will do a byte for byte copy of the iso onto the usb “stick”. note that this command only copies the exact iso, which may be a different, smaller size than the usb “stick”. if you do a gpart show da0 command immediately, the gpart command will complain that the partition is corrupt. it is not corrupt. gpart by default puts a copy of the partition table in the last sector of the physical device, which will likely be different from the size of the iso you just copied onto the usb “stick”. since it can’t find that copy at the end of the iso file, it thinks it is not there. don’t worry about it.

you now can use the usb “stick” drive to boot the trident os. in my case i use another usb drive - a 500gb hard drive - as my root disk (i’ll call this usb “hdd”).

For an initial (bare metal) install, i have to select F12 to enter the boot menu and select the usb “stick” drive, not the usb “hdd”.

once i boot up, and begin the installation, i will see the usb “hdd” on the screen for disk selection. i select to use the entire disk for the install. i let the install complete and power down the system once it is finished. i then remove the usb “stick” drive, leaving the udb “hdd” plugged in. this will be my root drive.

i power back up, and normally, my system will recognize the usb “hdd” as a bootable root drive and boot trident.

hope this helps!
jim b.


#13

Thank you very much! I will try to do everything you told me. In bios I don’t have any option related to usb or legacy boot. It’s a very striped down bios.


#14

You say secure boot is disabled, but the screenshot you posted claims otherwise…


#15

good catch


#16

The screenshots were made before I started this topic and even with secure boot enable, on freebsd, I get the message “Secure boot fail”. On trident I can’t boot at all.


#17

Please trust me, I know what I’m doing :slight_smile:


#18
Do you have the latest BIOS?
<URL:https://www.acer.com/ac/en/US/content/support-product/7540?b=1>
John
groenveld@acm.org

#19

Yes I have, version 1.09. I check for new version almost every day.


#20
:( 
But I like your idea of returning for a different make/model.
Please let us know which one you get.
John
groenveld@acm.org