Upgrade Causes Trident 18.12 to Lose Monitor


#1

New install which appears to run well in all respects…however, when I triggered the update I lose the screen but it looks like Trident is running in the background???

I’m new to BSD generally so I don’t know how to effect a repair or ‘workaround’… it looks like I need to re-set the monitor settings…can someone show me how to fix this, please???..and perhaps some kind of patch may be needed in the upgrade process


#2
When you switch to the console virtual terminal with
CTRL-ALT-F1, does text appear on your screen?
John
groenveld@acm.org

#3

what is your video card? a dual-hybrid?


#4

I’m guessing that I am booting to the log in screen and the screen is black…
CTRL-ALT_F1 doesn’t help…nothing appears.


#5
On reboot, after the BIOS message, do you see the
bootloader?
And then do you see the boot messages?
John
groenveld@acm.org

#6

My card is an Intel Graphics media Accelerator X3100…nothing special!

Acer Laptop/Notebook…fairly old but modified…SSD, 2core CPU and @gb ram


#7

…no, I dont see anything…just the black screen…the drive light flickers suggesting all but the monitor is working.

…caps lock warning light can be manipulated


#8
Unplug the power.
Remove the battery.
Insert the battery.
Plug the power.
Power-up.
At the Boot Menu, boot single-user.
John
groenveld@acm.org

#9

Thanks John, can you give a hint of where this is going…after all I had Trident going well…suggest that something got mucked up developers end cos things stopped working after the upgrade.

Think I’ll just reinstall, not do upgrade and wait for the developers to get it right…if it isn’t right next time we have an upgrade i’ll give it away
…unless you or somebody else have an answer!


#10
My WAG is that 18.12u1 includes an Xorg driver that
breaks your video.

By booting single-user, you should be able to...
1. mount the BE
2. obtain the xorg.conf in /usr/local/etc/X11/xorg.conf
3. obtain the output of "about"
4. disable pcdm
5. cp /usr/local/etc/X11/xorg.conf /etc/X11
6. adjust /etc/X11/xorg.conf to alternative Xorg drivers
7. test with start-lumina-desktop

You could also mount the BE and then beadm activate
your previous BE.
John
groenveld@acm.org

#11

Did as you suggested but /usr/local/etc/X11/xorg.conf
…shows as no file so couldn’t proceed

OK to boot to previous BE


#12

@John…After a lot of fumbling and bumbling on my part I finally learned how to use your instructions properly…and things are working again,… many thanks!


#13
Before you apply update 2 or higher, please post the output
of "about" and the contents of xorg.conf
John
groenveld@acm.org

#14

The whole point of our exercise was to get ‘update 2’ installed and running so I could continue using Lumina…so the first thing I did was install u2 to test if I had video.


OS Version: 18.12-RELEASE-U2
Build Date: 20190128014316

…happy to send current version…let me know.
…I guess I can select the prior in BE if that would help?


#15
Congrats!

The output of "about" and the contents of your xorg.conf
would still be interesting.
John
groenveld@acm.org