UNSTABLE 10/16/2017 Radeon 5000 Graphics Card Now Working!


#1

Radeon Graphics Card (5000 series) now seen and working in Unstable version 10/16/2017.

Graphics perfect.

Some odd things:
Sound working via my Internal ALC 662 chip but selection is stuck on R6xx HDMI.
I don’t have speakers on my monitor so I get video via HDMI (working fine)
but sound needs to go to speakers connected via green plug in front of computer.

If I click on the Speaker icon in the lower right corner of the screen and try to select
Realtek Analog 2.0, it just ignores my selection. Couldn’t find any other way to change it,
but sound seems to be working at least in Firefox. (Not in Qupzill, but who uses that piece of junk anyway ?)
Also can hear sound gongs at startup and shutdown OK.

Did updatemgr pkgupdate after install but something odd happened, it seems that App Cafe no longer has any apps in it. Did the Unstable repository get changed or something ? But from command line I did pkg install firefox no problem. Ooops, just checked AppCafe, now everything’s back.

One other odd thing, somewhere during the automatic reboot after the system update, it appears my selected network connection was lost and somehow it got stuck on xfinity wireless (the area wide connection). I couldn’t change it back to my wireless until I deleted my entry and then re-entered it and rebooted. (Or was that Xfinity quietly getting hold of my local password so they can “route” stuff though my privately purchased cable modem ?)

Please don’t redirect old PC-BSD forum messages to the trueos.org site, there’s a lot of good information still valid in that forum and I have to use google cache to read it.

Please don’t pop up Facebook login or sign-in requests from this page.

Keep up the great work !!!

THANKS AGAIN !!
J


#2

look on bottom tray for the speaker. left mouse button and change output to what you want.

are you using UNSTABLE? It sounds like you are. In a terminal run --> sudo pc-updatemanager confcheck && sudo pc-updatemanager syncconf

and then try checking for updates.

Did you let it reboot twice, which is the norm now?

as for losing network, not sure…


#3

Sorry for ambiguous Title…I meant I’m trying the Unstable 10/16/2017

I have Stable installed on the other disk but I was hoping that Unstable would
recognize my video card and it did.

No, did not know about the need for two reboots !
Eventually things started working after I did that.

Sound seems to be working but when I try to change it as per the bottom tray for the speaker,
left mouse button, it refuses to change and stays stuck on R6xx HDMI.

Time still wrong as with Stable so I’ll put the openntp line back into /etc/rc.conf.

Tried to install openarena game, it looks like its installing it but then, nothing, it’s not there.
Tried from command line too. Seems like it installed, no error messages but
doesn’t see it when I type “openarena”.

Otherwise looking great. Huge file copies going fast and smoothly.

Oh…one other thing… I get some message something like “bad pad in top view” at boot up right after
I type in my geli password to unlock the disk. What does that mean ? It appears every time.
Same message appears in Stable at the same point in startup too.

Thanks !!
J.


#4

glad letting it reboot twice helped. it became a necessary evil when FreeBSD changed ABI’s earlier this year

not sure where the sounds modules are installed/ Maybe someone else can point to that? in a terminal, type --> pkg info | grep pulse

what does it show?

As for time, I use the “date” command to get it close and then the system can keep it on track.

With your GELI command, I know you are on a BIOS system. geli is still broke using UEFI (FreeBSD ‘path’ in review for 8 months)


#5

[jimserac@trueos-2757] ~% pkg info |grep pulse
pulseaudio-11.0_1 Sound server for UNIX

Thanks
J.


#6

“A” solution is to install pavucontrol, and set your output device there


#7

Thanks, I will check into that.

So far as I can see so far, my file archiving and huge folder store and copying problems have now been essentially solved by TrueOS. Good name change by the way, I never liked the name “PC-BSD”.

Again, thanks !
J.


#8

Hello!

The accurate time is very important on the network (for example Man in the middle attack). You have to edit your ntpd.conf files:

/usr/local/etc/ntpd.conf
/usr/local/share/trueos/conf/ntpd.conf

The default setup in TrueOS is randomly choose one of time server from the servers pool.ntp.org under the boot process. But to be connected for the network under the boot process is not really safe, better to connect for the web if the system already ready.

This is the default setup in TrueOS:

use a random selection of NTP Pool Time Servers

see http://support.ntp.org/bin/view/Servers/NTPPoolServers

servers pool.ntp.org

You have to give a comment (# ) for this line:

servers pool.ntp.org

After go to the website of the pool.ntp.org (http://www.pool.ntp.org/en/) and search, I think minimum 5 maximum 7 different time servers (near for your home) and give for your ntpd.conf files and uncomment this line “listen on *” so for example:

Addresses to listen on (ntpd does not listen by default)

listen on *
server 0.hu.pool.ntp.org
server 1.hu.pool.ntp.org
server 2.hu.pool.ntp.org
server 3.hu.pool.ntp.org
server 0.at.pool.ntp.org
server 1.at.pool.ntp.org
server 2.at.pool.ntp.org
server 3.at.pool.ntp.org

After, if you are already online (connected for the network) from terminal as root:

ntpd -s

Sorry, because my english :frowning: and sorry I don’t understand why wrote some line with big characters and why missing the “#” character :frowning: I still have to practice the usage of this word processor :smile:


#9

Thanks ! and, by the way, your English is fine.

Ya, I had the same problem, giant characters sometimes when posting some config files.

Don’t know how much accuracy you need but for me,
just putting the following line:

openntpd_enable=“YES”

in my /etc/rc.conf file

give me the correct current time.

Thanks again,
James


#10

Pavucontrol was already there and I selected the front (ALC 662) built in speaker interface and sound is working fine in everything except Qupzilla. I don’t use Qupzilla so no problem.

Thanks again,
J.


#11

Happy to report that my FirePro/radeonian is working here as well despite goofy video driver, but in a stable env. Since I’m unstable, I seldom choose anything in unstable condition. I hope that everything will hold stable until the next stable update - lol

FreeBSD rodak 12.0-CURRENT FreeBSD 12.0-CURRENT #66 ac2f0aa3b(trueos-stable)-dirty: Wed Jun 21 01:09:23 UTC 2017     root@gauntlet:/usr/obj/usr/src/sys/GENERIC  amd64

System information:

Manufacturer: Dell Inc.
Product Name: Precision M4600

Base board information
Manufacturer: Dell Inc.
Product Name: 08V9YG

Graphic card information:                                                                                            
vendor='Advanced Micro Devices, Inc. [AMD/ATI]'
device='Whistler [Radeon HD 6730M/6770M/7690M XT]'

I rly don’t like laptops, but this one is an exception which shows that if all else fails, TrueOS can sometimes make it work with no logic and automagic - heh :))