Unmirror and then remirror


#1

Haha, I’m having fun with ZFS but am stuck and cannot find any proper references that shows the way out.

I decided to unmirror a mirror so it can be wiped and put back with a fresh format.
zpool split tank1 tank2

Which does not appear the be the way to go, digging a deeper hole I imported tank2 to tank1 which caused the ZFS lib to be lost. With an unstable system I rebooted with ada0 removed.

zpool now shows tank2 (exported) online and I can’t get anywhere.
tank2 has the previous suspect ada0, which is now ada3 with ada3p2.

The Disk Manager shows it dimmed as exported and online. :slight_smile:

Once off line I would destroy the old ada0 (now ada3) and use gpart to backup and restore from ada1 (the known working boot drive).

But I need a pointer to how to solve this if someone wants to help…

Edit:

OK, I booted off the DVD and sorted it out in a terminal which was much easier.
I got further than I’ve ever gone with ZFS and had a lot of fun especially with not loosing data while accidentally striping and then remirroring. (Gotta pay attention when using the GUI tool, I thought the one drive was a mirror but I had split it which made it not be part of a mirror anymore.)

I really appreciate the Installer’s options which makes it easy to work offline with the drives. (It’s hard to modify drives/pools that are in use.) :slight_smile:

Having mirrors certainly saved the day, ZFS on mirror is a great combination. (And of course that is no replacement for backup as many of us have seen more than one drive die at the same time.) Love to have the time to really play with the abilities of ZFS.

Having had some odd behavior on my O/S mirror since I originally installed a year ago I decided to reinstall and lo and behold I now got things such as autoloading of USB devices which never worked earlier. That alone made the whole extra time to reinstall all appl worth while.

Though with the nvidia driver (latest from DVD) I still cannot leave X and have legible terminals (just some thick vertical colored lines instead of text).

[I can see why nobody responded to what looked like a big mess.] :slight_smile:


#2

I would have responded, but was busy cutting down trees.

nvidia and text consoles after leaving X: search on posts by me, there is a tunable you can put in /boot/loader.conf that forces the console to use text mode instead of graphics mode that corrects that.


#3

hw.vga.textmode=1?

Maybe just try other mode/resolution:
gop set <mode number>
or
kern.vt.fb.default_mode=1368x768

gop list in loader cmdline provides a list of available modes, but probably works in UEFI only.


#4

Yep, I think that’s it.
It’s actually a bug in the nvidia driver blob itself; when it comes out of X it’s not resetting something correctly. Been that way for a long time, I don’t think I’ve ever seen a gop set or the kern.vt.fb.default_mode work.


#5

YAY! It worked (adding hw.vga.textmode=1)!

I had a few other lines of which neither worked:
kern.vty=vt
hw.vt.fb.textmode=1
kern.vt.fb.default_mode=“1920x1200”

After getting a clean O/S install where All things works as expected and now able to use tty as well. You guys made my day! Thanks!

@mer, I’ve been busy on our farm as well, I’m building a solar farm, which unlike 80%+ of US installs is a hybrid system, meaning it can work on and off-grid and even fire up a generator when it needs to. It scales from 5kW to 100kW. (We only have a 5kW capacity right now.)

We teach something called permaculture which stands for permanent culture. A technology that is not only sustainable but also regenerative. It has brought some interesting concepts which applies really well to computers, f.ex: whole system design. You don’t do anything without considering how it impacts everything connected to it. Every design should take everything that can be affected into consideration. You don’t install a tree, or an orchard, without seeing how it affects and works with everything else around it. Same thing with installing an application or computer, one should see how well it integrates and what liabilities etc it has. It’s interesting how so disrelated things works so similarly.

For some time now I’ve been using SmartOS on servers and I have TrueOS as my desktop. It used to be all Linux but I dropped it to get into ZFS and then BSD. (Just because I became a grower/teacher does not mean I have to give up technology! :slight_smile: )

This forum is a great representation of how people can come together and help each other! In permaculture you share, not unlike open source. We are actually standing shoulder to shoulder and are all stronger for it. Pretty neat!

I’d better get off my soapbox now, thanks again!