Unable to get a graphical user interface after installing Trident!


#1

You know when you are going to install Trident, you know how it gives you a bunch of programs you want to install, by default it did have nVidia -> Latest graphics drivers selected. My Graphics card is nVidia GTX 260. Does this have to do with any broken graphical issues?

When I boot into Trident, and I logged in this is what I see.
image

I did run rc-status and pcdm does appear to have started
image

I ran startx and this is what I see.

image

And when I press Control-C to end the program this is what I see.
image


#2

I don’t know if this helps, but I had similar problem installing Trident. In my case, there was graphical distortion during the install, so I could not see what I was doing. I solved it by removing my video card, and just using the onboard graphics, which were also Nvidia. This allowed me to install successfully (no graphical distortion). Once up and running, I installed driver 340 (an older driver which usually works) from App Cafe, shut down, put the dedicated video card back in, and on restarting, Trident recognized the drivers and is now using the card.


#3

@mdiemer that’s a good tip. Go to nvidia.com, drivers, all drivers and you can search by product and OS.
For the GTX260 it looks like FreeBSDx64 is version 340 which is “pkg install nvidia-driver-340”
so the installer “latest driver” was not correct.
It looks like the OP can be at the command line so log in, become root (sudo or su) and “pkg info | grep nvidia” you probably see something like nvidia-driver-390.87_2
If you do, then “pkg delete nvidia-driver-390” and “pkg install nvidia-driver-340” and see if that works. You should probably reboot after doing the pkg install nvidia-driver-340


#4

So I did uninstall nvidia drivers pkg delete nvidia-driver-390.87_2 but I could not install the other nVidia drivers pkg install nvidia-driver-340 that didn’t work as I can’t connect to the Internet for some reason.

So I did restart and the DE is now showing up but it doesn’t fit the screen properly, obviously I need to install those drivers but I can’t since I don’t have access to the Internet any idea how to resolve this?