Unable to connect to the Internet


#1

My current wifi USB adapter is D-Link DWA-125 and I have tried using my phone as the wifi adpter (on Android you can go to usb tethering and use your phone as the source of Internet connection) and neither seem to work.

I tried using the web browser, terminal to install packages, nothing works.

Any suggestions?


Unable to get a graphical user interface after installing Trident!
#2

does the adapter work?

open a terminal ant type --> sudo sysctl net.wlan.devices

does it return anything or a blank screen?


#3

Yes it perfectly works on Windows (provided that you have the correct drivers installed) and on any Linux distro without any additional configurations.

On Trident, the light on the wifi adapter does flash but if you physically reconnect it, then it will not light up at all.

Yeah it returned net.wlan.devices: run0. (note I did not physically reconnect the device before running that command).


#4

this is NOT windos or linux. Just because it works there DOES NOT mean it’ll work here.

Have you started the “Network Manager” and configured the WiFi device?

start menu -> (type Network) select Network Manager, configure your wireless device


#5

add this line to your /etc/rc.conf,

if_urtwn_load=“YES”

Delete the run0 line

save and restart.

edit:
write it down somewhere in case you want to put that line back in.


#6

I did that and it works, thanks for your help.

Although the problem is that if I were to physically reconnect the wifi device, it will not light up and can’t connect to the Internet, nor it will appear in the network manager.

On the bottom right hand side which displays the network status, I did open it and disabled the wifi adapter from there and then re-enabled it there and it does light up but still can’t connect to the Internet.


#7

If I added this line, can I physically reconnect the wifi device without it not working?


#8

So I did add that line and rebooted. The wifi device does work, but the issue is that if the wifi device was disconnected from the PC, and then connected again, it will not work, any ideas how to solve this?


#9

So you can connect to the internet now?.. Also the easiest way to solve that problem, is to not disconnect it :thinking:… The other idea I have is that you might have two Wi-Fi devices. An internal one that doesn’t work with BSD and an external one that works with BSD… @RodMyers can correct me if I’m wrong, but I think your internal one is taking preference over the external one, disabling the internal Wi-Fi device should give preference to the external one.

Another idea I just had is that you can also run

rc-service network restart

after you plug in your device, but I’m not sure how in/convenient that would be for you.


#10

Sounds like it