U5 package dependencies for Epclipse [solved]


#1

Hi there,

are those package dependencies correct?

sudo pkg install eclipse                                                                                                                                           
Updating Trident repository catalogue...
Trident repository is up to date.
All repositories are up to date.
The following 64 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
        eclipse: 4.6_2
        libgnome: 2.32.1
        libsunacl: 1.0.1
        cmocka: 1.1.1_1
        py27-dnspython: 1.15.0
        tevent: 0.9.37
        talloc: 2.1.14
        py27-iso8601: 0.1.11
        libinotify: 20180201_1
        jansson: 2.12
        gamin: 0.1.10_10
        tdb: 1.3.16,1
        libarchive: 3.3.3,1
        lzo2: 2.10_1
        samba47: 4.7.12
        rarian: 0.8.1_4
        docbook-xsl: 1.79.1_1,1
        docbook: 1.5
        sdocbook-xml: 1.1_2,2
        docbook-xml: 5.0_3
        xmlcharent: 0.3_2
        docbook-sgml: 4.5_1
        iso8879: 1986_3
        getopt: 1.1.6
        gnome-mime-data: 2.18.0_5
        libbonobo: 2.32.1
        gnome-vfs: 2.24.4_10
        libgnomeui: 2.24.5
        libbonoboui: 2.24.5_1
        libgnomecanvas: 2.30.3_4
        libart_lgpl: 2.3.21_3,1
        libgnome-keyring: 3.12.0_2
        gnome-icon-theme: 3.12.0_1
        gnome-icon-theme-symbolic: 3.12.0
        gvfs: 1.30.4
        libcdio-paranoia: 10.2+0.94+2
        libcdio: 2.0.0_1
        hal: 0.5.14_34
        policykit: 0.9_10
        dmidecode: 3.2
        libvolume_id: 0.81.1
        gnome-mount: 0.8_13
        policykit-gnome: 0.9.2_8
        gnome-doc-utils: 0.20.10_5
        py27-libxml2: 2.9.8_1
        gettext-tools: 0.19.8.1_1
        libnotify: 0.7.7_1
        gcr: 3.28.0
        gnome-online-accounts: 3.28.0_1
        webkit2-gtk3: 2.22.5
        enchant2: 2.2.3_3
        geoclue: 2.4.7
        woff2: 1.0.2_3
        brotli: 1.0.7_1,1
        rest: 0.7.93
        libsoup-gnome: 2.62.3
        libgphoto2: 2.5.16
        libexif: 0.6.21_4
        libgdata: 0.17.9
        liboauth: 1.0.3_4
        webkit-gtk2: 2.4.11_19
        openjdk8: 8.202.8
        javavmwrapper: 2.6
        java-zoneinfo: 2018.i

Number of packages to be installed: 64

The process will require 873 MiB more space.
375 MiB to be downloaded.

Proceed with this action? [y/N]:

Compared to https://www.freshports.org/java/eclipse it seems way over the top. Shall I report it as bug? Or am I missing something?


#2

very well could be dependencies.

mine shows:

sudo pkg install eclipse
Password:
Updating Trident repository catalogue…
Trident repository is up to date.
All repositories are up to date.
The following 1 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
eclipse: 4.6_2

Number of packages to be installed: 1

The process will require 217 MiB more space.
192 MiB to be downloaded.

Proceed with this action? [y/N]:

but i have a few other packages installed, and no idea what linux stuff they brought in.

did you notice that this package has an expiration date? At the end of March, it may be removed


#3

FreeBSD ports search, take a look at the dependencies.
https://www.freebsd.org/cgi/ports.cgi?query=eclipse&stype=all&sektion=java


#4

Thanks! No FreeBSD past from my side, I’ve still got to learn all the tools and where to look.


#5

Not a problem, we all were there once.

Starting here or on the trident telegram channel is always a good starting point.