Trying to boot TrueOS/FreeBSD on a Minix Z64


#1

Hi. I am trying to boot TrueOS/FreeBSD x86_64 on a Minix PC, model Z64 (4 Intel core CPU, 64 bits). This PC has 32 bit UEFI firmware. So i have installed Grub 2 on the Pendrive to boot.

While trying to load the FreeBSD kernel, it does not show video output (it is hdmi). Tried some resolutions from grub cli and the issue is similar.

On linux, the command to workaround the issue is “intel_iommu=off”. Is there a similar boot option on Freebsd?.


#2

What image was burned to the USB device? Was the the ISO or the IMG? The ISO is for a CD/DVD, the IMG is for burning to a USB drive.
The part about “installing grub2 on the pendrive to boot” is odd/confusing.
The TrueOS IMG format you just use dd to put it on a device (not the partition) and it should be bootable. Is that what you did?


#3

I burned the TrueOS-Desktop-17.12-x64-USB.img to an USB Pendrive via dd ; from a linux machine added another partition (FAT32) to the pendrive. Then installed grubia32.efi on that partition.

When i try to boot the pendrive on the Minix PC, Grub 2 CLI appears; i exec

root=(hd0,gptX)
kfreebsd /boot/kernel/kernel
boot

it shows a black screen, and reboots.


#4

GPT-disk or MBR-disk?

Boot the loader, not the kernel.


#5

The scheme is GPT disk. I try to boot kernel directly from grub because loader is 64-bit and the uefi in Minix PC is 32-bit.


#6

Did You try to GrUB-chainload: BOOTX64.EFI in the TrueOS-ESP-partition?

Don’t know, if You need “BOOTX32.EFI”…

Are You booting GrUB itself in EFI mode?


#7

I am booting Grub itself in efi mode (32 bit). I need to test what exactly happens when booting with bootx64.efi.

Update

Tried chainloading bootx64.efi and and when exec boot command, it shows: error: unknown error


#8

When booting efi-grub itself, is the pendrive GPT formatted?

Has it its own ESP?

If yes, how is its own efi-file called? “grub.efi”, bootx32.efi, or something else?


#9

Maybe, this helps:

Booting 64-bit kernel on 32-bit UEFI
https://wiki.archlinux.org/index.php/Unified_Extensible_Firmware_Interface#Booting_64-bit_kernel_on_32-bit_UEFI

Edit:
And -while there- also read this section:

UEFI boot loader does not show up in firmware menu
On certain UEFI motherboards like some boards with an Intel Z77 chipset,…This issue is caused because the motherboards can only load Microsoft Windows. To solve this you have to place the .efi file in the location that Windows uses.


#10

I sucessfully booted FreeBSD/TrueOS on the Minix z64. I recently flashed the BIOS to android version (before, it had windows 32 bit bios version) and works as expected.

Thanks anyway