TrueOS - News, How to do ... etc


#13

Hello All!
I want to find out if anyone is using any options in the make.conf file, using TrueOS just as a desktop user system (non as programmer, non as tester). I mean the optimization for building programs from ports, as I have in FreeBSD. For example, do you need set to default the version of Perl, Linux_base, etc.
Thanks.


#14

in the TrueOS handbook, will explain using the FreeBSD ports system

https://www.trueos.org/handbook/trueos.html


#15

I don’t know if the handbook says this (yes, I’m being lazy and not reading it), but if you git clone the https://github.com/trueos/trueos-core and cd build-files/conf/desktop you’ll find “port-make.conf” which has the default values that are being used to build the packages.


#16

Maybe I was misunderstood. In handbook general information that, where and for what,
I’m interested in the state of make.conf (by default it is empty). Whether there is a sense to fill it, that the system was guided with what version to compile this or that software. It’s just a matter of knowing, not a snob.
I deal with ports in FreeBSD and how they meet, where you can see the dependencies - that I know. TrueOS is something new in my practice and the information of handbook is not enough.
In the community, this question seems to be raised for the first time.


#17

for you, all the handbook will do is tell you how to get the ports tree, using TrueOS as the base, not FreeBSD

In particular, which port has no makefile?


#18

Please note this was only a question, not a claim to the TrueOS guru.
From the ports I was assembled to anything, without “tuning”, with the exception of the linux-telegram-desktop, which during the installation of linux_base-c7
Fail to rename /compat/linux/.run.AQ9CREuyQhC4 -> /compat/linux/run:Is a directory
And the linux_base-c7 is not installed either from ports or via AppCafe.
And with the previous version there are no problems (through ports or AppCafe). But due to the conflict, as well as the dependence on the linux_base-c6, I stalled in this moment. To say that this is critical for me is not so. But my knowledge is clearly not enough to resolve this issue.


#19

I pointed out the trueos-core git repo that contains items used when packages and distributions are built. As part of that, there is a file named port-make.conf which if one looks at it, contains values that can be put into the standard /etc/make.conf to build the packages the way that the distribution does.
If you want ports built as the packages are, you should probably git clone the trueos-core repo and at least look through it because it has a lot of the configuration and scripts used to build a distribution.

If this does not at least partially answer your question, then I’m sorry, I don’t know what you want.


#20

Thank you. You gave the most comprehensive answer.
I heard and understood you.
Thanks again.


#21

As to this specific issue, it seems to be a bug in the update process /compat/linux/run should be a symlink to /var/run, but when a new boot environment is made, it becomes a real directory and it messes up installing a new linux_base since the old removal of linux_base doesn’t clean up the directory (it only tries to remove this symlink).

I wrote up a bug for this a while back. I’m not sure there is an easy fix, but you can work around this by removing /compat/linux and installing the port again.

Hope this helps!


#22

I tried to delete these temporary directories, when the installation is repeated, an error appears again with a link to the new temporary directory (new name).
Reinstalling this port or reinstalling from AppSafe does not help either. I understand that this problem revolves around the Linux emulator, but my modest knowledge is not enough to solve the situation.
On an unstable TrueOS version it works. Wait, it’s not critical for me.
Thank you for your attention.


#23

Specifically tells you how to install linux-telegram-desktop


#24

Irumbumoideen

When I encountered this problem, I found this post and in the previous one I already described that I deleted these “symlinks”. But something went wrong … it happens …


#25

If you’re on unstable, the FreeBSD desktop client is available


#26

I made that post specifically to deal with the problem you seem to run into. Specifically,

Only remove these symlink files, not the directories they point to. Don’t rmdir or rm -rf. Just

rm /compat/linux/run

and so on.


#27

And so, the situation is the following. From the command line “rm /compat/linux/run”, an attempt is made to delete the directory of run and the system does not allow it to be done (which by the way was described in the installation guide in TrueOS Community). During the installation from AppCafe, the directory of run
remains empty, and what should have been installed or compiled in it was moved in the form of a symlink to the “/compat/linux”. I thought, since the catalog of run (0755; root/wheel) is empty, then removing it through the Midnight Commander, I will not lose anything. After deleting the directory of run, the installation of linux_base-c7 started and ended successfully: linux-c7; linux_base-c7; linux-telegram-desktop. The catalog run became a symbolic reference of run.

On the desktop appeared a shortcut with an unusual icon, in the form of an executable file, but name of Telegram Desktop. At startup received a list of errors (see screenshot).

While I was making a screenshot, it looks like the graphics shell (GUI) has fallen out. This I have had before, I sinned at a somewhat braked Firefox. I looked in the log files, found the following:

kernel: in_scrubprefix: err=51, prefix delete failed
trueos-ua anacron[13972]: Anacron 2.3 started on 2018-03-16

trueos-ua anacron[13972]: Will run jobdaily’ in 5 min.trueos-ua kernel: pid 3051 (PCDM-session), uid 0, was killed: out of swap space`

trueos-ua kernel: pid 3120 (fluxbox), uid 1001: exited on signal 10
trueos-ua kernel: composite sync not supported

trueos-ua last message repeated 4 times

Perhaps, the hardware of my laptop Dell Latitude D830 is old for these exercises, but, nevertheless, I see the progress of installing on Raspberi from my compatriot, I do not lose hope :slight_smile:


#28

You might have to run it with sudo :frowning: Other than that I have no more suggestions.


#29

It’s okay, do not worry.
If it was critical, I would not find an ordinary solution, right up to running the program I need on another device. And so, get acquainted, look closely, draw for myself some conclusions.
Impressive frequent updates on this OS, it is clear that the work on it is being done without rest.
This is positive, I believe in you.


#30

I tried the command and I don’t get any results. Also, what does the -k option mean? Thanks.


#31

“man man” should help :slight_smile: -k means “keyword search” man -k intro means search the man pages for the keyword intro then pipe that output into a grep command and search for lines that start with the letters intro (the caret, Shift-6, is an anchor for grep that means beginning of line)


#32

My respect to the developers of this wonderful OS.
After the upgrade, until TrueOS 18.03, the Telegram-Desktop was installed without errors.
Admired by your professionalism, good luck to you!