TrueOS Freezes On Boot After Install


Hi. I just discovered TrueOS, and it looks a really good system. I would really like to use it. I downloaded the DVD image, burned it on a DVD and installed TrueOS on my main laptop (Acer Aspire V3-472P) in UEFI, secure boot disabled. It is in dual-boot with Windows 8.1. The installation went successful. After it, the setup asks me to reboot. I reboot, choosing TrueOS in the boot manager. It loads a lot of things, but after the step where many lines show up followed by “ok”, always under “Starting NFS Automount Client…” followed by “ok”, a line appears. It says “Mar 12 14:22:40 dhcpcd[933]: timed out”, and nothing else happens. I reboot, and at the same place, the same thing happens, but with “Mar 12 14:25:46 dhcpcd[931]: timed out”. What could be the problem ?

I tried to install TrueOS on 2 other laptops, on VMware and on VirtualBox, and I get multiple problems (on one laptop, Acer Aspire 5720Z, the screen resolution is set at 1024 x 768 instead of 1280 x 800, on another one, Acer E1-531-4619, some apps, like AppCafe and Control Panel just don’t open, not to mention that TrueOS detects my WLAN card and successfully connects to my Wi-Fi but doesn’t give me Internet. On VMware, the screen resolution is not correct, and finally, on VirtualBox, even if it worked with the desktop the first time, when I shut down the VM because I had to reboot my real computer, when I booted the VM, it closed and Windows 8.1 tells me "Instruction at 0x81eafcbb referenced memory at 0x00000008. The memory could not be read. ". The first value changes when I retry, but not the second one. I even rebooted my real laptop again and the same error appeared.).

What could I do ? I just want a working TrueOS installation… Thanks for your help, if there’s anything to do… I would prefer it on real hardware though… :cry:


virtual installs are always tricky

an idea, search through here, and see how to install on a flash drive. will not be perfect, but will give you a chance to try it out


Okay, thank you @RodMyers, I will try this tomorrow. :smiley:


I tried installing it on a flash drive this morning, but 1 hour later, I had to give up, because the installation had not started installing packages and was still extracting files. I had no time remaining and had to leave home… An install has never taken so long for TrueOS. I know that a flash drive is not as fast as a HDD, but if it takes so much time to install, imagine how buggy will be the OS while running…


I deleted TrueOS from my Acer Aspire E1-531 and installed it back. All applications open. I still had this Wi-Fi problem once on the desktop. I set up manually the IP address. When I rebooted, I had Internet. It is now working perfectly. Thanks TrueOS ! Screenshot-2018-03-16-06-07-35