Trueos 18.03: open wiffi network don't reconize


#1

Hi every one!
i am new on trueos and i have a big problem for networking connection

i use a public wiffi network “Freewiffi” , the wiffi manager find it but ask me wpa key information

so how i can use public wiffi?

thank for answer and sorry for my english, i am french!


#2

I’ve never tried TrueOS box on public wifi… however, from the handbook

  • Disabled: If the network is open, no additional configuration is required.

#3

If Your “open” access point asks for a wpa-password, then Your “open” network isn’t open.


#4

thaks you,
and that the worst part this network is “disabled” because i use it everyday with my ubuntu before
maybe it’s a bug from the wiffi manager?

anyway i will retry latter, i dont give up !


#5

Your description is insufficient.
More details, please.

Example:
When I go to my favourite hospital, I want to join their WiFi network…


#6

i am client of “Free”, it’s a Internet access providers in france.

they have a service call “freewiffi” , it’s open, you are redirected to a captive portal where you type your custumer id and passeword.

the problem is there i can’t sellect this network because the wiffi manager ask me wpa information.

i don’t understand why


#7

What happened before, when You did it with Ubuntu?

In what location are You using this? On the street? In a public building?


#8

when i used whith ubuntu , it’s happend like i explain befor : until the network selected, ubuntu redirect me to a web page of free for login

i use this network in a disable center (i can’t wallk)


#9

I have a suspicion:

Maybe, the WPA-Password You are asked for by TrueOS, after having entered the Captive Portal data, is the combination of the NetworkName and the NetworkPassword.

Explanation:
You can login to a WPA2-WiFi network in two ways.

  1. NetworkName (ESS) plus Password.
  2. HexKey: This is a combination of the network name and the password rolled into only one single hexadecimal number.

I think it possible, that TrueOS asks for this (My number 2). If this is true, only one of the developers can help.

I’d try to send a bug report to TrueOS.

Edit: You could compute the hex-key yourself, and try it. There are programs to compute it, downloadable from the internet.


#10

If Your Captive Portal opens within a browser, You could check, whether JavaScript is allowed or forbidden. And check Cookie-permissions.


#11

thank you all for your answer!

i have solved my problem!

first, i did a new fresh install of true os from the dvd
after i launch the wifi configuration, i take my “freewiffi” and push the +ad selected, then apply, then edit choice disable in the “network security” item,then apply again.

to be sure it’s work i launch firefox, and yes i am redirected to the captive portal!

it’s good when it’s work!

thank you all again!!