TrueOS 18.03 nvidia frustrations


#1

I am not a regular Linux or FreeBSD user. But I wanted to see how TrueOS compares against Linux Mint. Unfortunately I cannot get the nvidia drivers to work with my triple screen setup.

I have installed the nvidia driver using the select at installation route, by appCafe, and by pkg install. It is not possible to change the driver at the log in prompt. The error given is that nvidia is already part of the kernel and cannot be loaded.

If I try nvidia-xconfig from root I am left with a system that leaves me at a text based login.

To get out of this I have to delete xorg.conf.

Attempts at using nvidia-settings always says that I am not using the nvidia driver.

I have tried editing /boot/loader.conf with

nvidia_load=‘YES’

and nvidia-modeset_load=“YES”

to no avail.

After running nvidia-xconfig if I try startx then I am told that there are no screens configured.

Would someone be kind enough to point me to a definitive set of instructiuons on how to get the nvidia driver working.

Thanks in advance


Nvidia Gforce GTX 1050ti
#2

PS

My system is i7-4770k
Z87 chipset
GTX 1080


#3

Have you selected the correct nvidia driver? ob FreeBSD, nvidia has 2 different driver. older, old, and newer.


#4

I’m using nvidia-driver. Not either of the two older ones.


#5

making sure that you grabbed the correct driver series.

Been a known issue in the past


#6

Sorry for not being clearer in my original post


#7

not a problem. things happen,

have you gotten to a login prompt yet?

If you can get to a root login prompt, try uninstall and then re-install the driver from the root terminal, and see what it spits out. I don’t own any nvidia cards, so…

Here is the freshport list for nvidia

https://www.freshports.org/search.php?query=nvidia&search=go&num=10&stype=name&method=match&deleted=excludedeleted&start=1&casesensitivity=caseinsensitive


#8

I’m assuming that you did instal the latest Nvidia’s-Offical driver:
"nvidia-driver" which refers to the latest 390.25 version in FreeBSD repos from “AppCafe” or “pkg” install.
If I remember correctly, the driver installation should also update/add to /etc/rc.conf the following entry:

kldload_nvidia="nvidia-modeset nvidia"

If not add the above to /etc/rc.conf

After installing the driver you need to reboot the system.
Then, as sudo or su, run “nvidia-xconfig”

Reboot the system again.
Then, as sudo or su, run “nvidia-settings”

In the nvidia-settings GUI util use the X Server Display Configuration options to set the display.
While in this menu options use the “Save X Configuration File” tab to save your setting(s)
Deselect the “Merge with existing file” option while saving the new “xorg.conf” with the nvidia-settings GUI uitl

I use nvidia-driver, but the older version, so I don’t know if anything changed in installation of the newest Official Nvidia driver

Edit:
Just noticed that “nvidia-xconfig” and “nvidia-settings” in the current pkg repos are still version 384.*
Don’t know if that may cuase some issues with the newest nvidia-driver 390.* :frowning:


#9

I started yet again with a clean install of TrueOS

No nvidia driver during the installation process
Skipped the graphics driver part during the first boot wizard

all steps below done as root

Installed nvidia-driver, nvidia-xconfig, nvidia-settings
used the most current driver (pkg install nvidia-driver)

nvidia-modeset nvidia = nvidia is present in rc.conf

Reboot

message that kdl loader cannot load nvidia module as it is already installed in the kernel

reboot

try

nvidia-xconfig

complains about undefined monitor but created an xorg.cong

reboot

No graphical loging, just command line. This time deleting xorg.conf does not restore the graphical login after a reboot

startx doesn’t start the X-server complaining there is an undefined monitor


#10

FreeBSD Display Driver – x64

Version: 396.24
Release Date: 2018.5.2
Operating System: FreeBSD x64
Language: English (US)
File Size: 58.02 MB

for:

GeForce 10 Series:

GeForce GTX 1080 Ti, GeForce GTX 1080, GeForce GTX 1070 Ti, GeForce GTX 1070, GeForce GTX 1060, GeForce GTX 1050 Ti, GeForce GTX 1050, GeForce GT 1030

GeForce 10 Series (Notebooks):

GeForce GTX 1080, GeForce GTX 1070, GeForce GTX 1060, GeForce GTX 1050 Ti, GeForce GTX 1050

And also this:

Version: 390.67
Release Date: 2018.6.5
Operating System: FreeBSD x64
Language: English (US)
File Size: 60.66 MB

for:

GeForce 10 Series:

GeForce GTX 1080 Ti, GeForce GTX 1080, GeForce GTX 1070 Ti, GeForce GTX 1070, GeForce GTX 1060, GeForce GTX 1050 Ti, GeForce GTX 1050, GeForce GT 1030

GeForce 10 Series (Notebooks):

GeForce GTX 1080, GeForce GTX 1070, GeForce GTX 1060, GeForce GTX 1050 Ti, GeForce GTX 1050

Available:

$ pkg search nvidia
nvidia-driver-390.25           NVidia graphics card binary drivers for hardware OpenGL rendering
nvidia-driver-304-304.137      NVidia graphics card binary drivers for hardware OpenGL rendering
nvidia-driver-340-340.106      NVidia graphics card binary drivers for hardware OpenGL rendering
nvidia-settings-384.59_1       Display Control Panel for X NVidia driver
nvidia-texture-tools-2.0.8.1_9 Texture Tools with support for DirectX 10 texture formats
nvidia-xconfig-384.59          Tool to manipulate X configuration files for the NVidia driver

#11

pkg install nvidia-driver installs nvidia-driver-390.25 so I’m not sure what point is being made by the previous post.


#12

Those are the exact data needed to solve this problem. Feel free to ignore them.


#13

Sorry, my bad :frowning:

It’s nvidia-driver-390.25 as the complete name of the pkg, in my current TrueOS pkg repos - “I assume you figured that out”

In my FreeBSD jail it’s nvidia-driver-390.48 is the latest nvidia-driver pkg

So to install the OFFICIAL nvidia driver with pkg in TrueOS do:

pkg install nvidia-driver-390.25

Same goes for the driver config and settings, exact name of the pkg(s)

pkg install nvidia-xconfig-384.59
pkg install nvidia-settings-384.59_1

And, /etc/rc.conf should have this entry exactly as follow, with text in quotes as follow:

kldload_nvidia="nvidia-modeset nvidia"

Edit:

Could be that the driver does not support your GPU, yet.

Can you do VESA so you can get going and dump here some infos of your installation?
Many here could help you better with troubleshooting by seeing output from various parts of your system.


#14

You are correct.


#15

So,
http://www.nvidia.com/Download/driverResults.aspx/130649/en-us

the 390.25 should work with GTX 1080


#16

Try few of those to see what’s going on in your sys:

look@ /var/log/Xorg.0.log

Here are some of my outputs:

kldstat | grep nvidia
46    1 0xffffffff82b18000 a24190   nvidia.ko

dmesg | grep GTX
nvidia0: <GeForce GTX 260> on vgapci0


dmesg | grep vga
VT(vga): resolution 640x480
vtvga0: <VT VGA driver> on motherboard
vgapci0: <VGA-compatible display> port 0xdc80-0xdcff mem 0xf6000000-0xf6ffffff,0xe0000000-0xefffffff,0xf4000000-0xf5ffffff irq 24 at device 0.0 on pci3
vgapci0: Boot video device
nvidia0: <GeForce GTX 260> on vgapci0
vgapci0: child nvidia0 requested pci_enable_io
vgapci0: child nvidia0 requested pci_enable_io

glxinfo | grep GTX
OpenGL renderer string: GeForce GTX 260/PCIe/SSE2

/etc/X11/xorg.conf - as done by nvidia-xconfig and nvidia-settings

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 384.59  (root@builds.trueos.org)  Thu Mar  8 12:47:03 UTC 2018

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/sysmouse"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "DELL U2713HM"
    HorizSync       29.0 - 113.0
    VertRefresh     49.0 - 86.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 260"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "metamodes" "nvidia-auto-select +0+0; 1024x768 +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

#17

I missed that. I hope that you’re installing the OS and driver with 1 monitor first and then connect the other 2, if you have to.

I’m a poor-arse computer enthusiast, so I use 1 display with 3 different monitor ports connected to 3 computer systems, 3 keyboards and 2 mighty mice - lol


#18

Another fresh install. No drivers selected during installation.

In the first boot wizard I’ve tried both nv and vesa. Both failed to install so I eventually had to skip that step.

I installed nvidia-driver, nvidia-xconfig, nvidia-settings and nvidia-texture-tools from AppCafe.

Rebooted

During boot there is a message from kldload that it cannot load nvidia as it is already in the kernel

BEFORE USING NVIDIA-XCONFIG

kldstat | grep nvidia
46 1 0xffffffff832f0000 f18f9 nvidia-modeset.ko
47 1 0xffffffff833e2000 c3c4e8 nvidia.ko

dmesg | grep vga
vgapci0: port 0xe000-0xe07f mem 0xf6000000-0xf6ffffff,0xe0000000-0xefffffff,0xf0000000-0xf1ffffff irq 16 at device 0.0 on pci1
vgapci0: Boot video device
vgapci1: port 0xf000-0xf03f mem 0xf7400000-0xf77fffff,0xd0000000-0xdfffffff irq 16 at device 2.0 on pci0
acpi_video1: on vgapci1
vgapci0: port 0xe000-0xe07f mem 0xf6000000-0xf6ffffff,0xe0000000-0xefffffff,0xf0000000-0xf1ffffff irq 16 at device 0.0 on pci1
vgapci0: Boot video device
vgapci1: port 0xf000-0xf03f mem 0xf7400000-0xf77fffff,0xd0000000-0xdfffffff irq 16 at device 2.0 on pci0
acpi_video1: on vgapci1
nvidia0: <GeForce GTX 1080> on vgapci0
vgapci0: child nvidia0 requested pci_enable_io
vgapci0: child nvidia0 requested pci_enable_io

glxinfo | grep GTX
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Error: couldn’t find RGB GLX visual or fbconfig
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.

/etc/X11/xorg.conf

Section “ServerLayout”
Identifier “XFree86 Configured”
Screen 0 “Screen0” 0 0
EndSection

AFTER RUNNING NVIDIA-XCONFIG

nvidia-xconfig

Using X configuration file: “/etc/X11/xorg.conf”.

VALIDATION ERROR: Data incomplete in file /etc/X11/xorg.conf.
Undefined Monitor “Monitor0” referenced by Screen “Screen0”.

sh: pkg-config: not found
Backed up file ‘/etc/X11/xorg.conf’ as ‘/etc/X11/xorg.conf.nvidia-xconfig-original’
Backed up file ‘/etc/X11/xorg.conf’ as ‘/etc/X11/xorg.conf.backup’
New X configuration file written to ‘/etc/X11/xorg.conf’

kldstat | grep nvidia
46 1 0xffffffff832f0000 f18f9 nvidia-modeset.ko
47 1 0xffffffff833e2000 c3c4e8 nvidia.ko

dmesg | grep vga
vgapci0: port 0xe000-0xe07f mem 0xf6000000-0xf6ffffff,0xe0000000-0xefffffff,0xf0000000-0xf1ffffff irq 16 at device 0.0 on pci1
vgapci0: Boot video device
vgapci1: port 0xf000-0xf03f mem 0xf7400000-0xf77fffff,0xd0000000-0xdfffffff irq 16 at device 2.0 on pci0
acpi_video1: on vgapci1
vgapci0: port 0xe000-0xe07f mem 0xf6000000-0xf6ffffff,0xe0000000-0xefffffff,0xf0000000-0xf1ffffff irq 16 at device 0.0 on pci1
vgapci0: Boot video device
vgapci1: port 0xf000-0xf03f mem 0xf7400000-0xf77fffff,0xd0000000-0xdfffffff irq 16 at device 2.0 on pci0
acpi_video1: on vgapci1
nvidia0: <GeForce GTX 1080> on vgapci0
vgapci0: child nvidia0 requested pci_enable_io
vgapci0: child nvidia0 requested pci_enable_io

dmesg | grep vga
vgapci0: port 0xe000-0xe07f mem 0xf6000000-0xf6ffffff,0xe0000000-0xefffffff,0xf0000000-0xf1ffffff irq 16 at device 0.0 on pci1
vgapci0: Boot video device
vgapci1: port 0xf000-0xf03f mem 0xf7400000-0xf77fffff,0xd0000000-0xdfffffff irq 16 at device 2.0 on pci0
acpi_video1: on vgapci1
vgapci0: port 0xe000-0xe07f mem 0xf6000000-0xf6ffffff,0xe0000000-0xefffffff,0xf0000000-0xf1ffffff irq 16 at device 0.0 on pci1
vgapci0: Boot video device
vgapci1: port 0xf000-0xf03f mem 0xf7400000-0xf77fffff,0xd0000000-0xdfffffff irq 16 at device 2.0 on pci0
acpi_video1: on vgapci1
nvidia0: <GeForce GTX 1080> on vgapci0
vgapci0: child nvidia0 requested pci_enable_io
vgapci0: child nvidia0 requested pci_enable_io

nvidia-xconfig: X configuration file generated by nvidia-xconfig

nvidia-xconfig: version 384.59 (root@builds.trueos.org) Sat Mar 10 00:56:49 UTC 2018

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0”
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
EndSection

Section “Files”
EndSection

Section “InputDevice”
# generated from default
Identifier “Mouse0”
Driver “mouse”
Option “Protocol” “auto”
Option “Device” “/dev/sysmouse”
Option “Emulate3Buttons” “no”
Option “ZAxisMapping” “4 5”
EndSection

Section “InputDevice”
# generated from default
Identifier “Keyboard0”
Driver “keyboard”
EndSection

Section “Monitor”
Identifier “Monitor0”
VendorName “Unknown”
ModelName “Unknown”
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option “DPMS”
EndSection

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
EndSection

Section “Screen”
Identifier “Screen0”
Device “Device0”
Monitor “Monitor0”
DefaultDepth 24
SubSection “Display”
Depth 24
EndSubSection
EndSection


#19

Following on from above

Rebooting after running nvidia-xconfig leaves me at a text based login.


#20

Success

The problem turned out to be that the built in Intel graphics were enabled.

This post in the dorum gave me the clue (I was actually l;ooking for posts with nvidia.ko)

I did a fresh install (again)

Selected nvidia drivers during setup

Selected nvidia during the first boot wizard

All three screens were detected and the nvidia driver installed.

Thanks for all the input here.


Nvidia Gforce GTX 1050ti