True OS Boot Stuck


#1

My System:
Fujitsu T5010
Core 2 Duo P8400
2 GB DDR3
120 GB SSD ADATA

I had Windows 7 which means the system partition, windows7 partition and third primary partition for storing files.

{
$“stuck”

F1 TrueOS
F3 Windows
F6 PXE

Boot: F1 ########
}

I deleted the Windows 7 partition and installed TrueOS on it. Boot Loader “stuck”.

I deleted System Partition and installed True os on the free space left after the system and windows 7 partition. Boot Loader “stuck”

I tried emergency shell:

  1. boo0cfg -B ada0 -> Boot loader “stuck”
  2. gpart bootcode -b /boot/mbr ada0 -> Boot loader “stuck”
  3. gpart bootcode -b /boot/boot0 ada0 -> “Missing operation system”

Deleted all the partitions and used the entire space for True OS -> Hahahahah “STUCK”

Ok guys…The first time i installed FreeBSD was in 1999 version 2.3 …it was not that difficult. It catched my windows 95 and just installed itself among the options of the boot loader.
I tried to install TrueOS an year ago and i met the same problem stated above.
Is the only way to install TrueOS with UEFI or EFI
In these days of modern Linux derivates “stucking” a new user coming from the Windows world is not very attractive.

$“stuck”

F1 TrueOS
F3 Windows
F6 PXE

Boot: F1 ########


#2

If your BIOS is UEFI only, then UEFI get’s installed.

rEFInd should have been installed, if using UEFI.

You said you had this problem before.

TrueOS is using FreeBSD-12.0-CURRENT, If possible, try a FreeBSD 12 install media and see what happens --> https://download.freebsd.org/ftp/snapshots/amd64/amd64/ISO-IMAGES/12.0/


#3

My BIOS definitely is not UEFI. The laptops is produced 2010. I just installed Linux Mint. It works like a charm. I want to get used to with and alternative of Windows as desktop OS because i currently still use XP. Windows 7 is possible solution also but i will never put Win 10. So i am looking for an option to migrate to.
FreeBSD is perfect but here in Europe it is quite uncommon so i try to stick to Debian related distros.
Thanks for the answer btw.


#4

Is it a 32 bit or 64 bit system? TrueOS is 64bit only, stuck bootloader may be due to 64 bit on a 32 bit cpu. Early instructions may be 32 bit instructions, but then get flipped to 64 bit at some point.

If the system is a 64bit system, then this is not the case.


#5

It is supports Intel 64 bit instructions set.


#6

Ok, just wanted to eliminate that. Thanks


#7

Doesn’t sound very informative IMHO. You’re saying the installer boots just fine, detects all the hardware just fine and, after installation is complete, your system can’t even load to the TrueOS boot menu? There should be something on the screen or is it just blank?

Kindly, you’ll have more chances of somebody helping you if you provide more information.

I’m relatively new to TrueOS, but, to my knowledge, it should work on non-UEFI. UEFI/rEFInd is only needed for dual boot:
https://www.trueos.org/handbook/dualboot.html

Also, you might wanna check the system requirements (cpu supported etc) and the troubleshooting section of the handbook:
https://www.trueos.org/handbook/introducing.html#supported-hardware
https://www.trueos.org/handbook/helpsupport.html#installation

As to my experience, I had to modify the video mode settings once, as the system hanged during the boot. Unfortunately, I don’t remember the details… it’s been a while.

TrueOS is based on experimental FreeBSD current, so you might expect some issues running it. As RodMyers suggested, you might wanna check FreeBSD 12 or even FreeBSD 11.1, which might perform better and provide some clues. BTW Given that your system has only 2GB of RAM, memory hungry zfs-based configuration might be sub-optimal.

Kind regards.


#8

Try this,

  1. go here https://trueos.org/downloads/
  2. Download TrueOS Unstable USB image, Note it’s the unstable version I am referring to.
  3. Create bootable disk using dd

On re-boot select boot from USB