Tried to install TrueOS today - no luck


#101

It’s tempting to get one of those. Problem is that I need one with Swedish keyboard and I haven’t seen that kind of machines on ebay.

There are Swedish advertisement sites, but there are most 15" computers, and they’re way to large. I need a really portable (not a towable) one that is easy to carry with me.


#102

Take a look at the X230 model, and see if you can find one with the Swedish keyboard. I’ve seen the keyboard itself, new for that model for $35.00 US. With a fresh battery, under FreeBSD (i5 CPU) it gets around 10 hours per charge.


#103

Thanks for the input, I took a look at it but it seems to be a little over my budget.

Anyway, I now decided to try to get a refund on the X102BA and called the shop today and they agreed to take it back and just charge me about $35 for the take back. After all I’ve had since September last year but its OEM HDD with pre-installed Windows 8.1 is totally unused. As soon as I got it I directly replaced the HDD for a new SSD before I even tried to start it.

So I started to look at advertisement sites and found a barely used Lenovo Yoga 2 11" for a fair price. It seems to have an Intel Quad-Core CPU, 4 GB memory (soldered) and a real 2,5" harddrive (so I can replace it for my SSD).

I don’t know if it works with TrueOS, maybe some of you guys here knows and can tell me? But the advantage of buying a slightly used one from an individual, is that I can ask the seller if I can try to replace the harddrive and install my OS, and say “if it installs, I buy it, and if not I restore it”.

But the best thing is of cause if some of you guys can tell me “yes, it works” or “no, don’t even try” :slight_smile:


Buying a new Laptop
#104

No idea on the Yoga. Hopefully someone else can provide some feedback.


#105

Hey guys,
Unfortunately having exactly the same issue. Installed fine on my old thinkpad t61, loved it so put it on my Asus P550CA laptop.
Installation installed fine, but having the drive ghost from the bios, and screen saying insert boot media.

On reninstall drive shows up for installer, but doesn’t in the bios, and get the same screen as mentioned in the last 100 pages. (Long read)

I guess this is an Asus confirmed issue then? Lenova has no problems, fantastic install, giving up on Asus and my hard drive for now, but will check back here for solutions.


#106

Yes, it seems to be an Asus issue. Don’t know why, but after I sent the Asus back and got an Acer Aspire 1810TZ I had no problem what so ever and TrueOS installed like a champ.

So the best advise is to get rid of the Asus and get something else, preferably with Intel CPU and graphics.
To find the harddrive again run the command “# dd if=/dev/zero of=/dev/da0 bs=1m” and white zeros over it, then run “# newfs_msdos -F32 /dev/da0” to give it a format.


#107

Yep, thinking about getting a Dell or ibm beast. Will put my windows drive back in.

Btw thanks for this thread man. Likely the most perseverance I’ve ever seen by someone trying to get an OS going.

On a side note, when either building or purchasing a mean rig, does anyone have any suggestions on what would be an ideal setup? Perhaps what gear the os was devved on?

Thanks for any help!


#108

@Robiww you have mentioned that Asus offered updated BIOS version for this model. I would recommend upgrading to this newest version even though every manufacturer warns about possibility to brick your motherboard. I have seen many occasions where BIOS update solved strange problems and if you follow instructions carefully there is very small possibility to screw things up (except if electricity fails during upgrade). There are numerous scenarios where some drivers that are offered by manufacturers won’t work properly until you upgrade to specific/latest BIOS version.


#109

Thanks! But i doesn’t matter anymore since I don’t have the Asus left. I got a refund on it and got my self an used 11,6" Acer Aspire 1810TZ instead. Thanks to that I found it on the private market at an advertising site, I was able to try it out with my own harddrive with TrueOS on it via my USB-adaptor before I bought it. So I was sure it would work.

So it runs now. I just have a few issues with with the sound/mic, but I guess that’s passing. After all, TrueOS isn’t fully developed yet and FreeBSD 12 is still in CURRENT status.


#110

Interesting thing happened.

I’ve installed the most recent edition of TrueOS; and while attempting to dual boot with Windows 10 (something I ultimately kind of gave up on—I never use it anyway), I bumped into the same issue as the OP. It’s a Dell Inspiron 15 5000 series, stock save for the SSD manually swapped out for a larger HDD. After the first apparently successful installation, I noticed that my firmware had a completely empty list of boot options.

The second time through, I installed over the whole disk, to defaults, and still couldn’t start. After that, I switched to Legacy BIOS and suddenly it worked—am I correct in presuming that TrueOS is not entirely UEFI ready? I didn’t have Secure Boot on or anything, but it would not boot in strict UEFI mode. I kind of figured it was the opposite with BSD? If this is the case, it’s almost certainly impossible to install alongside Win10; which is a problem for most newcomers.

I’m still bumping into issues with sound, but who knows what that’s all about.

The other odd thing is that the thumb drive I installed from (built with disk dump, as suggested in the installation manual) would not boot in UEFI mode. That could easily be because of something I did, but if it is then it’s well hidden; I’ve been using *nix almost exclusively for about nine years.

Hopefully it applies in some manner to the OP’s issue.


#111

With some BIOS’s, when you turn on UEFI support it also enables the Windows-only certificate verification. In my experience, there is typically a second option alongside the UEFI selection to tell the BIOS that you are booting non-Windows OS’s.


#112