Tried to install TrueOS today - no luck


#81

[quote=“Robiww, post:57, topic:216”]
Distribution Select - I’m trying “Base system (debugging)” - Is this the correct one?[/quote]

Probably not. Bear in mind, it’s optional, and not a default.

Accept the defaults.

  1. change selection
  2. use the space bar to select the required disk.

The selection dialogue confused me. It’s not enough to have something highlighted (in this context, highlighting is not selection); you must * the [ ] whilst that thing is highlighted.


#82

OK, I managed to run the FreeBSD installation now.

But the result… Well, same as before :disappointed:
Reboot = Back to the installation menu.
Reboot without the USB-pin = “Insert proper boot media”.
Check in BIOS = Harddrive is gone again.

I don’t know if it’s the ZFS/UFS formatting or the partitioning that isn’t compatible with the hardware. But there is definitely something wrong here. I guess we have tested all alternatives now, or are there any left?

We’ll see what Asus support says next week.

Addendum: Instead of zeroing the drive again, tried for fun to give it a FAT32 formatting (using this command “newfs_msdos -F32 /dev/ada0”) to see if that would help to bring it back. But the result was interesting: “The primary GPT table is corrupt or invalid”.
The other interesting result is that now when I reboot I get the black screen but the text is “Non-system disk - Press any key to reboot” and when I do that I’m back to “Insert proper boot media”.

I guess I clean out the drive again, because this is no use.


#83

If I understand correctly, you:

  1. performed a successful installation of FreeBSD; then
  2. booted that installation.

True?


#84

Yes, that’s true.
And if I leave the USB in it just goes back to the installation menu, just as when I tried to install TrueOS, and if I remove the USB it goes to black screen. And the harddrive did not show in BIOS.

I’ve now zeroed the disk again, but it starts to feel a little hopeless now.


#85

To clarify:

Did that installation of FreeBSD not present a login prompt?

If not a login prompt, then what was the text?

With text?


#86

Yes, correct. No login prompt. It just goes back to the installation menu on the USB.

Yes, black screen with text “insert proper boot media” i.e. the computers black screen, not FreeBSD’s.

During the installation process the program did prompt to ad root password, username and user password, which I did, but since the harddrive gets gone in BIOS, it’s for no use. No login prompt, just install menu or computers black screen depending on if the USB is in or not. It simply doesn’t find the SSD.

The install program also asked for other things like networks keys and so, but I skipped that since I don’t have it connected to the Internet yet. But I don’t think that makes any difference.

After I zeroed the harddrive again, it showed up again in BIOS, but it’s of cause empty now.

This must by far be the longest thread in this forum by now :wink:


#87

Thanks!

I was confused by reading about text and login where – if I now understand correctly – there was neither text nor a login prompt :-| (that’s not a dig … over the years I lost count of the number of times I tried, failed to install or use FreeBSD … weird, sporadic learning curves).

If you never had a bootable installation of FreeBSD, then:

– I reckon, it is worth continuing around that starting point.

Whilst https://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/bsdinstall-partitioning.html does not cover the installer for 12-CURRENT, this shot may help:

In that context, six partition schemes are available and here with a MacBookPro11,2 the installer defaults to GPT (BIOS+UEFI).

What’s the given default for your ASUS?

If that one did not work as expected then you might try the other five.


Without wishing to pre-judge ASUS support: if you do get someone there to provide the definitive explanation for this particular notebook not recognising, for boot purposes, some types of installation of FreeBSD or FreeBSD-based systems: I’ll be pleasantly surprised.


#88

@Robiww I would sumbit a bug report to the FreeBSD project at this point. Since you have tried stock FreeBSD, and it is the same result. See https://bugs.freebsd.org. Or you could try the freebsd current mailing list. https://lists.freebsd.org/mailman/listinfo/freebsd-current


#89

The default when I start installation, just plug in the USB, start and let it run, is GPT and UEFI. If I open the boot menu I can choose BIOS or UEFI. I’ve tested both, but it makes no difference, except that the rolling text and the menus get larger (lower screen resolution) when running plain BIOS.

However, I just got some new input.
I was out and not far from me there is a shopping centre and they have a small quick-fix computer workshop that was open today. So I asked a guy there and told him that I’m trying to install a BSD system. He didn’t know what BSD is, but when I told him that it’s a kind of UNIX he got the picture.

And this is interesting. Before I could even ask, ha asked me "is the harddrive disappearing?"
Me: Yeah!
Then he told me that he’s no expert in this matter, but he knew that it’s a common problem on newer laptops and notebooks when you try to install something else but Windows.
He also asked if I had disengaged Secure Boot and engaged CSM, and I told him I’ve done that.
The solution he mentioned is that I would need some SATA- or RAID-driver. He agreed that it’s a problem with either the partitioning or formatting and told me to contract Asus and ask more precisely.

I didn’t really get that thing with SATA-RAID, but then I was thinking that if I would install some driver and then try to put FreeBSD or TrueOS on top of that, it would probably erase that driver. And I don’t know if it’s possible to go the other way and install a driver on top of the OS and if that could attract the disappeared harddrive again.

As a last resort I’ve started to think to contact the shop where I bought the computer and try to replace it. Sadly 10" notebooks are hard to get by nowadays. But I saw that they have a HP 11,6" with the same performance for a fair price. But then I have to know that it will work before I try to do the deal. I think they should agree since I would have to ad some money on the replace.
It’s this thing, or close to it. Downside is that it’s larger and heavier than mine which is very slender http://support.hp.com/us-en/product/HP%20Pavilion%2011-n000%20x360%20PC%20series/6796818/model/6970533/product-info?jumpid=reg_r1002_usen_s-001_title_r0001

@jmaloney Can I use the PC-BSD Bug Tracking System (I already have an account there, but it seems inactive when I just looked) or shall I create a new account on FreeBSD?


#90

We can not add to, but we can …


#91

OK, I found out that the PC-BSD Bug Tracking System is closed and open for read only. But I followed the advice from @jmaloney and submitted a bug report at https://bugs.freebsd.org # 215870

To grab all possibilities I also called ASUS support today and sent a support request to them by e-mail with detailed information about what, why and how things behave like they do. I got an automated reply that their policy is to respond within 48 hours. So hopefully we have some more answers by Wednesday noon.

I also called the independent computer workshop I mentioned earlier. First of all he told me that the thing I was told by the computer guy in the shopping centre last week is bull and that must have been a Windows-guy, because there are no drivers like that in Linux or BSD. They are built into the root or kernel.

However, he mentioned something called “USB Boot Trapper” that can boot from the USB and then tell the USB to fix a root device on the harddrive that the computer can start from.

That’s is a little like Greek to me :wink: , but maybe some of you guys understands what he meant.

Anyway, the main thing he told me was to contact the guys at FreeBSD because they’re pro’s on this kind of issues.
I told him that I’ve done so, but I’m trying to open all doors to finally solve this issue somehow.


#92

Well, a little update and just another short question that I came to think of.

The contact with ASUS support didn’t give much. I sent a detailed description of the problem, but first they just said as expected: “We only support Windows”.
After a few e-mails back and forth I went more specific and asked these four questions and told them that I want support on the hardware and if I would have wanted support on Windows I would have contacted Microsoft.

  1. Can the computer be made compatible to other but Windows NTFS file system e.g. ZFS other then just disengaging Secure Boot and engaging CSM?
  2. Are there any hidden settings in BIOS and if so, how can I get to them?
  3. Should the BIOS-version 2.15 that is present be updated?
  4. Are there any alternative BIOS-versions?

The answers I got on the questions was not very helpful. But I guess I didn’t expect much more.

  1. Sorry not.
  2. Sorry not.
  3. There is a newer BIOS-version. But you do a BIOS-update at your own risk and it should not be updated as long as there is no error. Send how to do a BIOS-updates (I didn’t really understand what they meant with that last sentence. But I know there is a new BIOS-version on ASUS homepage and there is instructions how to update in the manual and in the present BIOS it self)
  4. Sorry not.

Oh well, I just hope that the guys at FreeBSD will find a solution.

The question: I noticed when I downloaded FreeBSD 12 that the version is called CURRENT and not RELEASE. Since TrueOS AFAIK is based on FreeBSD 12, does this mean that TrueOS not yet is in a completely developed mode?


#93

FreeBSD 12-CURRENT is also referred to as HEAD. It’s where current development is taking place; tracking this is similar to tracking Linux HEAD/bleeding edge. Typically you’d find just developers using it, but they do try to keep it stable enough for people to use.
Here’s FreeBSD release engineering page:
https://www.freebsd.org/releases/

Part of reason TrueOS is tracking CURRENT is because trueOS upstream is the FreeBSD graphics work being done by Matt Macy and others. They’re tracking current because their changes are too big to go into 11 or 10 release.

As for the ASUS stuff; sorry to hear (but we expected that).


#94

The “no” answer from ASUS was somewhat misleading, because neither the hardware nor the firmware is designed for NTFS.


#95

Updating this topic since I’m eager to have my notebook to start working and looking for all kind of signs that things get fixed :slight_smile:

Does this mean that the system may start to function on my notebook? Or is it an automount like on Mac’s were e.g. USB-pins automounts and an icon shows up on the desktop and then unmounts when you draw the icon to the recycle bin?


#96

Nope, not like that.


#97

Update on the ASUS issue.

After this came up about two week ago [Solved] Problem with trueos boot
I gave it a try again today with the latest install (2017-02-22) and booted with BIOS instead of default UEFI. Also UEFI don’t let me use MBR installation, only GPT.

Interesting now is that the harddrive don’t get hidden in BIOS now, but it still won’t boot after installation. But instead of “insert proper boot media” I now get the following:

F1 FreeBSD
F5 Drive 1
F6 PXE
Boot : F1 ################################## etc. (the # shows up one after another)

  • Hitting F1 or Enter just gives another #
  • Enabling or disabling “Launch PXE OpROM” makes no change.
  • Unplugging the USB only removes the option “F5 Drive 1”.
  • Hitting F5 or F6 starts a new install process with BIOS.
  • Setting the USB as first boot option in BIOS starts a new install process with default UEFI.

So… well… I’m stuck again “huh!” :grin:
At least the harddrive isn’t gone now - a small step for mankind :wink:


How long will pcbsd last?
#98

I tried to install the new version “2017-03-31” today - Same result :slight_frown:

I’m starting to think, is it worth to wait and hope that it will work later? Or should I try to replace the computer for another one?

I’ve been looking around and found another small and price worthy notebook. It’s also an ASUS, but model X200MA https://www.asus.com/Notebooks/X200MA

The only technical difference AFAIK is that it has Intel CPU and graphics. It’s slightly larger 11,6" instead of mine 10,1", but I guess I can live with that as long as I get it to work.

What do you devs think? Is it worth to replace it? I may be able to get a refund on the X102BA since it’s still kinda unused. I’ve only replaced the OEM HDD with Windows 8.1 (still only pre-installed) for a SSD, so I could easily restore it back to the status as when I got it from the shop.

So what do you guys think? Replace or not? In other words, is it worth waiting and see if TrueOS will work in this one (with AMD CPU and Radeon graphics) or replace it and hope that it will work better?
Maybe you even can tell if the X200MA may work?

Update:
I just found out on the Web that the X200MA not is available. But the questions may still be valid if I may find one.


#99

You asked for opinions, so…

I did find that Asus model online for around $450 new, to about $250 used on Amazon. I think that the specifications for the laptop aren’t that great. It is only available with either a Pentium or Celeron processor, with support for 4GB of DDR3 memory.

For your money, I think you’d be better off picking up a used Lenovo ThinkPad X220 off eBay similar to this: http://www.ebay.com/itm/ThinkPad-X220-12-5-i7-8GB-RAM-320GB-HD-Webcam-WiFi-Battery-Windows-10-Pro-/232282669353?hash=item3615204129:g:3SYAAOSwOgdYy-p~

Allan Jude seems to like this model, so there you go. :wink:


#100

Hello!

First please check the checksum of the downloaded installer .img file.
After make an msdos filesystem (with Gparted: Device-Create Partition Table) for the USB key, after make an primary FAT32 filesystem for the USB key and format it slowly (important!). The “zeroed” is some kind of wiping.
After write the downloaded TrueOS installer .img file for the USB key with dd command.

After make a new msdos partition table (Gparted-Device-Create Partition Table) for the SSD and make a primary NTFS filesystem for it and format it slowly.

After boot up the machine from the already written USB key ( try the install), first in UEFI unsecure BIOS mode with BSD bootloader.
If the install will broken somewhere or the installed system can’t boot than change in the BIOS from the UEFI boot for legacy boot mode, choose BSD bootloader again and try again the install procedure . If some option is missing from your BIOS than try to give an Super User or other password for the BIOS and check again the available options.