Tried to install TrueOS today - no luck


#61

That’s what I’ve selected. But it results in #8 “Stripe: Not enough disks selected. (0 < 1 minimum)”.

Can this mean that the hardware can’t handle the ZFS format? On the other hand, it seems to be the same with UFS.
The only thing I can think of is that I have to select something else in some menu. Why would it otherwise say " Not enough disks selected."?
It obviously that it finds the Kingston harddrive (#7). Could it have something to do with the installed Ubuntu (it has created two partitions in BIOS)? On the other hand when the installation process starts it should erase that.

It seems that everything goes wrong with this notebook computer and that it may have been that I bought the wrong hardware. It’s built for Windows 8.1, but that is my desktop as well, and that has no problems with ZFS and PC-BSD and probably not with TrueOS ether (haven’t tried yet).

I’m also thinking that if the Radeon graphics would be the problem the installation would start at all as when I first tried PC-BSD 10.3 and 10.2, that didn’t work at all and I got an early error.

I’m speculating a lot here. What do you guys think? Is there a solution?


#62

are you planning on using the Kingston drive? If not, remove it.

If so, look at the trueos handbook https://www.trueos.org/handbook/install.html#advanced-mode figure 4.3.2.2. ZFS Layout to add it


#63

The Kingston drive is the primary and only drive the notebook it has.

Looked into the handbook and a little further down in the section “4.3.2.2. ZFS Layout” I found this: “stripe: Requires a minimum of 2 disks”, so “Stripe” seems not to be the right option.

But in #6 above there is only these options in the menu: “Stripe - No Redundancy” (pre-selected), “Mirror” and “RAID 1+0”, “-Z1”, “-Z2” and “-Z3”.


#64

I think the USB image should let you boot into a live/rescue mode; if so then perhaps partitioning the device manually can get us to where we want.
The link that @RodMyers has is good, if you want a more low level using raw gpart commands, you can look at this:
http://www.wonkity.com/~wblock/docs/html/ssd.html

With ZFS you only need to create a freebsd-boot partition, a freebsd-zfs partition and then a freebsd-swap partition. For the instructions at my link, where it says “gptboot” you want gptzfsboot, for freebsd-ufs you want freebsd-zfs.


#65

I managed to install FreeBSD with UFS partition - Almost - BUT, Same thing happens now as when I try to install TrueOS. It just goes back to install mode after reboot and if I remove the USB-pin “insert a proper boot media”.

So I checked in BIOS and the harddrive is gone again. So… FreeBSD won’t run on this thing either.
If I run the installation again (this time as ZFS) it sees the harddrive in the installation program, but it doesn’t find it when it’s time to install i.e. almost the same as in TrueOS but on an erlyer stage “Stripe: Not enough disks selected. (0 < 1 minimum)”.

So what is left to do? Throw it out the window? Seems like this computer is garbage. Or re-insert the OEM HDD and run Windoze 8.1 on it? I don’t think so.

Or is it something that has to do with the SSD as in the link @mer provided (haven’t read it yet, just skimmed it)? But I have the same kind of SSD in my desktop and that works fine.
Sure I could try with a mechanical HDD, but That would probably make the notebook very slow.


#66

I think if you booted the USB, then in live/rescue mode did the partitioning steps in the link I provided, reboot and stop in the bios to see if the drive is visible, that may give us a clue. Of what I don’t know, but it could be something. I don’t recall if it was in the article I linked or another from google “freebsd install ssd”, but there was something about sizes and alignments of boot partitions in specific manner because “windows”. It could be that the BIOS in your laptop is expecting something like that (it saw the kingston when it was first installed, yes?), but the way FreeBSD/TrueOS partitions it the BIOS doesn’t like.

Desktop vs laptop: the bios is different between them, so it is very likely that the same brand/model SSD could work in one, but not the other. When you are stopped in BIOS, look around for the SATA interface, make sure it’s set to AHCI and not IDE. I’ve run across some old stuff that misbehaves if its not set to AHCI.


#67

man, this is very weird.

put your favorite linux distro on it?

Short of tinkering with the BIOS settings individually,I have no more idea(s) at this point


#68

Agreed. It feels like partitioning to me. I thought OP put a Linux distro on it that worked, but then overwriting with TrueOS/FreeBSD fails. That’s why I’m thinking manually partitioning can give us (and the devs) a clue.


#69

that, or tinker in the bios


#70

I tried the commands in the link from @mer but i wrote “freebsd-zfs” instead of “freebsd-ufs” in the commands. I got all kind of responses like “already mounted” and other things but it seems like it didn’t work. I don’t remember it all responses, but now I wrote zeros over the drive and that made the drive show up again in BIOS.

What I probably would need is to try manual installation commands for TrueOS or FreeBSD-ZFS.
Actually, I don’t know any manual commands except those that I’ve written down that I got from @Kris and others earlier. I don’t even know how to start a manual install. In this I’m a total novice.

About tinker in BIOS. It not much you can do in there. It’s very small, not graphic (as on my desktop) and the most I find in there is “secure boot” and stuff like that meant for Windows 8.


#71

that’s all I have left to offer. way past my knowledge level now.


#72

I’m with Rod, past my knowledge level. But the fact that you wrote zeros to the drive (I’m guessing just the first couple of meg?) and the drive shows up in the bios again leads towards partititoning somehow.


#73

Here’s something from last year, not sure if it is similar, but the solution talks about UEFI mode, GPT with a FAT32 partition.
http://superuser.com/questions/1134700/asus-laptop-with-emmc-shows-no-storage-device-after-deleting-all-partitions/1134743


#74

That was interesting, but it seems it’s more for Windows use.
I have disabled secure boot and enabled CSM and that also disables fast boot.

The difference is that when secure boot is enabled, BIOS won’t show the harddrive and when I start the computer without the USB-pin it goes strait into BIOS. With secure boot disabled it goes to black screen “insert proper boot media”.

Right now the harddrive (SSD) is clinically clean after I ran “clean sweep” on it with this command:
“dd if=/dev/zero of=/dev/ada0 bs=1m”

At least, now we know that the disappearance of the harddrive in BIOS probably has something to do with the formatting to ZFS and UFS, since as soon as I cleaned the disk it showed up again, and it shows up when I install Ubuntu that uses some other format.

So now I need some help what to do next, if there is a solution. Also, since I now know the likely cause of the problem, I will call Asus support again and ask what they think. But I have to wait until next week since it’s now holiday here again.


#75

Thanks for the “dd” command you’re running. I’m guessing it’s not really the formatting, but rather the partitioning of the device that the installer is doing.


#76

Thank @Kris , I got the command from him some time ago :slight_smile:

Also thanks for the suggestion:

I keep that in mind when I call Asus support next week.

Maybe some of the developers @grahamperrin , @jmaloney , @Kris or someone can clarify a little more what to do next no matter what they say at Asus. Because I’m afraid they just say “this is a Windows machine, and we don’t support anything else”. However, I’m also gonna call an independent computer workshop whom I know of, and they also works with Linux and BSD.

Or could it be that it doesn’t work with the SSD? As OEM it has a mechanical HDD with pre-installed Windows 8.1, but I had the option when I bought it to get the HDD replaced for a SSD with the Windows 8.1 pre-installation on it. But I said no since I thought “why should I pay extra for them to clone the drive and then I erase it anyway?” (now I have the OEM HDD laying around, but I don’t use it)
But at least this tells us that the hardware should generally be compatible with a SSD.


#77

I was just writing down some questions to ask Asus support. Then I got to think you said that it rather be the partitioning.
I’ve run GPT partitioning all the way, and I don’t remember if I ever have tried MBR (I might have, but I’m not sure). Could that affect things?


#78
  1. install FreeBSD, choose ZFS with no redundancy
  2. install TrueOS Desktop to the storage pool that was created at step (1).

Some of the recent installers for FreeBSD are confusing:

  • proceeding with installation does not proceed with installation
  • instead, there’s procedure to pre-installation questions about ZFS

– yeah, proceed with precedings or precede with proceedings :confused:


#79

@Robiww:
It may be worth it to walk throught the gpart steps in the article I linked, just as they are (which will do a MBR and UFS) and then reboot to see if the disk is still recognized in the bios. There are a couple of things mentioned relating to alignments and start of the data partition (words like …“ever since windows vista, microsoft has started their data partitions at 1M”) that ASUS may be counting on in the BIOS for the laptop. That kind of ties in with the dd zeroing out the first 1M and the disk showing up again.


#80

@grahamperrin I tried that already (see post # 57) and it failed. So unless the zeroing of the harddrive makes some difference I guess the result will be the same
Or to use a quote from Einstein: “Insanity: doing the same thing over and over again and expecting different results” :wink:

I saw somewhere, by searching the web, that there may be some hidden settings in BIOS, or if it needs to be updated, or replaced. One thing about GPT or MBR is that GPT seems to need UEFI to work, and it use to be graphical, but the Asus’s BIOS looks like a traditional BIOS although Asus says it’s a UEFI.

Yeah, about zeroing the harddrive. As far as I know new harddrives are zeroed when you buy them, aren’t they? So I guess the result will be the same as when I tried to install TrueOS when the drive was brand new. OK, I haven’t tried to install FreeBSD on a clean drive yet, but can that really make a difference?

Anyway, now I’ll wait until I’ve been talking to Asus support next week and heard what they have to say about this.

I tried that - didn’t work.
I also tried to install FreeBSD as UFS, but beside that the same thing happened again and the harddrive disappeared in BIOS, as far as I understand it won’t work to install TrueOS on UFS.

Like I said, we’ll see what Asus support says.