Tried to install TrueOS today - no luck


#41
  1. I placed the file directly in the Home directory, so it can’t probably be more visible, unless I place it on the desktop. However, I tried that right now while I’m writing this - no difference.

  2. I read somewhere that it should be possible to write the TrueOS .iso to a USB. On the other hand, I tried this with the .img file as well with the same result.

So the questions remains.

  1. Could the .iso make a difference and make the installation process to succeed?
  2. What am I doing wrong in the attempt the write to the USB pin?

#42

As long as you are getting file not found nothing will work. Try this:
ls TrueOS-Desktop-2016-12-15-x64-DVD.iso
dd if=TrueOS-Desktop-2016-12-15-x64-DVD.iso of=/dev/da0 bs=1M

If the ls works then the dd should work.
Or… create a file
#!/bin/sh
ls $1
dd if=$1 of=/dev/da0 bs=1M

Then chmod 755 the file and run it…
That way you know if the ls works… the dd should work every time.


#43

Many months ago with some bleeding edge installers for PC-BSD I found that with some computers, the DVD (created from .iso) would succeed where the USB flash drive (created from .img) failed.

Whilst I have not tested any recent .iso files, my sense of improvements with the .img files is that edge cases, requiring a DVD instead of a USB flash drive, should be increasingly rare.


For now please continue with the advice on getting a USB flash drive from an .img file.


#44

@grahamperrin if I am understanding @Robiww correctly the question is if one can use the .iso files to create a USB stick.


#45

Ah sorry, not paying full attention I thought that the question had been answered.

If the content of the .iso is written to a USB flash drive (instead of a DVD), then I should not expect any computer to boot from that drive.


#46

Well, as a last attempt I tried to install from the .iso from a newly burned DVD with a borrowed external DVD-player I have laying around (I can’t get in touch with the owner to give it back, but he is interested in Unix and BSD. So if you read here, contact me so I can give it back).

Anyway, TrueOS won’t install no matter what I do. When I reboot after what it looks like a successful installation, it just runs the installation sequence again probably since it doesn’t find the SSD to boot from because of that the SSD (that I have set as Boot Option #1) disappears in BIOS.
If I go the other way and unplug the USB, no matter if it’s the USB-pin or from the external DVD-player, it just goes to black screen “insert a proper boot media”. So as i seems there is nothing on the SSD = Failed installation…

After this attempt I tried to reinstall Ubuntu again - No problem what so ever, just a smooth install. But I don’t like the looks of it.

So, I can just conclude that it’s definitely something wrong in the TrueOS installation file. And since I don’t know if the current version from Dec 15th is a stable release version (I haven’t got an answer of that, although I’ve asked several times) I just don’t dare to try installing TrueOS on my desktop since I’m afraid it may destroy my PC-BSD installation or slay its SSD, or make it vanish in BIOS. According to my current experience from TrueOS I just don’t believe it’s a stable version. Sorry.


#47

@kris I see your Can’t boot after upgrade … without being hands-on, I sense that what’s descibed here by @Robiww is comparable to how things were before https://github.com/trueos/pc-sysinstall/commit/dd8ec0446cb319c1a1d4ef31f1a43795d5186784


#48

I noticed there is a new update of Dec 27’th. May that fix my issue?

On the changelog it says: "Fixes: trueos/trueos-core#222"
Don’t know what that means, anyone?


#49

@Robiww Have you tried the grub bootloader option during the installer?


#50

Yes, I think I tried everything incl. the options xorg, vesa, scfb, intel, amd and text install in the TrueOS Menu, but it makes no difference - it fails every time.

I haven’t however tried the newest updated version (Dec 27’th) yet, that’s why I asked. I also ask because because I don’t want to overwrite the SSD too many times.

Actually I don’t really know what happens when I try to install. The installation process seems to go as supposed to. It’s when I reboot after the installation that it fails. Or “fails” may not be the accurate word, since it reboots, but then it just goes back to the TrueOS Installation Menu, and if I remove the USB with the boot media it just goes to black screen as I described above.

So I don’t really know where the, what it first looks like, successful installation goes. Does it stick to the SSD but just won’t boot up since the drives somehow gets lost in BIOS? Or does the installation just vanish into cyberspace? On the other hand, I don’t have that computer connected to the Internet yet (I use the offline installer), so where could it vanish?


[Finished] TrueOS/Lumina Dev Q&A: Ask us questions!
#51

@Robiww Do you know the model, or part number for the SSD?


#52

Yes, it’s a Kingston 120 GB. Part number is SUV400S37/120G

A little earlier I had an Adata 120 GB, the par number on that was ASP550SS3-120120GM-C
I replaced that one since it looked like it broke and the shop confirmed it and gave me the Kingston instead.

When I had the computer open last time I disconnected the BIOS battery to get rid of all possible Windows 8 Ready crap that may be stored in it while I went to the shop and got the SSD replaced.

But both acted in the exactly same way on my attempts to install.


#53

@Robiww The repo you would want to watch for changes is pc-sysinstall.

https://github.com/trueos/pc-sysinstall/commits/master

I do not see any changes were made that would affect booting besides the disabling of global lenovofix in October. I do not think a newer image is going to help at this point.

If you really want to rule out our installer I would try out a FreeBSD 12 CURRENT snapshot. It uses an entirely different installer. Also there is not much point in continuing to try TrueOS on this hardware if FreeBSD itself will not boot. That is a better starting point in my opinion. If you do try FreeBSD I would chose the ZFS option to keep the setup as close as possible to ours.


#54

I’m very unfamiliar with FreeBSD, but I looked into it here ftp://ftp.freebsd.org/pub/FreeBSD/snapshots but there is a lot of stuff and I don’t know which to use.
However, I downloaded FreeBSD-11.0-RELEASE-amd64-memstick.img and I could try that although I don’t really know what to do with it if/when it installs. All I know is that FreeBSD creates a black screen with text. I know how to login, but I guess it just gives me more white text on a black screen :wink:

Does this mean TrueOS won’t install on the notebook ever if FreeBSD fails?
That would be bad because I simply don’t dare to try to install TrueOS on my desktop computer that has 10.3 on it right now. Because if it f**ks up the drive on that one I would go nuts since that’s my primary computer.

So before I try that I want to know for sure that TrueOS is stable, works and see it in action hopefully on the notebook. That one I can experiment with because I have nothing on it yet.

One reason is that the desktop is also an Asus, but home built. The motherboard has part number A85XM-A but I have a NVIDIA GeForce 210 graphics card in it. It also has a Kingston SSD 120 GB as system drive, plus a 1 TB HDD (ZFS formatted) that I use for storage.


#55

No.

Given past experiences with multiple Macs (a use case that is fixed), I can reasonably assume that in your case:

  • something on disk is not written in the way that is required for the computer to find the installed boot loader

– not to be confused with the installed operating system.

You need not log in.

If you chose ZFS when you performed the installation of FreeBSD, then there’s a ZFS pool and you can proceed with an installation of TrueOS Desktop.

At the third page of the installer for TrueOS Desktop, opt to install to a pool.


#56

@Robiww You would want to use and amd64 memstick image. Preferrably 12-CURRENT.


#57

I’m trying to install FreeBSD 12 CURRENT, but I’m having a little issue with it. Since I’m unfamiliar with FreeBSD I’m not sure if I do this right.

  1. Welcome = “Install”.
  2. Keymap Selection = No problem.
  3. Distribution Select - I’m trying “Base system (debugging)” - Is this the correct one?
  4. Partitioning - I’m using “Auto (ZFS)”.
  5. ZFS Configuration - “Install”?
  6. ZFS Configuration - Here starts the issue: “Stripe - No Redundancy” (pre-selected - other alternatives are “Mirror” and “RAID 1+0”, “-Z1”, “-Z2” and “-Z3”.
  7. ZFS Configuration - “ada0 KINGSTON”.
  8. ZFS Configuration - “Stripe: Not enough disks selected. (0 < 1 minimum)”

And there I’m stuck. I don’t get any further the only options are “Change Selection” and “Cancel”.


#58

Base system should be fine, that would be a minimal install.
How many disks in the machine and how many are you allocating to it? The output at line 8 seems to say it found no disks to use.
If there are multiple disks in the machine (I’m guessing not if this is the notebook you talk about in the OP), I’d unplug all but the one you want to install on. All the options you list in #6 refer to multiple disks.
Maybe instead of selecting auto at #4, select something else (probably manual). That should drop into something to allow you to partition the device (a freebsd-boot as the first partition, then most of the rest as freebsd-zfs ,then freebsd-swap)


#59

Yes, there is only one disk. It’s 10" notebook so there is no space for more and it’s a real 2,5" disk, not eMMC.

The only thing I have plugged in is the USB-pin with the installation file.
If I select “Manual” at #4 I come to “Partition Editor” where the options are “ada0” (the harddrive) and “da0” (the USB). Each have three options “p1, 2 and 3” and on “da0p3” it says “freebsd-ufs” and that is not what we want according to @jmaloney

On this ,menu there are also six enter options: “Create”, “Delete”, “Modify”, “Revert”, “Auto”, “Finish”.

Is it possible to go from here and make it ZFS?


#60

zfs? yes. “no redundancy”, since you only have 1 drive