Tried to install TrueOS today - no luck


#21

For machines with UEFI I think there is an option for “Secure Boot”, but that is related to booting… if you can’t even see the drive in the BIOS itself then there is some issue that needs to be looked into before you even try to install.


#22

I’ll agree with @RodMyers; contact ASUS support. It’s possible that a BIOS reset to factory defaults disabled the boot options; sometimes manufacturers like to hide them because they don’t trust their customers. There may be a battery or jumper somewhere on the motherboard, but you’d likely have to take the laptop apart to find it (not worth it).

In the really old PC days, partitions had to be marked as bootable to be able to boot from them. That should not be an issue anymore, but there still may be something needed to get the BIOS to recognize a device to be bootable.


#23

francisco1844: There is a an option for “Secure Boot”, but there is nothing I can do with it as it is now, The “secure boot” is if I understand it right something that has to do with Windows not to get a virus into BIOS.

“Secure boot” does not work with BSD. I realised that working with my desktop computer, so I disabled it and enabled CSM, but it didn’t help.

I will definitely contact Asus support tomorrow. I still have warranty on the notebook, but I don’t know how that compares with BSD or if it’s only if I use Windows crap. But in my opinion the hardware should be platform independent. Then if it is? That’s another story.

I get back here and let you know how it works out no matter if I solve it or not.


#24

what happens if you disable CSM? can it boot?


#25

Well, I tried that now, disabled CSM and enabled “Fast Boot”. Without the USB it didn’t change anything, it goes directly into BIOS and looking under “Boot” there is no “Boot Option Priorities”.

But if I insert the USB and reboot it starts the installation program automatically. The only difference is that it looks a little different right at the start where it shows a TrueOS square with seven options that I can choose if I stop the boot with an arrow key. In there if I hit “3” (escape to loader prompt) and then type “?” I can find a lot of options, but I don’t know what to do with them.

If I let it run it sees the drive in the disk selection screen and then it just runs the installation cycle as before and asks me to reboot at the end and then gets back to the TrueOS Boot Menu again.
If I remove the USB I don’t get a black screen now, instead it automatically gets in to BIOS and there it shows no drive.


#26

what you saw was the normal UEFI boot sequence

had to ask, and make sure.

thank you for your patience on this


#27

If you have not already done so:

a. enable CSM
b. perform a fresh installation, not to a storage pool
c. choose GRUB, not the BSD loader.


PXE = Preboot Execution Environment, for use only where an administrator has enabled network-based booting.

CSM

Compatibility Support Module – https://en.wikipedia.org/wiki/Unified_Extensible_Firmware_Interface#CSM


#28

[quote=“grahamperrin, post:27, topic:216”]If you have not already done so:

a. enable CSM
b. perform a fresh installation, not to a storage pool
c. choose GRUB, not the BSD loader.[/quote]

I tried that now, but it made no difference.
However, I called Asus support as well as Asus workshop and both where quite sure that it’s probably a harddrive failure since it doesn’t show in BIOS.

So I preformed a simple test and removed the SSD and inserted the original HDD that has a pre-installed Windows 8.1 on it. I didn’t run it but just went strait into BIOS, and it shows up. So it has to be the SSD that’s bad.

So right now I’m getting ready to go back to the shop to replace it. Maybe I should choose a more well known brand than Adata this time.
To be sure that it’s not a BIOS issue with that garbage Windows 8 Ready stuff, I’ve disconnected the BIOS battery and leave it that way until I get back.

A question. Do I need to pre-format the new drive before I insert it? Give it an actualise? (or what it’s called in English). I mean when you insert a new drive in a Windows machine and go into disk manager it says “not actualised”.

The reason I asked is that when I first inserted the new SSD the computer didn’t find it so I called the support and they told me that I need to format the drive. So I gave it a NTFS format in my old Windows XP machine and then it showed up for a while.
Or could it have something to do with the ZFS format and that the BIOS don’t recognise it?

However, I go to the shop now and see what they say. They will probably test the drive and if they say it’s OK, then it may have been the BIOS and in that case the BIOS battery disconnection hopefully have fixed the problem.


#29

Formatted or not, should not make a difference, the install dvd/usb drive should find it and format for the install.


#30

Now this is really strange.
I went to the shop, they tested the SSD and confirmed that it was bad so they replaced it with a new one.
When I came back i assembled the computer, started it and the first thing I did was to check in BIOS and the drive was there (now a Kingston) and everything looked good.

So I started the TrueOS installation, everything looked good and the install worked as supposed to (except for that (File system not clean - run fsck etc.) as I wrote in post #12 of dec 19.

Well, go to reboot and I’m back on TrueOS Boot Menu. Pulled the USB, reboot again and I got black screen “insert proper boot media”. What the…! :imp:
Checked BIOS and the drive is gone. It’s like before, the only that’s there is Realtek PXE :disappointed:

It seems like the TrueOS system trashes the harddrive. So as it is now I have no clue what to do. Suggestions please?

I have no intention to try to install TrueOS on my desktop before I know for sure that it works. And the notebook is the machine that will determine if I ever install TrueOS on my desktop. Because if it trashes that drive as well I’m gonna go bananas :scream:
As for now I’m sorry to say that my confidence in TrueOS has sadly suffered a blow unlike my PC-BSD 10.3 that runs strong.


#31

grab an ubunttu install media and verify hard drive.

TrueOS should have nothing to do with bad hard drives, etc


#32

I highly doubt that this is what is happening… and before anyone jumps on me for being defensive of TrueOS, let me explain. Modern hard drives have protections built in so that software cannot damage the device. I have seen this happen on cheap USB drives, because on some cheap Chinese flash disks they actually store the device info (what would normally be saved in some eeprom on the stick into the first few spots of memory on the flash NAND. In a case like this, when you dd the drive, you overwrite that firmware and the drive no longer is able to speak to the USB bus when you plug it in.
Modern Hard drives do not do this at all… unless there has been some change… which would seem to be a bad idea. I have exclusively used Kingston SSD’s for the past 3 or 4 years, and have never once run into a problem with any of them.
Formatting the disk should not cause it to not be able to be seen by BIOS. That information is saved elsewhere in the drive and cannot be touched with a disk format (unless Kingston went and did something stupid).
Are you able to plug that drive into your desktop and see if the desktop bios can detect it?

That was my first thought as well but if the Bios on that machine is doing something wonky. Another OS wouldnt be able to do much since it’s still plugged into the same motherboard. He should check the drive in another machine, so we can verify the drive is bad on something else. If the drive is readable on another machine then we know the issue is related to something specific with that hardware.


#33

I read what both RodMyers and q5sys says. But to me it looks like a strange coincidence that two SSD harddrives in a row breaks when I try to install TrueOS onto them.

The shop confirmed that the first drive was blown. They connected it to their computer and the clerk said that didn’t show up in BIOS there either, that’s why he replaced it with no charge.
And now it’s the same thing again with the new Kingston drive, it’s just gone in BIOS so I can’t think of anything else then that it has blown as well.

Sure I can try with another OS. On the other hand, I had Linux Mint in the notebook a few month ago with the previous Adata drive, I believe before TrueOS was out since it wouldn’t run with PC-BSD 10.3 and it worked but I didn’t like how it looked and felt.

But as soon as I tried to install TrueOS the drive broke down. I didn’t know that it was that at first (that’s why this thread is so long) but I got it confirmed today, and now the second drive broke down. At least it seems like that since the symptom is exactly the same. Coincidence?

I’m also thinking if there is some hardware failure in the notebook that destroys the drive. But in that case. Why would it run good before I try to install TrueOS? And why would it run good when I tried the original HDD with Windows 8.1?
Sure, I could replace the drive again and try another OS. But if I blow up another drive the shop will probably start to wonder what I’m doing with them.

Sure I’ll try with another OS. I can try Linux Mint again or whatever, but I doubt it will work since everything indicates that the drive is blown again.

Of cause I will also remove it again, and then I can try to run it on my desktop with my USB adaptor device and see if it shows up in BIOS. I could also try to run it on my old Windows XP machine. That’s probably easier since then I can see if it shows up in the Windows Disk Manager as well as in BIOS.


Coincidences in IT
Coincidences in IT
#34

Probably off-topic, but worth asking:

  • during each installation of TrueOS, do you take advanced options and choose to encrypt the installation?

#35

No, I just run a plain installation. The only change I do is to set the installation language.
I just use to check that it’s set to GPT. Talking about that, could the format GPT or MDR have something to do with it?


#36

OK, I tried Ubuntu. And what do you know, it worked and the SSD shows up again in BIOS, actually as two partitions (standard on Ubuntu?)

So now this is really strange. Why does TrueOS mess up the disk or BIOS or whatever when I try to install it? The only thing I can think of is if this can have something to do with the installation media?

Since I read somewhere that the .iso file won’t work with a USB-pin I was using the .img file from TrueOS. Ubuntu only has an .iso file that I used.
Could this somehow effect things? Can someone clarify this? I’m puzzled over this here.

I used the same USB-pin, the same setting and everything and I guess I could have saved the old SSD this way. But oh well, Kingston is better than Adata.

Another thing I noticed, not really on this topic, is that Ubuntu is much smaller and has less system requirements https://help.ubuntu.com/community/Installation/SystemRequirements than PC-BSD and TrueOS. Why is this? Does it have something to with the ZFS file format?

One thing I noticed on Ubuntu is that is seems to have no program menu, like a start button. All major programs are in a kinda task bar on the left. And I don’t know where to go if you want to find other things. But it doesn’t matter, my plan is to get TrueOS to run on the notebook.


#37

Ubuntu has gone to a Gnome3 interface; think of it like a big smartphone and it should make a little bit of sense. I don’t like it, but you should be able to install other desktops/windowmanagers (xfce4, lumina, lxde).
As for the SSD now showing up, it could have something to do with the way it was partitioned. Occasionally you run into weird partition “requirements” (sizes, alignments, etc) that maybe the Ubuntu install did that the TrueOS did not. TrueOS is not mucking up the BIOS, I’m guessing that there may be a flag Ubuntu is setting on a partition that is not getting set by TrueOS. Think back to the old DOS days, where you had 4 primary partitions and the boot partition had to have a flag set.

One of the devs can tell you the exact differences between a .img and a .iso as they are built. In theory, if the iso image is bootable, and you write it to the USB drive with dd, it should work. I have not done that with the TrueOS image, but I have with others in the past.


#38

I’m glad that (touch wood) there’s no longer a suspicion of coincidental failures of multiple storage devices :+1:

Some vendor-provided firmware suffers from inexplicably (or not easily explained) weird behaviours with boot devices. (I’ll not hijack this topic away from the ASUS X102BA, suffice to say that I find weirdness with at least two types of HP notebook.)

For example, you might find that:

  • an appropriate boot order will allow the computer to lazily work with a device that is configured to boot TrueOS Desktop (in simple terms: set an order, restart, sit back and wait)
  • a less lazy, more specific approach at boot time – positively selecting what appears to be the required device – will prevent boot from that device.

Yeah, that’s weird.


#39

First, Merry Christmas to you all (a little late, but I wasn’t at home the last days), hope Santa brought something nice to you :smiley

Talking about .img and .iso files. Is there some significant difference between the two that may affect the installation and that installation of .iso may work better? I haven’t tried the .iso yet, but it could be interesting to hear what you think before I try it.

Then another thing that has puzzled me for a while, probably easy for you guys, but I don’t understand it.

I’ve tried on several occasions to write an installation file to an USB pin, but it fails every time. I guess I’m doing something wrong. This is the command I used that should do it according to both the TrueOS and PC-BSD handbook, and the reply I get from the system.

root@PC-BSD:~ # dd if=TrueOS-Desktop-2016-12-15-x64-DVD.iso of=/dev/da0 bs=1M
dd: TrueOS-Desktop-2016-12-15-x64-DVD.iso: No such file or directory

I have a secondary internal HDD for storage and almost nothing stored on the primary SSD where the system is. But I thought to make it easier for the system to find the file, I placed a copy of it in the Home directory. But it doesn’t help.

Since I haven’t been able to solve this, I’ve used my Windows XP machine to write to the USB using the “Win32DiskImager-0.9.5-binary” program.

But like I said, I guess I’m doing something wrong in the command line. Someone please direct me how to do it right. As it’s now I have to move files back and force between the computers with a USB pin since the Windows machine it not connected to the Internet.


#40

Two comments. First notice how the file was not found. Perhaps you have it in a different folder. Second, my understanding is that you need to use the usb .img file. Not sure if the .iso will work to a USB stick.