Tried to install TrueOS today - no luck


#1

I tried to install TrueOS on my notebook https://www.asus.com/Notebooks/X102BA and the installation process seemed to run well with no mishaps and the installation looked successful when it came to the screen “Your system is now installed, press finish to reboot”. But when I do that it just goes back to the “TrueOS Installation Menu”, no error message or anything, and when I reboot from there it starts the installation process all over again.

If I instead just try to run the installation again without rebooting I get an error message that I logged (you can have a look at it here http://iww.se/trueos-install-debug.log if there is a solution) and if I remove the USB-stick and reboot it just goes to black screen and says “insert proper boot media”.

I tried to start the installation both with UEFI and plain BIOS, but that makes no difference. At the “TrueOS Installation Menu” I also tried Vesa and Scfb and I even get the options Legacy Intel and Radeon, so I tried Radeon, but with the same negative result.

I used the version 2016-10-28 and I know it’s not the final release. But will the release work with this machine? Or is it something I do wrong? I used the .img not the .iso since this computer has no optical drive.

I also checked the “hardware compability diagnostics” at the select language screen and it’s all green.

At least the graphical installer runs, unlike when I tried to install 10.3 or 10.2, then I just got a big error.


#2

That’s a known issue but (sorry) I can’t find the record of its discussion.

Workaround: press the power button.


#3

I did that and tucked the notebook away again and hope that the issue get solved before the final release :slight_smile:

Oh I forgot. I only tried the BSD boot loader, not GRUB since I have no desire to use dual boot. Don’t know if it would have made any difference.


#4

Could you try one more thing please. Boot from the installer image again and go to a shell (you don’t have to reinstall). Next type this:

gpart unset -a lenovofix ada0

and reboot without the installer USB.


[Solved] Problem with trueos boot
#5

I tried that now. The outcome of the command is “lenovofix unset on ada0”, but rebooting is another story without the USB.

  1. Typing “reboot” gives the result “/sbin/reboot: Input/output error”.
  2. I can close the QTerminal and go back to “TrueOS Installation Menu”, but the option “Reboot the system” doesn’t work.
  3. When I force reboot, it just goes to black screen “insert proper boot media”.
  4. Trying “reboot” with the USB in works, but it just results in another installation session.
    Please note, this isn’t a Lenovo, but an Asus even if they may have some hardware in common. It also has a real HDD/SSD, not an eMMC (I made sure of that before I bought it). The memory unit is however soldered and not interchangeable, but its 4 GB so it should be enough.

The SSD (I’ve replaced the computers standard HDD) simply seems to be empty after the reported so to say “successful installation” (“Your system is now installed, press finish to reboot”) - Not! :confused:

However, if I take a few more steps into the installation process again and into the “Disk Selection Screen” I get the options “Install to disk” or “Install into Boot Environment” (pre-selected). So it seems to be at least something on the disk.
So far I just selected “Install to disk” on every sessions I tried since “Install into Boot Environment” sound to me like it just will place a second installation on top of the first one. I don’t know, maybe I’m wrong here. Anyway, I’ll wait to try that until (or unless) someone with more knowledge than me comes along here and tells me otherwise.


#6

Re: https://builds.ixsystems.com/jenkins/view/Push/ I recommend awaiting the next push of ISO and image files.

In the meantime: I should probably ignore the boot environment option. Better to aim for a fresh initial installation.

UEFI

Some computers are affected by a known issue with installers, where an apparently error-free installation is followed by the computer behaving as if the EFI system partition (ESP (separate from the partition for the operating system)) is not present. Technically:

  • both partitions are present
  • both are correctly populated

– and there are various workarounds to make the problematic GUID Partition Table (GPT) usable with the computer. TrueOS-Desktop-12.0-CURRENT-08-01-2016-x64-USB.img installed but not bootable with UEFI on HP EliteBook 8540p · Issue #15 · trueos/trueos-core

Without UEFI

If you find a problem, you can seek or create an issue in the trueos-core area.


#7

You can try booting from rEFind by downloading the USB image. If rEFInd boots your TrueOS system maybe you have to look in your BIOS/UEFI menu in the booting or disk selection section.


#8

We have already updated that “finished” page of instructions for the next package update, but basically you are just forgetting one step - remove the ISO/USB from the system before it boots up again (otherwise you are just booting up the install image again).

The procedure is:

  1. Boot Installer
  2. Do Install
  3. Click “Finish” to return to text menu
  4. Select “Reboot” from text menu
    **5) Before system comes back up - remove the install media (USB stick, DVD, ISO image, etc…)
  5. Let the system boot up normally

#9

Ken: I tried that, but when I follow your point “5” I only get the black screen I mentioned above. And if i pull the USB stick during boot when the first TrueOS screen comes up or during the boot text is running, the only thing that happens is that the system freezes.

I think I better go with grahamperrin’s advise, “awaiting the next push of ISO and image files” and "aim for a fresh initial installation."
It also makes no difference if I try to install with or without UEFI. I tried both with the same result. I didn’t change the settings in BIOS, but the computers boot menu gives me the option to install with or without UEFI.

BTW, my desktop computer runs as a champ with 10.3 and I won’t try anything with it until there is a stable version of TrueOS. All this testing I’ve done with the Asus notebook that I first tried out with 10.3 (didn’t work), Linux Mint (looked like :poop: ), so I threw it out and decided to try an early TrueOS and hope for the best. Well, it didn’t work, so I guess I just wait a little longer.

In this thread A few questions about update from 10.3 and new installation Ken said the final release may be awaited during November. We’ll see. In the meantime, I’ll guess I tuck the notebook away for a while again and say: Keep up the good work guys! :slight_smile:

BTW again. In what state is TrueOS at the moment? Is it beta or a RC version?


#10

https://www.trueos.org/downloads/ there’s a new set of installers for the operating system.

After installing (or updating to) the most recent version of the operating system, use SysAdm to view your Update Manager preferences. Easy switching between repositories, one of which comprises a stable set of software.

Announcements


#11

December 15th 2016 is latest iso, and I had no problems with install.


#12

Still no luck and it’s still the same story :slight_frown:
The install looks successful, but after reboot I just get back to the TrueOS Installation Menu and if I remove the USB I just get the black screen (install proper boot media) as before.

The TrueOS Installation Menu offers six install options: xorg, vesa, scfb, intel, amd and text install. I only tried xorg this time since the other options didn’t make any difference before.

When I start the installation I get the green OK on all from OpenRC except one that says "dev/ufs/TRUEOS_INSTALL: R/W mount of / denied. File system not clean - run fsck. : Operation no permitted."
I don’t know what this means and it runs by so fast so I don’t have the time to read it all, but this is most of it.

The graphical installer runs and looking into the TrueOS Hardware Compatibility I get green ticks on all five points.

Update: I tried to run the amd install as well, but it made no difference.


#13

can you run the non-graphic installer?

have you tried the legacy/sffb drivers?


#14

I tried the text installer but didn’t go all the way since the install process seems to be the same and it’s only the pre-install options that are text instead of graphical.

I don’t know what legacy/sffb driver is. But the notebook I have is quite new with Radeon HD 8180G graphical card.
I don’t know if it’s the graphical driver that is the problem or if it’s something else since the graphical installer runs which it didn’t do when I tried to install PC-BSD 10.3 or 10.2.


#15

that’s why I mentioned the text installer. it bypasses the video driver issue, which will help narrow down he issue

TrueOS is using the new DRM drivers, while pcBSD uses older drivers


#16

I tried to run the text installer now. No difference. I don’t even know if anything have got stuck on the SSD, it seems there is nowhere to tell. Starting the computer without the USB just results in the black screen “Insert proper Boot device” so it seems there is nothing on the drive.

I don’t know where the installation gets gone after it says (not literally, but I you get the picture) “installation finished, Reboot to enter the new boot environment”.

About the drivers. Their in the installation file and I don’t know if or how they accessed and my knowledge of FreeBSD are very limited.


#17

“Insert proper boot device” can you stop in the bios and select a “boot device”, make sure you select the disk you just installed on? I’ve got an Intel NUC that does PXE boot and boot from the internal device, I do everything possible to select the SATA device and save it as the default, but it won’t stick. It may be that the SATA device is not marked as a bootable partition so the BIOS can’t find it.


#18

Follow mer advice first

1: can you get any linux distro installed on the laptop?

2: have you tried grub as bootloader?

this is 2 fold. To make sure (1) hardware is working and format hard drive. And (2) see if the FreeBSD loader is the issue

we’re trying to eliminate things


#19
  1. Yes, I had Linux Mint on it. I worked but I didn’t like the look at it so I didn’t use it.
  2. No, I haven’t tried that.

BUT! I checked the BIOS and this is strange. I don’t find the drive(?) The only boot option is “Realtek PXE B02 D00” and that’s not the name of my drive.
I have CSM enabled but there is no real boot option. I had this problem when I first started the computer brand new after I replaced the HDD (I never started with the HDD that has Windows 8.1 on it) for the new SSD. Then after contacting Asus support I got boot options. But now their gone again.

This could likely be the problem and I don’t know why it occurred again. I made a reset on the BIOS and that made it not even get to the black screen but strait into BIOS when i start it. I guess I have to call the support again.

However, I have a theory. My desktop computer with an Asus motherboard (Windows 8 Ready) didn’t accept anything else when I first tried to install PC-BSD 10.0 about two years ago. The only way to fix it was to remove the BIOS battery to kill all the installed Windows 8 Ready crap in it. After that it worked with no problem. Could it be the same thing in this notebook?
I don’t even know if it has a BIOS battery. I had the main battery out when I replaced the drive.


#20

windos ready cruft.

yes, contacting asus support would be a good optoin