Trident successful installed, but with major problems


#41

sudo cp /usr/local/etc/X11/xorg.conf /etc/X11/

sudo ee /etc/X11/xorg.conf

you will want to find the driver entry, replace modesetting with vesa


#42

(I went into root so I don’t have to type the password every time)

But OK, something happened. But I’m too much of a novice to know what to do with it. What next?

#===========
# Auto-generated X11 graphics
#    card/driver configuration
#===========
# Created by Project Trident
#===========
# DO NOT MODIFY
# - Will be replaced on every bootup by trident_i
# - Place alternate X11 settings into separate fi
#  /usr/local/etc/X11/xorg.conf.d/[something].con
#    OR
#  /etc/X11/xorg.conf
#===========
Section "ServerLayout"
        Identifier     "XFree86 Configured"
file "/etc/X11/xorg.conf", 39 lines

OK, now I got it. went into /etc/X11/xorg.conf (that now has shown up)

Section “ServerLayout”
Identifier “XFree86 Configured”
Screen 0 “Screen0” 0 0
EndSection

Section “Screen”
Identifier “Screen0”
Device “Card0”
Monitor “Monitor0”
EndSection

Section “Device”
Identifier “Card0”
Driver “vesa”
BusID “0:2:0”

EndSection

Section “Device”
Identifier “Card1”
Driver “vesa”
BusID “0:2:1”

EndSection


#43

please remove the

Section “Device”
Identifier “Card1”
Driver “vesa”
BusID “0:2:1”

EndSection


#44

I must open /xorg.conf from Terminal. Need a open-file-command. Is it ‘rm’ (sounds to me like “remove”) or ‘lte’ or something else?


#45

what are you attempting to do?

to open and edit

sudo ee /etc/X11/xorg.conf

to remove

sudo rm /etc/X11/xorg.conf


#46

I’m just trying to open/access the file to remove the section you told me.

The ee-command just shows it in Terminal. However, I can access it from Insight, but I can’t save unless I save it as a new file and then replace the old one.


#47

ee is the editor

you need to be root or use “sudo”


#48

I am in root and I can open and edit /xorg.conf from insight, but I can’t save.

When I try to save I get “xorg.conf already exists. Do you want to replace it?”
So I hit “yes” but it doesn’t save anyway.


#49

at PCDM, did you log in as root?


#50

No, is that possible? How? Do I just enter the root password instead on user password?


#51

i think they have it disabled. then your insight is not running as root then

to edit,

sudo ee /etc/X11/xorg.conf

edit the file, then ESC to save and exit


#52

Well, now I rebooted and tried the root password = No.
I hoped that the new xorg.conf file fixed the problem = No.

Adding root password into Terminal doesn’t let me in to open the files from insight, I just says “Read_Only File”. (didn’t think at that before). As far as I can tell the xorg.conf files need to be opened from Terminal in sudo or root mode and I haven’t got to that yet.

Hitting ESC doesn’t have any effect, it just closes the save window if it’s open.


#53

in a terminal

sudo lumina-textedit /etc/X11.xorg.conf

that gives the lumina text editor to be used instead


#54

Nope!

root@Trident:~ # lumina-textedit /etc/X11/xorg.conf
qt.qpa.xcb: could not connect to display
qt.qpa.plugin: Could not load the Qt platform plugin “xcb” in “” even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: wayland-org.kde.kwin.qpa, bsdfb, minimal, offscreen, vnc, xcb.

Abort

I thought if the problem was that I’ve set Dolphin as default file manager. So I set it back to Insight = No effect.

I Just hope this doesn’t mean that I’ll need to reinstall the OS and fix the resolution before I ad the KDE Baseapps pkg


#55

we got that file from

/usr/local/etc/X11/xorg.conf

in the beginning you had no xorg.conf


#56

Yea, correct. But it didn’t change anything by creating it since I can’t edit it for some reason. But at least we have come a bit on the way.

Anyhow, thanks for the attempt to help, but we have to postpone this until to tomorrow or another day. It’s 2.30 AM here and I’m almost dead, can’t think anymore. Maybe some of the devs can come up with a solution later.


#57

Did a test. I thought if I set the Program setting for Virtual Terminal to Kate instead of QTerminal it may point right and open the xorg.conf file from Terminal so I can edit it, but it didn’t.

Another interesting thing is that I can’t open normal .txt or .pdf files from Dolphin nor Insight. O now it works! But wait (I’m testing and writing at the same time), if I close the file manager and open it again it doesn’t. I see, it’s kinda the same issue I had with 18.03 but now it just affects the files and not Dolphin as a whole. Well, I recognise this and I can live with it.

However, I don’t understand why I can’t edit the .conf file. Could it be that it’s in conflict with the KDE Baseapps? (thought it was a Windows-only problem that programs could be in conflict with each other :wink: )
I’m starting to consider to make a fresh new install and try to fix the resolution issue before I install KDE Baseapps. Do you think this could solve things?

You’ve probably seen that I Posted a question here Monitor Resolution Wrong with New 18.12 Installation but:

  1. If I download a driver from AppCafe, which one is suitable for my Intel card? They all say “xf86-video” something. @2otherjobs seems also to have an Acer but probably some other board
  2. I will probably need to edit the xorg.conf anyway, but I don’t know how?