Trident successful installed, but with major problems


#21

1 & 2: menu button -> Browse Applications -> Desktop Configuration (keep it open). search through the choices.

4: when you set it up, you may not have set the “UTC” to your time. Is it hours off or what?

3: look at the text, and it tells you how. you may also want to look at this place for zsh additions --> https://github.com/zimfw/zimfw


#22

I clicked around there, but I didn’t find anything that looked good. Maybe if I give it a little more time.

Well, it’s actually temporary. The bios-battery is bad, so I have to set the clock every time I start the computer. Haven’t come around to fix that yet. Then I also don’t know if it sets it self for summer daylight saving. Some OS’s do, some don’t.


#23

in desktop config, you will find what you are looking for

ntpdate is unable to set time if too far out.

web search --> freebsd command

you’ll have to manually set date/time after power gos out


#24

OK, now this is really interesting.

As you can see above I made a Trident test install on an external HDD on my stationary machine that went well, even with KDE Baseapps.

So I thought I try the same on the laptop.
Just connecting the external HDD to the laptop and try to run it with the same installation didn’t work, but I expected that. So… A new install,but this time from the laptop and afterwards install KDE Baseapps… Yes! Success! It works! @vit was apparently right. Just installing Trident on the same ZFS Pool as 18.03 seems to stir things up, Thanks!

OK, so far so good. Now lets see… It asks for a system update, so lets update. BOOM!
Well, it updates, goes thru the boot menu and the whole boot, everything in OpenRC shows a green OK, black screen, some more text with smaller characters that ends with “login”. And that’s it… No DE and no login screen!
I rolled back the system in the boot menu and there is no harm done since this just is a test install on a HDD I don’t use for anything else. But I don’t want to experience something like this when I make a hot install.
Any ideas? Bad update?

[2019-01-23 19:54:41] Checking for system updates...
Updating package remote database
Checking system for updates
Kernel: OS-kernel-generic-nodebug

The following updates are available
The following packages will be updated:
----------------------------------------------------
xorg-server 1.18.4_10,1 -> 1.18.4_11,1
xdg-utils 1.1.1 -> 1.1.3
vlc 3.0.5_1,4 -> 3.0.6,4
trident-core 201901101126 -> 201901180936
sudo 1.8.26 -> 1.8.27

pianobar 2017.08.30_3 -> 2018.06.22
pcdm 201811060944 -> 201901180936
p5-URI 1.74 -> 1.76
netpbm 10.85.00 -> 10.85.01
lumina-textedit 1.4.2_201901150747 -> 1.4.2_201901210847
lumina-screenshot 1.4.2_201901150747 -> 1.4.2_201901210847
lumina-pdf 1.4.2_201901150747 -> 1.4.2_201901210847
lumina-mediaplayer 1.4.2_201901150747 -> 1.4.2_201901210847
lumina-fm 1.4.2_201901150747 -> 1.4.2_201901210847
lumina-fileinfo 1.4.2_201901150747 -> 1.4.2_201901210847
lumina-coreutils 1.4.2_201901150747 -> 1.4.2_201901210847
lumina-core 1.4.2_201901150747 -> 1.4.2_201901210847
lumina-calculator 1.4.2_201901150747 -> 1.4.2_201901210847
lumina-archiver 1.4.2_201901150747 -> 1.4.2_201901210847
lumina 1.4.2_201901150747,3 -> 1.4.2_201901210847,3
libdvdread 6.0.0 -> 6.0.0_1
ffmpeg 4.1_3,1 -> 4.1_4,1
OS-runtime 13.0.20190113173435 -> 13.0.20190121163841

The following packages will be installed:
----------------------------------------------------
xf86-video-scfb: 0.0.4_7

The following packages will be removed:
----------------------------------------------------

[2019-01-23 19:57:04] Finished: OK

#25

Well, this reads like a serious off-putter…

What I’ve seen of Lumina it is suitable and capable enough as a thinly-covered-bones DE for users who don’t really need a full-fledged desktop environment. If you do, it just doesn’t cut it, and I’m NOT talking about missing animations and similar bells and whistles.
Touting “we only support Lumina, you’re on your own if you want something else” is NOT how you gain a large user base.

In that light I also find it, pardon the term, downright stupid that FreeBSD have deprecated Qt4 and KDE4. No matter how obsolete they are officially, they provide a very capable (basis for) a DE that does just about everything you get on MSWin or Mac and can be configured not to get in the way.
And, crucially, it worked and was stable. Throwing everything Qt4 out before there’s substantial evidence that Qt5/KF5 are really ready to replace them on your OS is something I’d expect from tiny, “hot and cool” Linux distros, not from FreeBSD. And FWIW, event the latest Ubuntu still has packaging for Qt4 and the KDE4 libraries (and let’s face it why wouldn’t you if an unknown part of your user base still needs those for their own software or job?)

Rant out :slight_smile:


#26

We only support lumina. We’re NOT here to support other DE’s. If that is an issue, then you are free to look elsewhere.

You are only seeing a minor subset of users here. Some issues are self induced, while others are genuine issues.

Maybe the you need to look deeper into the QT/Issues, other than the narrow view of blaming FreeBSD. the QT people and KDE folke have depreciated those items, Since THEY depreciated them, why should FreeBSD be forced to support them. Same goes for Lumina. The Trident devs made Lumina, so they only support lumina

If you want Linux, you know how to get there


#27

As far as I can see on the update list I posted this IS a Lumina issue.
Note. I haven’t switched DE to KDE, I’m just using KDE Baseapps inside Lumina and that works now. And it seems it haven’t updated any of the KDE stuff, just Lumina.


#28

cool deal.

the telegram has folke wanting to do weird stuff, because they did it elsewhere


#29

https://en.wiktionary.org/wiki/deprecate

Qt and KDE have deprecated Qt4 and thus KDE4 because they develop(ed) them and have successors. This is inevitable and normal because they cater to developers (but note that the KDE4 libs have been maintained until about a year ago and maybe still are).
Distributions have different priorities: they cater to users and if they want to appeal to the largest possible user base they’d better try to support everything that might be in demand as long as that’s reasonably possible.

That’s not a narrow view, that’s a very broad and generous view.

The Trident devs didn’t make GTk or Gnome, so should we assume they don’t assume those technologies either (and so good luck with dependents like Firefox, LibreOffice etc)?

I’m not planning to troll this issue, but indeed I’ll probably be looking elsewhere for less sectarian support politics should I want something other than Linux and/or Mac OS.


#30

actually you took on the roll of troll. just moved to that level and responded in kind


#31

OK, Trident is in on the laptop with the KDE-Baseapps and everything works. It actually works better than 18.03 and the battery life has improved :star_struck:

There are only two minor flaws:

  1. I Have sound but still no mic. When I Look in the Mixer => Recording unit it says “monitor”, and the option “mic” does not exist in the drop-down menu. I tried before to install PulseAudio into 18.03. but it didn’t have any effect. I wonder if its audiocard isn’t fully supported?
    The only info I find on its audiocard is this:

Optimized 2nd Generation Dolby® Sound Room®4 audio
enhancement, featuring Dolby® Headphone, Dolby®
®Natural Bass and Dolby Sound Space Expander
High-definition audio support
S/PDIF (Sony/Philips Digital Interface)5 support
for digital speakers
MS-Sound compatible
Built-in microphone

  1. Is there anyway to get a higher screen resolution? Everything is too large on the screen. At the moment it runs on 1024 x 768 and that’s too low. And there are no other options. Is there any way to force a higher resolution?
    This is the info I find on its graphics card:

Mobile Intel® GS45 Express Chipset with
integrated 3D graphics, featuring Intel® Graphics
Media Accelerator 4500MHD (Intel® GMA 4500MHD)
with up to 1759 MB of Intel® Dynamic Video Memory
Technology 5.0 (64 MB of dedicated video memory,
up to 1695 MB of shared system memory), supporting
Microsoft® DirectX® 10
Dual independent display support
16.7 million colors
External resolution/refresh rate:
• 2048 x 1536: 60 Hz
• 1920 x 1440: 75/60 Hz
• 1920 x 1080: 100/85/75/60 Hz
• 1856 x 1392: 75/60 Hz
• 1792 x 1344: 75/60 Hz
• 1600 x 1200: 100/85/75/60 Hz
• 1600 x 900: 60 Hz
• 1400 x 1050: 60 Hz
• 1366 x 768: 85/75/60 Hz
• 1280 x 1024: 120/100/85/75/60 Hz
• 1280 x 960: 85/60 Hz
• 1280 x 768: 60 Hz
• 1152 x 864: 100/85/75 Hz
• 1024 x 768: 120/100/85/75/60 Hz
• 800 x 600: 120/100/85/72/60 Hz
• 640 x 480: 120/100/85/75/60 Hz
MPEG-2/DVD decoding
WMV9 (VC-1) and H.264 (AVC) decoding
HDMITM (High-Definition Multimedia Interface)
with HDCP (High-bandwidth Digital Content
Protection) support


#32

2: Log out , when PCDM shows up, in the top right corner. click on icon.

chnage DPI, I’d recommend “medium” as a starting point. change as needed

1:, anywhere on the desktop, left mouse click, preferences , display.

you can change the resolution there, depending if the freebsd video drivers support that resolution


#33

Trying to change the DPI on the login screen has no effect.

Then right click (not left click - you sure you don’t live in the UK? :wink: ) looking on the display config. the only resolutions available are 1024x768 and 800x600.
It seems FreeBSD’s driver doesn’t support my computer.


#34

they do support your video card, just not the way we always want :frowning:

type --> about <-- and copy/past in the reply


#35
What is the auto-generated /usr/local/etc/X11/xorg.conf?
John
groenveld@acm.org

#36

OK, now logged in from the laptop.

Trident% about
Project Trident Information
--------------------------------------
OS Version: 18.12-RELEASE
Build Date: 20190113173435
--------------------------------------
TrueOS Sources Used:
  Base Repository: https://github.com/trueos/trueos
  Base Commit Branch or Tag: trueos-stable-18.12
  Ports Repository: https://github.com/trueos/trueos-ports
  Ports Commit Branch or Tag: b42445dec15979dabc50c64073c0fe08dd870a9a
--------------------------------------
System Specs:
  Boot Method: BIOS
  Genuine Intel(R) CPU           U4100  @ 1.30GHz
  Physical CPUs: 2
  Physical Memory: 3.86 GB
--------------------------------------
GPU Information:
  vgapci0@pci0:0:2:0:   class=0x030000 card=0x029b1025 chip=0x2a428086 rev=0x07 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Mobile 4 Series Chipset Integrated Graphics Controller'
    class      = display
    subclass   = VGA
  vgapci1@pci0:0:2:1:   class=0x038000 card=0x029b1025 chip=0x2a438086 rev=0x07 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Mobile 4 Series Chipset Integrated Graphics Controller'
    class      = display
--------------------------------------
Network Device Information
  alc0@pci0:1:0:0:      class=0x020000 card=0x029b1025 chip=0x10631969 rev=0xc0 hdr=0x00
    vendor     = 'Qualcomm Atheros'
    device     = 'AR8131 Gigabit Ethernet'
    class      = network
    subclass   = ethernet
  iwn0@pci0:2:0:0:      class=0x028000 card=0x13058086 chip=0x00838086 rev=0x00 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Centrino Wireless-N 1000 [Condor Peak]'
    class      = network
Trident%

#37

BIOS, so the video driver is scfb, i think

can you see the the video driver is set to?

sudo cat /etc/X11/xorg.conf


#38

Checked the BIOS. It’s a simple BIOS with just a very few setting and nothing about the video card.

cat: /etc/X11/xorg.conf: No such file or directory
Trident%

Looked in the root catalog /etc/X11. It’s empty.


#39

how familiar are you with using the terminal?


#40

I know a few simple commands. But I’ll be happy if you can guide me through it.