Trident successful installed, but with major problems


#1

First, the benefits.

  1. The install it self went flawless.
  2. Now I have wireless connection (didn’t have that since I upgraded to 18.03)
  3. I have sound (also system notifications),but still no mic, but I can live with that so far
  4. It runs smoothly and fast

BUT… The problems are that insurmountable so if this get don’t solved very soon I will be forced to leave TrueOS/Trident. I can’t sit on a outdated system forever.

  1. Insight File Manager it totally useless and doesn’t show my files in the home directory and there is no way to copy and paste anything (copy or cutting is doable, but there is no paste).
  2. Due to this I cannot paste and install my backups from Thunderbird and Firefox. Terminal just says “tar: Error opening archive: Faailed to open backup.tar”. Due to this I cannot use mail or Internet with the Trident install since it just would mess everything up.
  3. I installed KDE Baseapps. The install it self meet no problems, but… Dolphin opens but shows just an error message “Could not create 1/0-slave. Cannot create outlet to start 1/0-slave for the protocol ‘file’” (hope you understand, I just translated what it says that looks like a Google-translation to me) no files. If I can’t use my files I could as well upload everything to “the cloud”, leave it open to the public and use some shitty ChromeOS 'puter with no harddrive.

KDE and Dolphin works good but not perfect on 18.03 but that’s KDE4, Trident uses KDE5 (I looked for KDE4 in AppCafe after I ran into the problems with 5, but it’s not there.

On the less serious side is that the text on the desktop icons are giant and that the cursor looks more like a drop than a cursor. Don’t know if this can be fixed.

However, these two things are not that serious as the things above. I was thinking if it could have something to do that I use Swedish setting on the OS and that some directories and system texts are in English. But I don’t think it could because even if Insight can’t open a director with another name, it should at least show it, not just say “there is nothing here” and there are some directories where the name is the same in both languages.

At least I’m glad I didn’t try this on my main computer that still is on PC-BSD and probably needs a format to accept Trident because then I would have gone nuts.
Talking about that. This discourse won’t let me open a new thread since it asks for a category and that can’t be done for some reason. Too old browser maybe? So I’m sending this from the rolled back laptop.


Monitor Resolution Wrong with New 18.12 Installation
#2

FreeBSD depreciated kde4/qt4. not available

trident DOES NOT use KDE.

trident uses QT.

Drop to terminal and see who owns your ~/HOME directory

These are NOT a trident issue, but feel free to di what you must


#3

Well, what shall I do? After all KDE5 is in AppCafe. What shall I use as file manager? According to my eyes is Insight garbage. Seems it can’t read the backup reversal commando 'tar xvf backup.tar', it’s not dynamic, I don’t find how to personalise it and it seems there is no smooth way to move files back and forth.
I see the HOME directory and can open Insight, but there is almost nothing I can do with it. And that’s bad since I use the file system a lot.

So do you say there is no way this can be fixed? Any suggestions? I use to like PC-BSD, TrueOS and even Trident seems kinda nice if there Just is a way to make it usable. But if not, is this good bye then?

Problem is that I’ve set my harddrives to use the ZFS file system and I don’t like Windows nor Linux…
Do you know if GhostBSD is compatible with FreeBSD/TrueOS i.e. uses ZFS, the same kind of BE and the same commands?I’m thinking if I can install it in the same BE without having to format/clean out the drive?

I really don’t want to give up on Trident, but if there is no way out i guess I have to.

I thought QT was a development tool, not a file manager.

Yes, it is, or it may be a Lumina issue. At least it’s a Insight issue and I don’t know if that’s a part i Trident or Lumina.


#4

open a terminal and type;

ls -la /usr/home

what do you see?

ls -al /usr/home
total 52
drwxr-xr-x 4 root wheel 4 Jan 16 15:03 .
drwxr-xr-x 17 root wheel 17 Nov 28 05:29 …
drwxr-xr-x 16 test test 28 Jan 16 15:19 test

is your ~/HOME directory owned by you?


#5

Yes, I get what you describe., only instead of “test” I get my username “robiww”

3’rd row end with '26 jan. 18 01:53 blue text ’
I also get a 4’th row that ends with '56 jan. 17 17:19 blue text ’

It’s only I who using this computer, so it probably can’t be any other username than I wrote at the install.
Note: I’m using a full install, not virtual box or something like that.


#6

When you paste a file, viewing in Insight is often not updated - but sometimes it works. If not, then it helps to switch to another directory and back, then the file is visible. F5 brings nothing in that case. Actually never.

I often wonder why I still use Insight again and again, maybe because I love the challenge.

If I really want to deal with something quickly I use ‘Thunar’ - with the great advantage that it offers bulk rename. On the other hand ‘Thunar’ can’t deal with snapshots. Insight can.


#7

The problem isn’t that I can’t see the pasted files. There is simply no option to paste anything into Insight. There is no paste-option in the menu, not by right-clicking and Ctrl+V doesn’t work.

Yea! Problem is there seems not to be anything else, at least not for Trident. In TrueOS I use KDE4 Dolphin, it works good, but only ones. If I close it and reopens, it opens but I get an error message instead of seeing my files. The way around that is to logout Lumina and login again.

In Trident it’s kinda the same, KDE5 Dolphin opens but I just get the error even the first time, so it’s unusable.

What is ‘Thunar’? I don’t care about snapshots, I just want to access my files and be able to manage them.

I’m not looked on KDE with Dolphin, I just want a file manager that works (Insight doesn’t) and is easy to use. Then if it’s from ‘Mate’ or whatever doesn’t matter. Just a file manager that works, looks ‘normal’ and is dynamic so I can personalise it etc.

Then of cause I need to be able to roll back the backups from Firefox and Thunderbird. Since I couldn’t paste it into Insight, I pasted it onto the desktop. The command should find it there, but nothing ‘no file’.

I miss PC-BSD. It was an admirably OS.


#8

It is not clear how you installed KDE 5, and is it possible that you did not install the entire KDE 5 package?
Perhaps you should uninstall whatever KDE you have and reinstall again.

If you are running Trident 18.12, you can find KDE 5 in App Cafe (use the Search Box) or to add the package start up a terminal and as either root or using sudo type after the # prompt:
#pkg install kde5

I like Trident 18.12 a lot better than TrueOS 18.03. 18-Prereleases seemed tired, but the 18.12 release is fast, smooth, and worthy of committing to it.

Also, the VirtualBox app lets you install just about any operating system into a virtual machine, so you can run the newer OS’s without messing up your main OS.


#9

First please note: I thought to run Trident 18.12 RELEASE 2019-01-15 as a full install, not as VirtualBox. I’m using BSD as primary systems both on my stationary desktop as well as on my laptop (still PC-BSD on the desktop and TrueOS 18.03 on the laptop). So I’m not using it for development or testing etc. but as hot use.
Now that the final release of Trident was out I thought now to switch to it on both machines. Since I’m unsure if PC-BSD can share the same ZFS-pool as Trident and may need a full format, I tried it on the laptop first were I can install it without harming the existing system. But as you can see above, it wasn’t what I expected. Very disappointing!

I installed KDE5 by using the command pkg install kde-basseapps
When I first learned this I think I may have been on 17.03 and someone told me first to use the command pkg install kde-runtime.
Anyway that didn’t serve no purpose on Trident, so I just kept on with the install.

Afterwards I saw that KDE Baseapps is available on AppCafe, but I don’t think it makes any difference in you install it from AppCafe or Terminal. Unless the failed installation of KDE Runtime messed up things? But as far as I can tell it didn’t install anything.

I didn’t use sudo or root, seems it’s not necessary to get KDE installed.
With pkg install kde5 I think I get the full KDE package with loads of programs (tried that before) and I don’t want that.

In the meantime I tested out GhostBSD on an external test drive via USB. File manager, menus and so looks kinda nice, but the Mate DE seems not as flexible/dynamic as KDE. I also noticed that it can’t manage NTFS-drives and I didn’t get any Internet connection (however, these two issues may have been due to that I drove it from a USB-port). Otherwise it worked good and testing to roll back from the backup.tar file went without any problems what so ever.

However, if I just can get the KDE issue right, I rather stay with TrueOS/Trident most because I know it better and it looks nicer, except that Insight-garbage :face_vomiting:
That’s really garbage. I just don’t understand how the devs could come up with something like that on an otherwise good system? TrueOS/Trident is good, Lumina too, but then they should have made a full KDE-porting to the system with e.g. that great Dolphin file manager instead of spending time on developing that ugly Insight.


#10

enjoy GhostBSD


#11

Did you install into BE or do a clean install? Upgrade through BE is far from perfect in my experience. At least not from 18.03.

Neither Insight nor Thunar worked for you? Strange. Thunar is a default FM from XFCE, perhaps one of the most polished DE out there running on BSDs. Maybe you messed up your user permissions?
Drop to a terminal try to manually un-tar your backup into your home directory. What do you see?


#12

Yea! But like I said, I actually like TrueOS/Trident better if it wasn’t for Insight and the impossibility to roll back from the backup.tar file.

However, now something interesting has happened.
I deleted the Trident BE and rolled back the system to 18.03 that worked mainly good incl. KDE, except for the wireless that didn’t work. Well, now after I had Trident installed does the wireless suddenly work. It can’t determine the connection strength and speed, but it’s on :slight_smile: and I don’t get the error message at start up anymore that it’s missing something in “/etc/in”.
A quick look shows that there is a directory “/init.d” that contains mostly .txt files. Could that have anything to do with it?

Anyway, now that I have wireless, I can use the laptop for what it’s meant (on trips), stay on 18.03 and hope that the devs soon will solve the file manager problem.

Because, even though you say…

KDE5 is in fact in Trident’s AppCafe for some reason, and I don’t think it’s there to tease us users just for the fun of having a program there that doesn’t work. Please tell me that I’m not completely way off? :wink:


#13

I Installed into BE since as in the quote you used I didn’t want to harm the existing system. In a clean install everything gets lost, and if Trident doesn’t work and I can’t roll back to a previous BE, then I’m seriously f**k*d!
According to your explanation I’m sort of in a Catch 22 situation here.

No, I didn’t try Thunar, only Insight and KDE Dolphin.

I did try to install the backup.tar from Terminal. I don’t know any other way, and when I do that it finds its own way into the Home directory.


#14

You are correct KDE is in AppCafe, but you can unofficial support here or telegram


#15

I’m sorry, I don’t follow you here. Did you mean “unofficial get support here or telegram”?

In that case, that’s exactly what I’m looking for, i.e. getting KDE to work in Trident, then I would be happy and don’t need to move to GhostBSD :slight_smile:

But you just told me:

And:

I can live with much, but not with Insight, it’s just too worthless. So I just thought that if there is no solution, then I just have to say thanks for the coffee (“tack för kaffet” a Swedish saying, don’t know if it’s translatable into English) and just move on (actually what it means) :wink:


#16

RobinW said:

“I installed KDE5 by using the command pkg install kde-basseapps . . . With pkg install kde5 I think I get the full KDE package with loads of programs (tried that before) and I don’t want that. . . . However, if I just can get the KDE issue right, I rather stay with TrueOS/Trident most because I know it better and it looks nicer, except that Insight-garbage”

Comment:
You may have misunderstood Rod Myers when he said “Trident does not use KDE.” The term “KDE” in that context means he was referring to KDE4 rather than KDE5.

My insight (unapologetic pun) on your problem is you would have a much better KDE5 experience if you installed its full (i.e. “meta-app”) version (pkg install kde5). Although you get more apps than you want, you don’t have to use them, and any icons deposited onto your desktop can be deleted or parked in another folder. However with the full KDE5/Plasma Desktop Environment, you would get a fully functional Dolphin.


#17

trident offers official support only for the lumina desktop only

any other desktop you install, is in you


#18

My experience with Ghost is that on first boot after install the network is disabled (a small red dot on the network icon in the top right corner of the screen). Right click and Enable and it’s sorted.


#19

On my Trident install (installed from the currently available version) right click Copy and right click Paste are both available and work perfectly.


#20

Some good news at last :slight_smile:
I Installed Trident on my main machine with an external HDD attached to a USB port, so it’s not yet on the computer own drive. I also installed KDE Baseapps, and… What do you know? everything works!
One reason I can think of that I got it to work is that when I looked a little harder on the install menu, I noticed that the graphics and CPU settings were hidden, so I opened it and set it to the correct standards for my computer. I didn’t think about that when I made a test install on the laptop. Could that be the reason KDE didn’t work?

So I’m quite satisfied with Trident now, at least on my stationary machine, and I’m now considering to do a serious installation on this machine.

Just a few kinda stupid questions:

  1. The color schemes are a little strange. In I use a light scheme the dark characters disappears and vise versa if I use a dark scheme. So far I found a compromise with Color scheme “Dusk” and Icons “Le Trident (Dark)” but it don’t looks very nice.
  2. Is there a way to get a “normal” cursor? Doesn’t matter how I set it, it looks the same anyhow.
  3. Can the info text in QTerminal be turned off somehow?
  4. How do you set the clock and date in Trident? I know I can do that in BIOS/UEFI, but it should be necessary to go that way.