Trident: hard drives not shown in installer


#1

I decided to try Trident Beta3 and never succeeded installing it.

First issue: Machine with multiple GPU’s has Xorg fail - no usable screens or something along the lines. I tried using simply Intel iGPU (Haswell i7 4770) and Xorg failed again. I disabled iGPU completely in BIOS and tried using my main GPU : Nvidia GTX1050Ti - succeeded there (vesa though, not Nvidia’s driver).
PC has CPU’s iGPU and discrete Nvidia’s card. I usually have both enabled and use Nvidia primarily but also make use of built-in QuickSync hardware video encoder Intel iGPU has.

Second and more serious issue : in graphical installer, I got stuck on selecting hard drives - nothing appeared there (I have one SSD and 2 x 1TB mechanical HDD’s in my PC. I rebooted multiple times, tried also UEFI mode, nada…

Any advice?


#2

dual video systems have always been a pain. Try disabling the nvdia, using the intel video card

search here, for others advice


#3

I have always found that disconnecting the drive/s which are not to be installed on, to be a good idea. Don’t know if this would help in this case, but it’s always a good idea. Guurantees you won’t put it on the wrong drive. Of course, you may have multiple partitions on a drive, so then you have to be careful. I did once succeed in erasing an os and putting a new one in its place, but it was only Vista, so I wasn’t too upset.


#4
Escape to the shell and confirm the OS can see the disks:
# camcontrol devlist
# gpart show

John
groenveld@acm.org

#5

The problem is with the harddrives, not with the video cards.
I have same problem.


#6

I have same problem,but how can I login in the terminal (login name and pass)?


#7

What I found out.

Drives are just fine. Both drives had GELI encrypted ZFS mirror on them (old FreeBSD installation). Once I had destroyed all the partitions, rebooted and tried again, drives became visible in installer.

Problem with video cards is a separate issue. Xorg seems to be unable to handle situation where it can see two GPU’s at once. Getting it work was complete PITA in vanilla as well. Until I found out how to fix it. Had to define primary card in Xorg conf there. Read-only Xorg working beneath the installer is unable to do it and it’s not like I can actually edit it’s configuration file it on installation disk either.


#8

geli encryption is still a work in progress :frowning:


#9
IIRC Beta3 has root with no password.
John
groenveld@acm.org

#10

then you didn;t enter one.

it asked for root password, and then login account info


#11

Thank’s jgroenveld this works! Thank’s again! :slight_smile:


#12

It could be WIP. I found out it seemed to offer only single drive installer later, when I had rebooted with a EASEUS live disk and wiped the drives clean of previous data.

Generally already existing partitions are visible along with the online/existing disks in Operating System installers (not only BSD but any, starting from Windows 98). It was something I did not expect, so I came here and posted about it, only to find out the cause few hours later.


#13

I can confirm this.

Both recent version of the Beta that I tried failed to see the hard drives at all, this was on page 2, I believe, of the graphical installer.

By clicking on previous and then next, several times, going back to Page 1 of the Install and then forward to Page 2, the drives finally appeared, but showed NO disk space available and NO option to format, even though I had selected “entire disk” for the install. This happened with a 128 gb Cruzer SSD disk and also with a confentional Western Digital disk.

Being unable to get past the disk election I have gone no farther.

Jim