Trident Beta 3: Emacs crashes on startup


#1

I installed Trident beta 3 today and then Emacs via pkg install emacs, and trying to run it in graphical mode crashes immediately on startup with

Xlib:  extension "GLX" missing on display ":0".
Fontconfig error: Cannot load default config file

(emacs:6891): Gtk-WARNING **: Could not load a pixbuf from icon theme. 
This may indicate that pixbuf loaders or the mime database could not be found.
**
Gtk:ERROR:gtkiconhelper.c:494:ensure_surface_for_gicon: assertion failed (error == NULL): Failed to load /usr/local/share/icons/Adwaita/24x24/status/image-missing.png: Unrecognized image file format (gdk-pixbuf-error-quark, 3)
Fatal error 6: Abort trap
Backtrace:
0x37640d <XSetWMNormalHints+0x2cf7d> at /usr/local/bin/emacs
0x357ea6 <XSetWMNormalHints+0xea16> at /usr/local/bin/emacs
0x3777ce <XSetWMNormalHints+0x2e33e> at /usr/local/bin/emacs
0x377843 <XSetWMNormalHints+0x2e3b3> at /usr/local/bin/emacs
0x376019 <XSetWMNormalHints+0x2cb89> at /usr/local/bin/emacs
0x80079e166 <pthread_sigmask+0x536> at /lib/libthr.so.3
Abort trap

Given that error message, I did pkg search pixbuf, and came up with gdk-pixbuf2. But that’s already installed. It definitely does appear to be something related to the graphical aspect, though, since emacs -nw in a terminal window works just fine.


#2

fresh whole disk install or install into Boot Environment?

I’m beta3 in a BE, and I just installed it loads fine from the terminal

edit:

try renaming the original folder to something else and try


#3

I have Beta3 in Virtualbox, and I just installed it, and it also loads fine for me. From both the desktop shortcut that it created and the terminal.


#4

This was a fresh whole disk install. I think I’ve literally done nothing except install the OS, and then install Emacs and a couple other packages.


#5

from the terminal, this is what I show being installed

sudo pkg install emacs
Updating TrueOS-ports repository catalogue…
TrueOS-ports repository is up to date.
Updating TrueOS-base repository catalogue…
TrueOS-base repository is up to date.
All repositories are up to date.
Checking integrity… done (0 conflicting)
The following 5 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
emacs: 26.1_3,3 [TrueOS-ports]
libotf: 0.9.16 [TrueOS-ports]
mailutils: 3.4_1 [TrueOS-ports]
m17n-lib: 1.8.0_1 [TrueOS-ports]
m17n-db: 1.8.0 [TrueOS-ports]


#6

another user is having issues with a game as well.

fresh install, and his does not work. I can install run it and it works.

No clue at this point


#7

That is a huge clue right there.
“file /usr/local/share/icons/Adwaita/24x24/status/image-missing.png”
Looks like the fatal error is that the above icon can’t be parsed/recognized.
Could be anything, perhaps it doesn’t exist (theme Adwaita bad), or it’s not a PNG file.
If you have any existing emacs config (.emacs file or .emacs.d directory) try moving that out of the way.


#8

This was immediately after the pkg install, so no ~/.emacs or ~/.emacs.d. Just now confirmed that I get the same behavior with emacs -Q, so it shouldn’t be reading any startup files.

I looked at the image file earlier, I should have said–it seems to be a perfectly normal PNG; certainly Phototonic opens it fine. For testing, though, I did copy another couple of PNGs to that filename, and got exactly the same error with both.


#9

For my own edification, did you su and then pkg install OR did you “sudo pkg install?”


#10

Good enough.


#11

Not sure, actually. I think the first time I used su, but I wouldn’t swear to it. In any case, I just tried it both ways (with sudo pkg remove emacs && sudo pkg autoremove before and between), and got the same result both times.


#12

that error is very similar to the user with the game

claiming an icon is corrupt, but can view it with a picture program.

I’m not sure what is going on with that


#13

So, not sure if it’s related, but it falls in the “graphical” bucket so I’ll mention it just in case. Wasn’t familiar with Falkon, so I started it up for a test spin and got a completely-black window, except for the title bar (which looks normal). Here’s what I get when I run it from a terminal:

[carson@pertinax ~]$ falkon
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-carson'                                                                                                                                                                 
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-carson'                                                                                                                                                                 
Fontconfig error: Cannot load default config file                                                                                                                                                                                            
Falkon: 1 extensions loaded                                                                                                                                                                                                                  
QKqueueFileSystemWatcherEngine::addPaths: open: No such file or directory                                                                                                                                                                    
[49840:353821952:1003/193003.060135:ERROR:gl_context_egl.cc(117)] eglCreateContext failed with error EGL_BAD_CONTEXT                                                                                                                         
[49840:353821952:1003/193003.076850:ERROR:gl_context_egl.cc(117)] eglCreateContext failed with error EGL_BAD_CONTEXT                                                                                                                         
[49840:353821952:1003/193003.085123:ERROR:gl_context_egl.cc(117)] eglCreateContext failed with error EGL_BAD_CONTEXT                                                                                                                         
Fontconfig error: Cannot load default config file                                                                                                                                                                                            
[49840:353821952:1003/193003.101034:ERROR:gl_context_egl.cc(117)] eglCreateContext failed with error EGL_BAD_CONTEXT

Not sure what that’s about.


#14

what is your video card?


#15

NVIDIA Quadro K1200. I’m using the nvidia-driver-390.77_2 package, looks like.


#16

i don’t own an nvidia, so I don’t know which driver set you need.

can you triple check to make sure you are using the correct driver package?


#17

When I go to nvidia.com and put in my card and FreeBSD, it recommends the 390 series driver (390.87 versus the package’s 390.77, but still 390). So, to answer your question–I think so? Is there a better way to tell?


#18

Since AppCafe is still broke

this is the link for the packages built against this release

http://pkg.project-trident.org/pkg/release/ports/FreeBSD%3A12%3Aamd64/latest/All/


#19

I was already running the same version of the nvidia-driver package listed there, but I downloaded that one and (re)installed it for good measure. No change in behavior.


#20

the other topic I mentioned, was deleted by the OP

was trying to see of he/she had an nvidia card trying to narrow down