Trident Beta 3: Can someone successfully install "pkg-provides"?


#1

I installed the package but it doesn’t work.

pkg install pkg-provides
Updating TrueOS-ports repository catalogue...
TrueOS-ports repository is up to date.
Updating TrueOS-base repository catalogue...
TrueOS-base repository is up to date.
All repositories are up to date.
Checking integrity... done (0 conflicting)
The following 1 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
	pkg-provides: 0.5.0 [TrueOS-ports]

Number of packages to be installed: 1
[1/1] Installing pkg-provides-0.5.0...
[1/1] Extracting pkg-provides-0.5.0: 100%
Message from pkg-provides-0.5.0:

======================= pkg plugin activation ========================
  In order to use the pkg-provides plugin you need to enable plugins in pkg.
  To do this, uncomment the following lines in /usr/local/etc/pkg.conf file
  and add pkg-provides to the supported plugin list

  PKG_PLUGINS_DIR = "/usr/local/lib/pkg/";
  PKG_ENABLE_PLUGINS = true;
  PLUGINS [ provides ];

  After that run `pkg plugins' to see the plugins handled by pkg`.

  To update the provides database run `pkg provides -u`

  ====================================================================

Check if it is installed:
ls -la /usr/local/lib/pkg/
total 571
drwxr-xr-x 2 root wheel 3 4 Okt. 17:42 .
drwxr-xr-x 92 root wheel 2390 4 Okt. 17:42 …
-rw-r–r-- 1 root wheel 27240 23 Sep. 20:30 provides.so

I added to /usr/local/etc/pkg.conf:
PKG_PLUGINS_DIR = “/usr/local/lib/pkg/”;
PKG_ENABLE_PLUGINS = true;
PLUGINS [ provides ];

And tried to update:
pkg provides -u
pkg: unknown command: provides

For more information on available commands and options see ‘pkg help’.


#2

Did you do this as suggested by the install?


#3

Yes, it shows no plugin at all:

pkg plugins
NAME DESC VERSION


#4

Ok, that’s why when you did pkg provides it failed. Now to try and figure out why.
Did you run “pkg provides” as your normal user or as root? If normal user, try running as root, either su or sudo should be fine.


#5

I always use pkg as root.

BTW, I also tried to install the github version from https://github.com/rosorio/pkg-provides
It fails as well. I informed the author about this in an issue.


#6

pkg provides will not work here. Works fine in mine FreeBSD-11.2 jail
Different pkg versions, here and there, I guess :frowning:


#7