Trident 18.12Pre Release2 Installs ! But NO Terminal or xterm ? How start terminal?


#1

Installed 18.12 Pre Release 2 successfully on an HP 15 Laptop.

The reason I could never get past page 2 of the installs before was found - it was not seeing my language choice (American English) so I clicked on “Previous” and selected “American English” again just to see if that was keeping me from seeing the “Next” button activate. It was, because after I selected British English, the “Next” button activated andI could proceed to the next page and the rest of the installation.

OK, so it installed OK, but when I went to type "terminal"in the application list (Lower left corner of the screen) there’s NO terminal !! No xterm. How the hell do you start terminal to type in some commands ??? !!!

I did see a “terminal” selection when I right click on the desktop but that did nothing except ask me if I wanted to use xterm to open up some editing program.

I selected “bash” as my shell when installed, if it helps any to know that.

Thanks
James


#2

Ctrl+Alt+F2, for example, log in and use pkg install to deploy missing packages.


#3

the default terminal is qterminal, and it is installed


#4

Typing “qterminal”, QTerm, qterm does not do anything.

Will try to install the package with pkg install.

Thanks
J.


#5

did check/uncheck anything during install?

During every build I have ttest drove, release, testing, etc. qterminal is always installed. Did you look far enough down the start menu?


#6

I looked again, there is no qterminal.

In the install process, I clicked on “bash” as my default shell, which, of course, automatically unclicked “fish”. I have no idea what “fish” is.

If I type "bash"in the “Type to Search” box (lower left hand corner of screen) it finds bash and then I click on that and there is some hour glass activity and then nothing happens. Same zsh. Then I tried right button click on desktop and went to /us/local/bin/bash and tried to start it from there. Again, hourglass but then nothing. Finally I tried pin bash to desktop and start it from there. Same result.

I could reinstall and leave the default shell as “fish” (whatever that is, never heard of it) if you like, just to see what happens.

But qterminal is nowhere to be seen. The last entries in the lower left corner lest are Lumina Archiver, Lumina File/Information, Lumina Search, Network Manager, SysAdmin Client, TrueOS Mixer Tray, TrueOS Network Tray and that’s it.

Thanks again,
J.


#7

just did a fresh install with the latest ISO, and added bash

install went as expected.

qterminal was installed, and the default was bash.

It’s in the start menu, just default puts it toward the bottom.

look again


#8

Then the incremental search window should find it when I type “qterminal” but doesn’t.

I’ll reinstall and see if I find what I clicked or unclicked wrongly.

Thanks
J.


#9

Did reinstall this time without changing default zsh.

Installs OK but no qterminal anywhere.

There is bash and zsh which appear when I type those words in the incremental search window (Lower left corner of screen).

As before, when I click on them, there is some hourglass and disk activity for a moment or two and then nothing.

Will wait for next release.

Thanks again,
J.


#10

anywhere on the desktop, left click. At the top you should see terminal

click it


#11

Ya I tried that, the Lumina Text Editor opens up !!!

Thanks
J.


#12

If you use different virtual console (any other than graphical vt9, with ctrl+alt+f2 for example) to log in, you could check qterminal is actually installed or error messages it produces on start with which qterminal and qterminal. If it’s missing, just install it with sudo pkg install qterminal. Alternately, sudo pkg install xterm or sudo pkg install rxvt-unicode to install other terminals.


#13

Yes of course, thanks !

But…I’m a little curious why it doesn’t show up in the Application list in the lower left and…

Uh…wait a moment… I don’t want to know !!

Keep up the good work, I will try installing.

Thanks again,
J.