Total catastrophy installing Trident

#1

My main computer is dead!
I installed Trident initial by USB, it went so so. It’s in but I have no Internet. I can’t update to U8 because there is no Configure in Update Manager and like I said, it has no Internet. So please don’t ask me to post any outcome of any commands because I CAN’T since it has NO!!! internet!!!

This is the worst that could have happened and I’m NOT very happy now!!! I wanted to avoid this in the longest, but now it’s done, and it seems to be no return. This is a major disaster not at least since I have all my works stuff in that computer. I’m on my laptop now.

Any ideas how to get around this? The only installation files I have for Trident are 18.12 Initial on USB and U8 on DVD.
I installed with UEFI setting. While I wait for reply I’m trying to fix this, first with the DVD, then with the USB and I think I’n gonna try the standard BIOS setting instead.

0 Likes

#2

@Robiww can you post the output of…

Sorry, just kidding. Really. (If I was next door I’d bring a bottle of aquavit)

The disk you installed on, was it already partitioned or was it brand new?
I personally have had better luck with a BIOS install instead of UEFI.
If it was already partitioned wiping out the first bit of it may help. You’d need to boot something that would let you drop to a command line or “rescue shell”. Even a Linux Live disk would work.
If you can get to a shell, figure out what device you want to install on (the SSD if I’m remembering correctly). Lets say it’s “ada0”. camcontrol devlist should give you enough to figure it out.
then
dd if=/dev/zero of=/dev/ada0 bs=1m count=4
to zero out the first 4m of the device.
Then see if the install works for you.

Sometimes the installers (not just Trident, but Linux too) try to be too smart if they see a partition table.

I had to do that with a USB drive my wife uses under Windows: Windows kept complaining about it, even after a full format under Windows. I finally did the dd thing on my BSD system, then Windows to format it, all fine.

0 Likes

#3

Progress… You had already backed up your data… And Trident wasn’t installing, now it’s installed and working you just have no internet correct?

0 Likes

#4

@mer
Yes, the disk is partitioned, I had PC-BSD on it. Just tried the DVD with BIOS instead of UEFI = Same result. “Broken”. No disks show up at “Select Installation Location”.
I could use the DD command, but I’m afraid it may burn the SSD. It has done that to a USB-drive and I know SSD’s (kinda same technique as USB’s) have limited writing times.

I installed on ada0 so the Seagate should be unaffected, but I can’t access it as it is now and even if I could recover it, it’s no meaning since I cannot do anything with that computer as it is now anyway.

One solution I can think of is if I could get another version of Trident (U-something) that has the Configure in the update manager and that maybe is better. I also have the Initial and U8 iso’s saved on USB I’m thinking if I burn U8 onto a USB-drive?

Just tried the DVD with BIOS, no luck. Now testing with the USB but with BIOS.

Yes, all data is backed up. Trident installed but won’t start by it self, I have to go into the computers boot menu and manually select the right drive. And I have no Internet, but I don’t think it matters in this case since I can’t upgrade anyway since Initial Trident has no Configure in the Update Manager so I can’t use this:

sysup -change-train Trident-release (there is no train to change)
sysup -check
sysup -update

Both @mer and @Groot
Just installed Initial again. It starts better, but still no Internet and like I said, I won’t be able to upgrade. Some should have warned me not to use the Initial version.

Just some extra info:
I just checked. I have IP-address, Netmask, MAC-address and the Network Manager Status says Active, but I still don’t get any connection.

0 Likes

#5

was internet working?

can you post the

/etc/rc.conf

0 Likes

#6

No Internet on that computer.

However, when I try that command I get “permission denied”
If I use sudo I get “command not found”

0 Likes

#7

That sounds like your missing some tools. I know it happened to a couple of other users. When you dd your 8GB or greater USB thumb drive with the latest trident installer try to dd it with a command similar to this one.

dd if=the_ISO_or_IMG of=/dev/da0 bs=10M conv=sync

I’m not sure what command you used to dd before, so just a suggestion.

0 Likes

#8

This is the dd command I’ve been using dd if=/dev/zero of=/dev/da0 bs=1m
But like I said, since it writes zeros over the whole disk it wears it and if you use it too many times you don’t have a functioning disk anymore. I happened to an 8 GB USB-pin i had that I later trashed since it didn’t save anything I putted on it anymore.

It seems btw like if I’m soon having a total computer blackout here. I have an old Windows XP computer that I use to write ISO’s or IMG’s to USB since I had no luck doing that in PC-BSD and TrueOS. Just tried to run it on - Dead!

Some more info:
No luck like I said. But this is very very very very interesting, why does the TrueOS User Guide give false information?
I do EXACTLY as it says here https://www.trueos.org/handbook/install.html#writing-to-a-usb-device and this is the result:

root@Trident:~ # dd if=Trident-18.12-RELEASE-U8-x64-20190328.iso of=/dev/da0 bs=1m
dd: Trident-18.12-RELEASE-U8-x64-20190328.iso: No such file or directory
root@Trident:~ # 

I’ve tried this many times, but it has been as useless every time i.e. it’s impossible to write an ISO or IMG file to USB in TrueOS and Trident i.e. you always need a Windows computer nearby be able to use TrueOS or Trident.

It like you would need a bicycle to drive a car for occasion (not if, but when - in Trident’s case) the car breaks down.
Reeeeeeeeally good OS this Trident - NOT!!! That goes btw for ALL computers!!!

I’m sorry, I’m so pissed off right now you can almost melt led of me :rage:

0 Likes

#9

this is what I’ve used;

sudo dd if=/full/hath/to/iso/Trident-18.12-RELEASE-U8-x64-20190328.iso of=/dev/da0 bs=4M

making sure that the /dev/*** is correct

0 Likes

#10

the dd command has a “count” parameter that is the number of blocks of size “bs” to write. You probably don’t need to do the whole device, just the first few mb at the beginning.

0 Likes

#11

That’s what I did ("/dev/da0" see the outcome of the command I used above). I’ve tried this on many occasions before, never had any luck with it. This was the first time I tried it in Trident - same result.

That’s why I’ve been using the Windows XP with win32 DiskImager. But now I won’t start - no power. I don’t understand how a computer can break down just by sitting, I use it very seldom, it’s not connected to the Internet since I have no anti virus in it. It’s a desktop that I use it as a test computer. Do you know if PSU’s has a fuse that could be blown?

I don’t understand what the block sizes do, but I don’t think it should affect the systems ability to execute the command instead of saying “No such file or directory” that to the best of my knowledge means that it doesn’t find the ISO on the harddrive.

Example: When I roll back the backup for Thunderbird and Firefox using “tar xvf backup.tar” it always finds it no matter where it’s placed.

0 Likes

#12

Fuses either on the motherboard or in the PSU. I’ve had them go bad, especially in a “consumer” grade PC like from Dell or others. I typically buy a good quality PSU (like for a gaming computer) with more power than you think you need.
Power Supplies can be touchy at times, consumer grade can get trashed by just a little blip on the power line (yes I’ve had this happen).

blocksize (bs) says how big of a chunk to write out at a time.
Why is this important? SSDs, USB thumb drives, generically “flash” devices have a native sector size in the device, called “erase block size”. To make it easy on the device, you want to do things in multiples of that size (nominally 2048 or 4096 bytes) for performance and less thrashing of the device.
Correct that blocksize has nothing to do with being able to find the ISO on the harddrive.
I typically do what Rod pointed out: “full path to the ISO” even if I’m in the same directory (I may cheat and do ./filename). The dd command may actually need the full path for the if parameter, it may not make any assumptions.

I’ve burned many a USB device under all forms of *nix systems: Fedora, Centos, Redhat, Ubuntu, FreeBSD, TrueOS-legacy, Trident without issue. But as I say I’ve always used the full path to the file for the if parameter, so that may be the key.

0 Likes

#13

@mer
I guess that leaves it to get a new PSU for that computer. I will need it anyway to access my phones, specially since I’m on the way of replacing it and need to copy the phonebook (I don’t want to type everything in manually if I can avoid it).

I buy that Nokia Suite, BankID and similar special programs etc. not are available for BSD, but not that i’ts almost impossible for others than experts to create a bootable USB flash drive and also not that it’s impossible to access a SD-card in a device like I mentioned here MicroSD card doesn't show in auto mount especially since it worked in PC-BSD.

Well, back to topic.
I’m gonna get a new PSU early next week, then write U8 to a USB flash drive with win32 DiskImage (that I have in that computer) and hope for the best. If that doesn’t work, then I’m really in trouble. I could try to reinstall PC-BSD (I still have the latest ISO). On the other hand, that ISO is on the Seagate and I can’t access it unless I get the main to run. For the same reason I can’t go back to Windows (I don’t want that either) since Windows can’t read ZFS.

So I’m stuck between a rock and a hard place (to use a worn out cliché). What do I do if I can’t get Trident to run? I hate my self for putting my self in this situation. I should have kept it on PC-BSD since it worked well. Right now I’m thinking of that old but very wise saying: “If it ain’t broken, don’t fix it”.
Why didn’t I remember that before I did this? :cry:

0 Likes

#14

I’d buy a brand new USB thumb drive, make sure it’s at least 8G in size just to give you the best shot.
Heck I can try doing an install on a samsung SSD I have an mail it to you if you want.

0 Likes

#15

@mer
I have a quite new Sandisk 16 GB USB flash drive that I use.

Thanks, but I’m uncertain if the install then would be compatible with the rest of my hardware.

I found a store that’s open on Sundays who has a PSU for a fair price (Kolink Core 400W). It’s probably consumer grade, but I don’t want to spend too much on that old computer. On my main machine I have a better thing, don’t remember the brand now. I can check it as soon as I get access to the Seagate :triumph:

0 Likes

#16

Update:
I had to open the main since the BIOS battery was bad and needed to be replaced. While I have it on the bench I also decided to remove the SSD and run a dd on it so it’s clean when I later try to to install U8 on it. I just hope it doesn’t shorten its life span too much.

This will take some time and in the meantime I’ll go get the new PSU for the oldie. I probably run a dd on the USB flash as well before I put the U8 install files on it.

Btw, @mer
Now that I have the main on the bench, I saw its PSU is a XFX Pro 450W. At the time I bought it the guys at the computer store told me that it’s a good high quality PSU.

Btw 2. It was a long time since I had the main open last, and it’s amazing how much dust those things collect. Although it has two body fans, one in and one out, so it’s kinda a storm inside when it’s running so I think most of the dust is blowing out through the vents.

0 Likes

#17

Dust is a good reason to power down once a year, take it outside and let loose with the compressed air.
Dust can shorten the life of PSU components by causing overheating.
Fans and heat sinks: dust magnets.

The dd: most ssds have years of erase cycles at a much higher sustained rate than you see in normal use. Worst case is something streaming movies to the SSD and then erasing them. 24 hours a day, 7 days a week. That is the type of load they measure lifespan on.

0 Likes

#18

Another update.
The dd cleaning of both the SSD and USB flash went well, new BIOS battery is in and everything reassembled.

But why shall everything run smooth when it also can f**k up?
The new PSU doesn’t fit. You know that white 4-pin coupler with black and yellow cables on the motherboard? The new PSU has black 2-pin, 6-pin and 8-pin couplers with the black and yellow cables. None of them fits (don’t know what those cables are for, but I bet they are for something or they wouldn’t be there). Yea, it’s probably a newer type, but in that case, why does it have power couplers for IDE? Nobody uses them anymore.

Well, back to the shop on Monday or Tuesday and hope there are other type of PSU’s or at least some adapter. I’ll take the old with me so the clerk know what I mean.
Next door from the shop, there is a computer workshop, maybe they have some idea otherwise.

This starts to turn out as a never ending story :sweat: I just hope the install of U8 works in the end after all this effort.

0 Likes

#19

Finally some good news, actually two good news.

  1. Trident is in on the main and everything seems to work, but it took some effort and I probably got some new gray hairs :wink:
  2. It was nothing wrong with the PSU on the spare/test machine that I have Windows XP in. It was the power cable that was broken. It’s not the first thing you think of when the computer goes on strike, for some reason you always think about the simplest option last. I even removed the PSU, took it to the shop and asked them to test it - “it’s nothing wrong with it”.
    Me: ??? Went back home and tested it with another cord. Yea, it runs. Well, at least I saved a little money, although I spent a little of it on fuel instead.

@Sergio
About the Skype issue in the other thread No mic output and not even a mic setting in mixer
I tried to install and it did without any problems, and it even launched at first, but closed again I before I could do anything more, after that it didn’t launch anymore so I uninstalled it again.

Btw, @mer
Skype seems to have left some linux-c6 stuff behind. Can I uninstall that without damaging anything else?

0 Likes

#20

@Robiww glad you finally got it installed, sorry that it was such an effort.
Removing linux c6, yes you should be able to remove them.
I like doing things from the CLI instead of AppCafe.

pkg info | grep -i linux to get all the packages
pkg info -dx packagename to see what packagename depends on
pkg info -rx packagename to see what requires packagename

Doing the pkg info -d and -r will tell you what may get broken or what else you can remove before you do the pkg delete commands.

1 Like