Timez Attack in VirtualBox with Windows as the Guest


#1

My son is starting to learn multiplications. I found an old CD that I had with the Timez Attack game from Brainz.

I thought I could install it via wine since I had tested that game via wine on PC-BSD and it worked fine (for the most part). I downloaded PlayonBSD from the appcafe and try to install it, and it just installed a bunch of icons that persisted even after I uninstalled the game. I went as far as sudo rm -r .wine, and when I went to the kickstarter and typed Timez the icons kept popping up.
(How much junk do those windows installers leave behind after they have been uninstalled?)

Then I thought I would just download a tech preview copy of Windows and play it on virtualbox-ose. I tried to open virtualbox by clicking on the icon, and it would not open. I typed in QTerminal sudo virtualbox and it opened, I made the Virtual Machine and loaded the tech preview .iso and it just crashed and closed.
After a few more tries with different settings I gave up.

I thought maybe I shouldn’t be using a tech preview, and maybe an official release will be better. I bought a retail version of Windows 8.1 DVD installer unopened and still in the box. Popped it in, and this time it didn’t crash and close it gave me some weird 0xx000xx must turn off computer errors and never installed. The terminal read something like incorrect sRGB and OpenSystem missing. I’m not sure about the second one because it was so fast and I couldn’t reproduce it.

At which point I vaguely remembered somebody mentioning that Virtualbox wasn’t working on TrueOS. I thought that had been fixed in the last update, but I could be wrong and it could just be fixed in Unstable. Can anyone using Unstable confirm that?


#2

are you a member of the vboxuser group?

works for me under UNSTABLE


#3

It’s working for me on stable, but it’s possible that I built it from ports, since I’ve had to do that for a few packages.


#4

Well, I don’t know about unstable but I can confirm that vb works on my “stable” system.

I didn’t install a Windows system from scratch on the TrueOS-VirtualBox though but just copied an existing vm (guest) from my Windows system and put it into the respective folder of my TrueOS user home folder.

It loaded/booted just fine.

I guess, all I did was installing those two virtualbox-ose packages (via AppCafe), the main one and think some package equivalent to the extention pack for Windows.

There was some “editing” necessary to get vb to start in the first place. I’m not on the TrueOS system now, so I can’t say for sure, but I’d say I took the advice from this page regarding the vboxdrv entries into the system to get it to work.

I’ll check the next time I’m on TrueOS and report back.

[Edit]

While I was typing apparently @RodMyers and @jmdavis already were done with their input. I think I had to add myself to the vboxuser group, too. :slight_smile:

[/Edit]

[Edit 2]

I just rebooted into TrueOS to check:

  • The 2 packages are: virtualbox-ose and virtualbox-ose-additions

  • Apparently I saved the post-installation output (of AppCafe / pkg install using terminal) into txt files (but apparently those can be found in respective info for every installed package in the AppCafe) for future reference:
    It’s essentially what the FreeBSD link from above states, but after installing the additions package are some notes that are not covered by the link as far as I see right now.

  • So I’ll try to cover what I did when “editing”:virtualbox-ose

According to virtualbox-ose instructions:

  1. Add

vboxdrv_load=“YES”

to /boot/loader.conf

  1. Add

vboxnet_enable=“YES”

to /etc/rc.conf

  1. Add users to

vboxusers

group

According to virtualbox-ose-additions instructions:

  1. Add

vboxdrv_load="YES"to /etc/rc.conf

to /boot/loader.conf

  1. Add

vboxguest_enable="YES"
vboxservice_enable=“YES”

to /etc/rc.conf

  1. Add users to

wheel

group

[/Edit 2]


#5

You definitely need to be part of the vboxusers group, though I thought that it had been fixed so that that was taken care of for you. Maybe not though. But if you run it via sudo like he did, that’s not required, and he got a crash when running it that way. Being in the vboxusers group should negate the need for sudo, but it shouldn’t fix a crash.


#6

I was trying to remember pw addgroup, was that it or was there a -m after it?.. Then I saw it’s really easy to do in TrueOS with SysADM click on an arrow and save. Now that I have added myself to the vboxusers group I can open VirtualBox by double-clicking on it, but it is still not working.


#7


#8

LOL. It’s probably stupid of me, but I’ve always just manually edited /etc/group when I wanted to change which groups my user is in.

That really should just make it runnable as your user. It shouldn’t have any effect on whether it works correctly when you run it.

BTW, I’m currently running virtualbox-ose-5.1.26, so if that’s not the version you have on TrueOS stable, then I almost certainly built it from ports, and if I did that, it was likely because the package in stable wasn’t working for me. You could always try grabbing the ports repo and building virtualbox-ose locally, though it’s been long enough since stable was released, you might have to go to an older commit. I don’t know. I’ve installed a few packages that way though.


#9

The version that is on AppCafe is 5.1.22 which is the version that I have installed. Look like I might have to go the ports repo way jmdavis.


#10

The AppCafe version of vb (5.1.22) runs just fine (the only thing that doesn’t work is USB 2.0 or higher, only USB 1.1 implementation for guest systems works) on my system.

Also, I did the user adding using GUI, i.e. SysAdm. So, no hasseling about “-m” suffixes and the like on my side…

But that’s all on “stable”. If that changes anything…


#11

Just to add another datapoint.

Virtualbox works fine on the latest unstable for me as well. I have both a Windows 7 VM and a Linux VM and they both work just fine. I had a Windows 10 VM going for a while, but I “retired” (actually reinstalled) it to the Windows 7 VM. But, due to some unfortunate zvol trimming on my part, I had to create both of them from scratch in the previous unstable release.

So, things should work. I attached their disks to a zvol, but I can imagine that that would make a difference (more the opposite).

You may want to try with a Linux install or something else to rule out the Windows Install media.

Given how VirtualBox wasn’t working for a good chunk of the first half of the year, I’m quite happy with the past months of it working on Stable and Unstable.


#12

I tried it on two different laptop, and the Timez Attack game worked on both of them with PlayonBSD. And the windows disc also worked with VirtualBox, I didn’t install Windows, just because my goal was to play Timez Attack and PlayonBSD already fulfilled that role.

I think it has something to do with my video driver though, I chose Intel because it was the first one that worked with a 1920x1080 resolution, but it looks like that may bring some other problems.

The Timez Attack game now works (for the most part) as soon as my laptop gets hot it gives me an option to change to a lower resolution, but doesn’t let me click on the option, the arrow just sits there mocking me with a big white screen I can’t move or close… I have to turn it off, let it cool down, and hopefully my son hit a checkpoint before we did that or else it’s progress lost.

That is the best game I could find to teach a child multiplication, but it’s no longer being sold. I just happened to have a disc that I bought a long time ago, so if any one knows of any cool games that work on BSD and can teach a child multiplication please let me know. Thanks.


#13