That was interesting


#1

A “play around with it system” running TrueOS desktop last version 20180325 or so.
Tried installing to BE (Rel 1) did the shutdown, never rebooted. Forced reboot, then didn’t boot, lots of errors like “kernel is not ELF format”.
Ok, rebooted, tried to select old BE.
&*^%^#$%!!! Autoboot timeout way too short! (Can we please default it to 10 seconds so I can actually read the screen before it boots?)
Eventually get it to respond to 7 select BE. Tell me the current BE (13-Current) is 1 of 5 but I can’t select anything.
Ok reboot again, stop in loader prompt. Now WTF is the syntax to set a different BE and different root directory?
Try that a dozen times, no dice.

Ok, I said this was a test system, so let me do a full install and see what happens. Well, same “no reboot or shutdown” when done with the install, force a power cycle and see what happens.
Intel i5 based system, kldstat shows the i915 driver is not loaded. UEFI boot.

I’m not upgrading my main desktop (nvidia) anytime soon.


#2

you found the “issue” with the new FreeBSD lua bootloader. it’s been having THAT issue with the older forth bootloader :frowning:

It’s been asked before, for a 5-10 second pause. always received the response, that’s what the space bar is for.

Maybe we need to put an “enhancement” request in the --> https://github.com/project-trident/trident-installer repo

edit:
or the https://github.com/trueos/trueos-core


#3

Thanks :slight_smile: But I barely have time to hit the space bar. Once I reboot into an installed system, changing the timeout is the first thing done.

The “issue”, is it just not able to figure out the BEs or is the loader expecting something set in UEFI vars that is not set? This is a dedicated system, so no funky dual boot or anything, just UEFI instead of legacy boot. The installer recognized the existing ZFS config.


#4

Ok, full reinstall with U3 and at least the intel driver seems to be installed and is recogniing the correct resolution.


#5

after U3 is installed, the upgrade process is

sudo sysup -check
sudo sysup -update
or
sudo sysup -update -fullupdate


#6

Thanks.
I’ll see what that does.


#7

I’ve little to contribute with while two experts are talking :slight_smile:
But I learned one thing while updating my laptop from 18.03… Trying to install Trident into the existing BE seems doomed to fail.

  • When I first made a test install onto an empty HDD it seemed fine.
  • But onto the existing BE on the internal drive on the laptop almost nothing worked.
  • But a fresh install worked fine. That was surely more work since formatting the disk means you have to put all files back afterwards.

However, my main desktop (amd with nvidia) will be easier since I have everything on a secondary HDD and almost nothing on the system drives Home directory.

Talking about updates. During the testing I tried to update to U2 (sounds like the Norwegian rock band :wink: ) that crashed (although I was able to roll back the system), so I haven’t updated the laptop yet. Is U3 more stable?

But this confuses me.

If you update from Update Manager, doesn’t it update it self after reboot? Also, is it U3 that in listed in Update Manager if I run it?


#8

@Robiww Was your laptop UEFI? The system I updated was (not any longer). A main reason for asking is I recall seeing a lot of discussion on the FreeBSD lists about UEFI boot and the correct way to do things (Warner Losh was one of the parties involved in the discussion). A lot had to do with the proper way to set EFI variables. That also wound up discussing gptzfsboot and “boot1”.
I’m wondering if Trident/FreeBSD 13 installing to a new BE on UEFI system also requires updating the UEFI boot partition to keep everything in sync with the lua based loader.
It’s too late for me to try that experiment, but it bears thinking about.

The downside I think may be that once you do that, perhaps you can’t roll back BEs.

My main system (still running 18.03 also) is an nvidia based system also, home directory a mirror pair with the “system” on an SSD, so I have less to be concerned with. I will most likely get another SSD so I can easily “upgrade” and fall back if needed.


#9

The laptop is not UEFI, but the desktop (also my main machine) is and I tested that one as well with the external test HDD and it worked out well. In fact it worked better than on the laptop since it didn’t have the graphics issue (now solved). I just checked the correct nvidia-driver (340) in the installer.

The test drive I use is a 3,5" HDD connected by USB, but I don’t think that makes any difference since it goes through the same system anyway. The internal system drives on both machines are however SSD’s.

I haven’t installed Trident on the desktop yet, and I don’t think it can be done on the existing BE, not at least since that one is still on PC-BSD 10.3.


#10

U2 (sounds like the Norwegian rock band :wink: )

You mean A-ha.


#11

No, I meant U2, but me bad… They’re Irish :wink:


#12

Irish, Norwegian, same thing. Everyone “Not Svenska” is interchangeable.


#13

Just to update folks:
I wound up doing a fresh install of U3 and everything is working fine.
I would have liked to have not done a full install, but since it’s a test system, it’s not a big deal.
So far things seem to be working fine.

My main system I may go back to a FreeBSD 12.0 install (waiting on some new SSDs to show up for that, probably do a mirror for the boot drives, simply “because why not”)


#14

:rofl: But then there are those who think Swedes are interchangeable with who ever (“look what’s happened last night in Sweden” has become a classic :wink: ).

Anyway, I would almost give my right hand (I’m left handed :wink: ) to get in contact with a Swedish dev (I know there are FreeBSD/TrueOS/Trident devs almost all around the globe). But I don’t underestimate the help I get here, it’s worth a lot. Only sometimes it’s hard to explain technical terms in for me a foreign language.

Good to hear. Then I can be almost sure that it will work out on my desktop as well. But that have to wait a few weeks since I have a lot of other things to do in the near future. But I’ll carry the laptop with me so you won’t get rid of me :wink: