System76 Oryx Pro


#1

I have a System76 Oryx Pro laptop that’s about a year and a half old that I’d been running Ubuntu on but had to redo the install. So, I figured that I’d try TrueOS again. I think that when I tried it when I first got the laptop, the graphics didn’t work for some reason, but more recently, when I’ve tried the hardware compatibility test in the TrueOS installer, it said that the wireless card wasn’t supported, so I haven’t bothered trying to install it (I think that it’s an Intel 8260; the card definitely wasn’t supported by FreeBSD when I bought the laptop). However, I saw in a post somewhere in this forum that someone had a laptop that the installer claimed wasn’t supported, and it worked anyway, so I figured that I’d give it a try this time (using the unstable branch). It didn’t work, but poking around online, I found this post:

and with the changes in loader.conf listed in that link, the wireless card works now, which makes the laptop at least usable.

However, I have found that suspend and resume don’t work properly - or at least, resume doesn’t work properly. It’ll suspend just fine, but in most cases, when it resumes, the screen stays black, and I can’t ping the box. And of course, suspending without resuming is pretty pointless. :slight_smile:

If I switch to a different tty at PCDM and suspend from there, resume seems to work at least some of the time, and I think that I got it to resume at least once when having suspended directly from PCDM (though I may have had to switch to a tty after resuming to get the screen to not be black), but usually that fails, and when I’m logged into KDE, it definitely fails (I assume that it fails with Lumina too - particularly given that it tends to fail at PCDM, but I don’t use Lumina, so I don’t know). And unfortunately, with how I use that laptop, not being able to suspend and resume is unacceptable, and it suspends and resumes just fine in Linux (and actually suspends much faster than FreeBSD does), so unfortunately, I’ll be going back to Linux on that box. Given that it can resume some of the time in TrueOS, it’s probably close to being where it needs to be to work, but for me to use TrueOS on this laptop, suspend and resume need to just work, and they don’t. So, back to Linux unfortunately (at least on this machine).

But I figured that someone might find this information helpful, so I’m posting it.