System crashing all the time


The system is crashing over and over before the latest update as well as after. I don’t know how get a log from it since it just crashes. It starts up, I can login, then it runs for a few minutes and then it crashes.

It seems to crash after I connect it to Wifi via a dongle from TP-Link. I made the update via cable connection and that worked at least during update. I also had it connected to cable for hours before without a crash. So I don’t know if it’s something with the Wifi or something else. At least the text that comes up after crash doesn’t say anything about failed Wifi (wlan).

If someone tells me how to get a log I can post it here. But it’s a lot of warnings and the screen starts with “sysctl_root() at sysctl_root+0x239/frame” and ends with:

“failed at /usr/src/sys/dev/drm/drm_gem.c:854
[ tread pid 2715 tid 100722 ]
Stopped at device_sysctl_handler +0x7a movq (%rbx),%rax

Please help!


roll back to a previous boot environment (BE)

i’ll assume you are running UNSTABLE?


No, I’m just running STABLE and I’m very accurate to do so. There is nothing to roll back to since I had the same problem before the latest STABLE update.

However, since I wrote the question/help request I’ve done two things:

  1. I have no Wifi connected and it runs so far with no crash.
  2. I connected it via cable and deleted kde-workspace.

It still runs connected by wire. Could the kde-workspace had something to do with the crashing? While I’m waiting for your next reply I give it a shot with the Wifi again and we’ll see what happens.


if kde is giving you issues. try re-installing and use Lumina only for a while to see if that works


I was using Lumina even with KDE installed since I didn’t like the look and feel of it (thought it was gonna look like PC-BSD, but it didn’t). So I had it installed but didn’t use it.
Well, it did run for a few minutes again, then it crashed again with the same error. So obviously it wasn’t a KDE issue.

So it seems to be something about the wlan. If you tell me how to get a log from it, I can paste it here. Maybe that helps to solve it.


let’s try something completely different.

how about grabbing the UNSTABLE ISO/IMG from -->

and see if that makes a difference


But that will format the harddrive = Not a good idea. However, I could set the repository to UNSTABLE or I could just wait for the next STABLE update since I’m not in desperate need to connect it to Wifi right now.

I rebooted again, disconnected it from Wifi and connected it to wire and now it runs as supposed to. So it’s definitely something about the wlan.
Two thought:

  1. I could try it with my home Wifi (I have it off right now) or to some open network
  2. There is some problem with the dongles ISP, it has a cash card and doesn’t connect to the Internet. I’m was thinking of calling the ISP but it serves no purpose if I can’t test it if the computer crashes.

However, if I turn off the dongle then it makes no difference if the computers Wifi is on or off, it runs without crashing whichever. The crashes comes when it connects to the Wifi, but I don’t know it it make any difference if it’s connected to the Internet via Wifi or not.

But whatever the problem with the Internet is, I don’t think it should make TrueOS crash, unless there is a hardware issue in the computer.


If the driver for your wifi chip has a problem in it, that could easily crash your system when you load/use the driver.
Can you give us any info about the chip/driver you are using?


Intel WiFi Link 5100 IEEE 802.11n

Here is all info on the computer

The chip is built in and the Wifi dongle I’m using is a TP-Link M5250

I will try to test soon it on some other network that I know works (don’t know if I can get my home Wifi network to run).


actually, it won’t reformat the drive, unless YOU tell it too.

It should find the previous Boot Environment


@beanpole135 @RodMyers
I haven’t installed the latest UNSTABLE update since I think it’s more likely to crash than my present STABLE installation.

Now this is interesting. For fun I was clicking around a little in the local settings and in the SysAdm Control Panel. At System Management I noticed that when I click Service Manager, Task Manager or User Manager the system crashes almost immediately in the same way as when I try to connect to Wifi. It just takes a little longer (a few minutes) after the attempt to connect to Wifi. Clicking on the mentioned icons makes it crash in just seconds.

I also now remember that this has happened for a while now (I don’t use the laptop that often) even before the latest updates (I use STABLE updates only) and also before I installed kde-baseapps and kde-dolphin.

So it seems to be some system error. The crash comes no matter if it’s connected by wire or offline.

I don’t know if it has any relevance, but when I first installed TrueOS I used the 2017-03-31 version to get Firefox and Thunderbird auto-installed. Afterwords I immediately updated to the latest version at that time. I don’t remember when this crashing problem first occurred, but it wasn’t from start, nor from the first updates. I think it was sometimes after the “Space Invaders” (as I call the ugly B/W icons in SysAdm Control Panel and Desktop Setting :wink: ) first came up.

If you need a log to see what happens, just tell me how to get it. I can send from the laptop as long as I use wire connection and not Wifi.


I’m sorry for the language, but I fucked up the whole laptop. I was gonna turn it off but by mistake I hit Change Video Driver instead of Turn Off. That made it to totally fuck up the video driver and it seems there is no way to reset it. To go into a previous boot environment can’t be done and won’t probably help. So all what is left is a harddrive format and reinstallation.

This will take me a lot and lot of time, many many hours, probably days to get it back to the state I want to have it and I have no back-up. On the other hand Life Preserver wouldn’t have helped anyway since the whole system has gone to hell. Symantec Ghost maybe could have done it, but A. I haven’t done one, and, B. I don’t think it’s possible to do it on TrueOS. I tried it ones on PC-BSD but it didn’t work, it just made the system crash. It’s probably just meant for Windows.

I don’t blame you guys, I’m the idiot my self here and the one who shall be, and will be kicked in the ass here. I just don’t understand why you have that option at the turn off button on the login screen? That is the most dangerous system killing option on the system that should be really well hidden since it destroys the system.

Well, hopefully this reinstallation will take care of the crashing problem even if I doubt it since it will install the same system.

Anyway, I won’t have the time to fix it this week, maybe next if I’m lucky. I just hate my self for this and I definitely don’t look forward to the work :rage:

Installing KDE onto TrueOS

I’m using STABLE with Intel video driver, and I must confirm that the option to change video driver is dangerous. Out of curiosity, I tried to change to modesetting, or anything else, and I ended with VESA and no way to set it to something else. I didn’t confirm any settings change, but the system moved to VESA anyway, over and over.

Fortunately, I could revert the xorg.conf file to a previous one, restoring my video settings.

The “change video driver” should keep the video settings untouched when the user does not confirm the changes.

First attempt with TrueOS

Well, the new installation is done with all settings. Didn’t take as long as I feared. Actually, the laptop works better now and doesn’t crash as before like when I try to connect to a Wifi. Hitting Task Manager inside SysAdm Control Panel does still make it crash, I don’t know why, but if I just avoid to hit that I’m good.
Anyway, from now on I’ll be very careful not to touch the “destroy graphics button” (change video driver).

Just for info. I tried to fix the xorg.conf by typing “intel” to the graphics driver, but it didn’t work. Then I made a copy of it, saved it in the Home directory, removed the default one and tried to replace it - didn’t work either. After reboot I was in FreeBSD and was able to log in. But since I’m very novice on FreeBSD I didn’t know what to do with it. So after that I made a full reinstallation of TrueOS. I hope I won’t that again.

Just a short question. Has anyone tried to use Symantec Ghost on TrueOS? Result? However, I don’t think it works since A) It’s a DOS program. B) Everything is on one partition, and I learned (* during my Windows days) that Symantec Ghost works best if you have the system only on one partition and all files on another.
But is there any way in TrueOS to make an image of the harddrive and save it on an external drive?

  • Nowadays I only have Windows (XP) on an old test computer, offline only.


you can always dd your HDD


How is that done? Can you post the command line?


I could post it, but dd is a very dangerous program mostly used by more advanced users. If I remember correctly dd stands for disk duplicate, but some people started nicknaming it. disk destroyer, this is not something that should be taken lightly. Now with that said and if you still feel adventurous enough to try it. It could be as simple as

dd if=/dev/ada0 of=~/HDDbackup.img

I suggest you read up on that before trying, then you could do cooler stuff like set bs=64k or 128k, etc…


Ah thanks. But as you say that dd’s are very dangerous programs nicknamed “disk destroyer”, I think I stand over this since I just came out from a destroyed disk :sweat_smile:
I sometimes use dd to clean up (write zeros to) disks and memory sticks connected to USB, but then I use da0 in the command line so that won’t affect the system drive unless I screw up in typing :wink:

I found that dd seems to be the only way to get a USB pin back to a state for normal use (and then format it to FAT32 or NTFS) after you used it for disk imaging for installation of devices that have no optical drive, like my notebook/laptop.


I tested this just now, and I’d like to confirm that changing the xorg.conf file from Intel to modesetting works fine after reboot.

Testing driver changes by the options dialog on login page doesn’t work here (you always end up with VESA), and testing using X tools ends with a black screen.

Hence, to be sure that a driver does not work in your system, you should be bold enough to reboot with the new settings. The testing tools are not reliable by now.