Supported Wireless cards for TrueOS


#1

I know a lot of people ask, "Is my wireless card supported in TrueOS [or any other non-microsoft OS for that matter] and the answer is typically no; or else they wouldn’t be asking about it or how to edit config files to make it work…

I on the other hand would rather buy one that is supported because it was recommended by the experts. So my question is not if my wireless card is supported, but what wireless card should I buy to make sure it is supported?

I have heard the “as long as it’s based on blah” it will work argument, but I’m looking for a more concrete answer. Make and model of a USB Wireless card that I should purchase and then I can install on my laptop and have it recognised by TrueOS and fully functional.


Qualcomm Atheros wireless adapter
#2

As a step towards this I read some of the information that’s linked from, and within:


#3

man -k wireless gets a nice list; beyond that I have no specific recommendations.


#4

grahamperrin, I can see why it’s difficult to keep a database like that, and why they use chipsets rather than make and model of the card.

It appears that the same make and model can use different chipsets. And sometimes when there is an update a chipset that did work no longer works, and sometimes ones that didn’t work start working. Then there are revisions of the same chipset, so you could have bought the right chipset, but the wrong revision of the chipset.

I have an Edimax, and a Belkin (USB) wifi adapter, and both do not work on either PC-BSD or TrueO.S. I was going to start a list of the ones that don’t work because I haven’t found one that works on TrueOS yet.

The Laptop an HP pavillion DV2000 comes with an integrated wireless card, but I never expected that one to work. I bought a cheap 20 dollar wifi card, that didn’t work, I bought the edimax because it said it would work on Linux, but that one also didn’t work on either PCBSD or TrueOS so I bought a 60 dollar one which is the Belkin one and that didn’t work either.


#5

I’m still looking for a wireless USB dongle that works with FreeBSD.

I went to https://www.freebsd.org/releases/11.0R/hardware.html#wlan and found most of the supported chipsets.

I copied and pasted the names from there into Amazon and most of them returned zero results, and quite a few are PCMCIA, and I really just want a USB dongle.

There were only five of them that actually showed up in Amazon as something you could purchase and they were the , D-Link DWA-160 rev A1, The Netgear WNDA3100, The SMC Networks SMCWUSB-N2, all these are not low profile, and they stick out a lot.

There was only two that showed up in the list that are in the FreeBsd hardware release notes, and are available for purchase at Amazon, and also have low profiles which is the, ASUS USB-N10, and The Buffalo WLI-UC-GNM.

I bought 3 of them, the ASUS USB-N10, the Buffalo WLI-UC-GNM, and one that isn’t on the list, but it was cheap enough that it didn’t really matter, it’s the Vodool 150M 11N Mini.

Now all I have to do is wait for it to be delivered, and when they show up I’ll let you guys know if those 3 actually work in TrueOS.


Network icon doesn't display signal
Any issues to expect?
#6

I received the Buffalo WLI-UC-GNM, Wireless USB yesterday. I plugged it in, and it wasn’t recognized, I restarted my computer and it still wasn’t recognized. I added the line "if_run_load=“YES” to /etc/rc.conf, restarted my computer and that card was recognized, and started working without a problem on TrueOS now I’m on the internet without having to run a cable to my laptop.

I should be getting the Vodool some time today or Monday I will try that one out and see how it works on TrueOS.


#7

USB network adapters


#8

@grahamperrin is that a list of the ones that don’t work?


#9

I got the Voodol, on Friday.

I didn’t like it at first, because it sticks out about twice as much as the buffalo does.

I plugged it in, and it didn’t do anything.

I restarted my computer, and it just started working without me having to do or edit anything.

I did a speed test and it read 30.69Mbps download speed and 9.63Mbps upload speed which is a lot better than what the Buffalo read.

The Buffalo read 18.5Mbps Download speed, and 17.5Mbps upload speed
I looked at the ifconfig and on the buffalo the MCS mode was 11g and on the Voodol the MCS mode was 11ng.

Just for comparison on a wired connection I get 50Mbps up and 50Mbps down.


#10

I bought a Netgear WNA1000M from Radio Shack today and, all I can say is DO NOT BUY this.

It’s on the FreeBSD compatibility list and it says it works with a urtwn(4) driver, but it doesn’t.

I plugged it in and there was no light. I restarted my computer and still nothing. I added the line "if_urtwn_load=“YES” to /etc/rc.conf, restarted my computer and the light came on, but you hit scan and it doesn’t find anything, after a couple of restarts it finally found my SSID, and actually connected to it, but you couldn’t get it do to anything it.

I couldn’t ping anything on my local LAN never mind anything on the internet…

Terrible experience. This Wi-Fi USB dongle does not work on TrueOS.


#11

Please do read the topic, you’ll find at least one that does work.

Consider moving your test results so that results are not spread across multiple topics. Thanks.


#13

I got the ASUS USB-N10 yesterday. And I was impressed it comes in a big nice looking, very professional looking box, it has Windows, Mac and Linux support written on it. it comes with instructions, and a CD that has a Linux shell script to install the drivers (They don’t work on TrueOS). I plugged it in, restarted my computer and it started working right away without a problem. I still had the “if_run_load=“YES”” line in /etc/rc.conf and according to the release notes that dongle should use the rsu(4) driver. I changed the line to “if_rsu_load=“YES”” restarted my computer and I noticed the signal strength got 8% stronger it went from 64% to 72%…

I didn’t do a speed test, instead I opted to do the update.

I woke up this morning and started my computer and that dongle did not work anymore. I opened up a terminal (And transparency works again :grinning: thank you). But my card wouldn’t light up anymore (it worked just fine yesterday before the update).

I did a “sudo rc-service network restart” and it lit up. I restarted my computer and the light stayed on, but the wireless network manager that lets you see the SSID’s, signal strenght, and connect to them never showed up. I opened up a web page and it connected, internet works fine as long as you have connected to that SSID previously I guess. I’m pretty sure this has more to do with the recent update than the Wi-Fi dongle itself though.

I ran a speed test anyway and I the results were 23.05Mbps download speed, and 7.15upload speed. Although I’m not sure how reliable these results are. I will have to re-test in a few weeks when the next STABLE version is released and I update to that one.

For now I would say this works as advertised and my favorite of the ones I have tested so far.

Edit:
I just noticed there is an icon of a red cable with a red jack. If I right click on it I can start the network manager, once in there I can select the wlan0 and push configure, and the wireless configuration pops up. It doesn’t stay at the bottom like it used to, but at least now I know how to get to it.


#14

When you first plugged any of those in, did you run pc-netmanagr (and press ‘apply’ which usually results in “Restarting the network” dialog window?
I’m asking because usually that causes the OS to recognize a new device, but if it didnt, did the OS recognize it only After a restart?


#15

I did not try to restart the network first. I plugged it in, it didn’t recognize it so I restarted my computer, and they where there and in working order after the restart.

Not a big deal on a laptop that I restart and turn on often, although, I’m fairly certain that they would have been recognized without having to restart the whole computer though.


#16

Wanted to thank you for the posts on testing the wireless network adapter dongles. Your post prompted me to order one of the ASUS USB-N10 Nano adapters.

I am a new FreeBSD / TrueOS user and had been wanting to try TrueOS.

I did a full install on a laptop and install did not find my wireless adapter.

For mine, after ordering the Asus USB-N10 Nano adapter and plugging it in it was not recognized by the OS.

I was able to get it to work after a bit of reading, including your post.

dmesg identified it as rtwn0 and using grep | rtwn0 the ASUS USB-N10 nano hardware was identified as RTL8188CUS which a search of ‘FreeBSD RTL8188CUS driver’ identifed as using the urtwn driver.

I added ‘if_urtwn_load=“YES”’ to the /boot/loader.conf file and configured \etc\rc.conf by adding wlans_rtwn0=“wlan0” and
ifconfig_rtwn0=WPA DHCP"

then after running
sudo rc-service network restart followed by
sudo pc-netmanager

I was able to see wlan0 in the netmanager GUI.

I experienced the same issue you posted with the wireless icon disappearing from the left bottom bar where the time / battery / speaker icons reside.

Were you ever able to resolve the issuer with your wireless icon disappearing?

I noticed from reading that appending an ‘&’ to some of the command line commands like pc-mixer for example adds the icon, but I haven’t located the comand line yet to add that to the Lumina desktop for the wireless icon.

Huge thank you for posting the info on the wireless dongles. It gave me a huge head start with a wireless dongle to start with.


#17

Thank you, my wireless card is not recognized either.


#18

Discovered how to display the wireless icon, but have not yet found out how to make it sticky, (may be related to an issue I have getting network service to starting on boot.)

Click the TrueOS icon at bottom left

Type ‘network’ in the search box

Select the “TrueOS Network Tray” icon.

The wireless icon is back if your wireless is configured.


#19

With some help here on discourse, was able to get a ASUS USB-N10 Nano adapter configured so it was recognized on boot.

Turns out, what I had researched was for NetBSD, not FreeBSD.

The ASUS USB-N10 Nano I have identifies as an RTL8188CUS chipset and it uses a rtwn driver instead of an urtwn.

By the way, this is a great resource for BSD driver info: https://en.wikipedia.org/wiki/Comparison_of_open-source_wireless_drivers

My setup:

/boot/loader.conf
if_rtwn_load="YES"
wlan_wep_load=“YES”

/etc/rc.conf
modules=“if_rtwn if_rtwn_usb” # included these two modules to load (this was the fix for loading on boot)
wlan0_enable="YES"
wlans_rtwn0="wlan0"
ifconfig_rtwn0="DHCP"
ifconfig_wlan0=“WPA DHCP”

/etc/wpa_supplicant.conf
network={
ssid="YOUR_ssid_name"
priority=145
scan_ssid=1
psk=“YOUR_password”
}

(where YOUR_ssid_name is the name of your wireless SSID and YOUR_password is your wireless password)

After the two rtwn modules were loaded, the Asus dongle fires up on boot and seems to just work.

A massivley huge shout out to MER for telling me to load the rtwn modules in rc.conf

The default rc.conf settings live in /etc/defaults/rc.conf

As MER pointed out you can find the modules defaults to add back to rc.conf by using:

grep -i modules /etc/defaults/rc.conf

That worked for me getting the dongle loaded on boot.

Thanks MER !!!