Strange situation on new install


#1

I’m trying to install TrueOS on a friends Acer Aspire 5349 15,6" laptop (it’s a Windows 7 machine, no secure boot and no UEFI).

The installation seems to run well but when it’s done and reboots instead of going to username and password settings etc. it’s goes to login, still on black screen. But I haven’t entered any username or password yet.

It just says login:
And after a few seconds I get date, time and “dhcpcd[880]: timed out”

Note. Instead of the latest 2017-07-05 version of install media, I use the older 2017-03-31 version since it’s the last that has Firefox and Thunderbird and plan to update as soon as it is installed. However, I don’t think it’s likely that this is the problem since I have done it this way before and the Acer is not a new machine, It’s five or six years old. It has only 3 GB of memory, I know that a little low but I plan to upgrade to 4 GB.

Any suggestions?


#2

Are you remembering to pull out the install media before the machine reboots? Watch the messages and the last line will talk about syncing nodes. Just after that is done, the machine goes into the reboot.


#3

It make no difference if I leave the media in or pull it out. Or will I need to reinstall?

I just came up with one thought. The HDD use to have Windows 7 on it with some kind of recovery partition. Could it be that the installation media don’t cleans up and formats the HDD completely and leaves some stuff hard burned on it and that I need to run a deep clean (write zero’s) on it?

It’s a 320 GB HDD and not a SSD.


#4

Good info about the Win7 recovery partition. You may need to drop into the “advanced” section of the disk partitioning and delete all the old partitions.
As for writing zeros, that’s not a bad idea. 2 MB from the start of the disk should do it.
There have been cases of the install trying to restart if you leave the install media in when it reboots. You may also want to try the latest Unstable image that on the downloads; I just put that on a NUC and it was pretty easy.


#5

I did run a full disk installation, but maybe that wasn’t enough.

I don’t know if the dd-command to write zeros over the disk works from the installation media. So I probably remove the disk and run it though my SATA to USB adaptor. But that won’t be today, it’s kinda late here now :sleeping: :sweat_smile:


#6

Issue update.

I made a deep clean on the disk and I found out how to do that without having to physically removing the drive. Instead I was able to do that from within the installation program => Text install => Emergency shell, where I could type in the dd-command, and clean the drive in the same way as if I had removed it. Only difference I used was to write “ada0” instead of “da0”, but…

It didn’t help. I came to that same point when I tried to install TrueOS again “Login => Password”. It’s really strange and I have no idea where it comes from, probably something in the hardware. But like I said, Windows 7 doesn’t have security boot nor UEFI, so it shouldn’t be anything left from the Windows installation in BIOS.

Well, since the guy who owns the computer said he doesn’t care (he just liked the idea of a virus-free computer), and also since it has no lids on the bottom for the drive, memory and maybe BIOS-battery, instead you have to remove the whole bottom lid with a zillion screws, so I simply don’t have the energy to spend any more time on it :confused:

So he have to settle with Windows again, only now way cleaner than when I first got it. Maybe I upgrade it to Windows 10 (I believe that has an integrated anti-virus - Anybody who knows?)

Interesting is that to get Windows to install on the same drive where you already had a BSD-system with ZFS formatting, you have to run a deep clean again since it seems that NTFS cannot overwrite ZFS. But I believe that’s a good grade to ZFS since it that way probably can’t be corrupted from another file system.

Conclusion: Problem unsolved, but at least I learned a thing or two :wink:


#7

I just read your other post about not being able to reboot into a freshly installed TrueOS/FreeBSD. The one with 111 messages and 0 success.

Do You still try to install the OS in ZFS-striping mode without selecting at least the one necessary drive? So that You get an empty partition table with zero partitions again, and again, and again?

Did You learn in the meantime to see the difference between Your external USB booting stick and Your internal HDD/SDD drive? Have You learned, what their names mean (da0/ada0)? And to know, which is which?

Do You still not understand that “0 < 1 minimum” means:
“No disk selected as yet. At least ONE is needed. Select it.”?

Or did You understand all this in the meantime?

You are lucky that it’s a BIOS machine, this time. Else You would probably again have tried to install a EFI version in non-EFI (= BIOS Compatibility Support) Mode.

I admire Your persistence. Good Luck!


#8

There is a possibility, that what Your are trying to do or at least what You are doing is this:

Maybe, You are installing a pure disklabel partition table. It’s called “dangerously dedicated” not without a reason. Neither (U)EFI nor BIOS can boot this unless You pack a disklabel partitioning scheme either into an GTP- or MBR-PartitioningScheme’s S_L_I_C_E. If You never heard of this: After installation, reboot from USB installer stick again. And check from command line using:
a. fdisk
b. gdisk
c. disklabel
d. gpart

I’m not sure this is, what You’re doing there. But it may well be.


#9

I’m not sure that I understand what you’re suggesting. ada0 is the primary harddrive, da0 is an external drive lite an optical device or an USB device.

My primary desktop computer has two harddrives (and I know for sure it’s EFI) :
A primary 120 GB SSD that carries the system, called ada0.
A secondary 1 TB HDD that I use for storage only, called ada1, also formatted with ZFS.

I never tried to install any BSD system on an external harddrive via USB.

What you read in the post with 111 messages was about when I tried to install TrueOS onto my former Asus X102BA, that in fact was EFI although it wasn’t very graphical as my desktop is. But it was built for Windows 8 with secure boot and all the other garbage. However, it didn’t work, no matter what I did. I’ve also read that (you must have seen that too?) TrueOS has an issue with Asus computers and possible also with AMD CPU’s. That is what makes me unsure whether I should try to overwrite my fully functional 10.3 PC-BSD system (although it’s old and has started to limp a little - but it has no major problem) on my desktop computer with TrueOS since it’s in fact is an Asus with AMD CPU, although it has a GeForce 210 NVIDIA graphics card.

I’m starting to think about to try it with another harddrive (I have a 250 GB 3,5" HDD laying around) and simply temporary replace the primary ada0 with that one so I can test if the hardware accepts TrueOS without risking to destroy the PC-BSD installation. In this case it would be nice if it would be possible to do this test external via USB so I wouldn’t have to physically change harddrives. But I don’t think it is.

About the Asus vs Acer laptop.
I was able to get a refund on it from the shop where I bought it. Instead I bought an used Acer Aspire 1810TZ (you must have read it) that runs TrueOS with no problems. Before I bought it I ran my Asus-installed disk (that didn’t work on the Asus) external on the Acer and it worked although the drivers must have been all wrong. But that’s the only time I tried to run TrueOS from an external drive.

So you don’t need to tell me how to partition, format and install an OS. I know all that. My issues both back then and now was simply that the computers didn’t accept TrueOS. And this time it was extra strange since it was an Acer Aspire with Intel CPU and Windows 7 as OEM. Same as my laptop (although it’s another model) that has accepted TrueOS with no problem, while my friends machine after reboot asked for a login that wasn’t there instead of going into the section to ad username and password etc. So instead of keep on struggling with it, I gave up on it and installed its OEM Windows 7 again.

Just about your second post.
When I install I run the graphical installation all the way and only check so I’m on the correct disk

You’re right, I’ve never heard about this. But I don’t understand what good it would do? If the hardware don’t accepts the OS, then I can keep on doing command line checks until I turn blue :wink:


#10

You say:

If the hardware don’t accepts the OS, then I can keep on doing command line checks until I turn blue.

I say:
The hardware doesn’t accept the OS? How do You know that without checking? All You and I know is: It is not working in the current configuration. We both don’t know why. But we could 1. try to find out. Or 2. give up.

Number 2 is a legitimate choice, too.

It’s like in medicine.

Either:
“He/she’s as good as dead, anyway. It’s God’s will. Let’s let him/her die.”

Or:
“Let’s try to revive him/her.”

Attitude “Let it/him/her die” leads to too many dead people or computers, in my opinion.

I think, there exists a certain responsibility to try to solve such problems. To help others.

Of course, not everybody has the time and energy.


#11

Of cause I can’t be 100% sure, but using the elimination method I saw there isn’t many options.

  1. It didn’t let me in to stage 2 of the installation process where you ad root password, user name and user password. It just asked for login and password as if it was a FreeBSD install. “What f***ing login and password? I haven’t added one yet you stupid computer!” :smiling_imp: :wink:

  2. It didn’t help not even after I deep cleaned the harddrive and made a fresh installation.

  3. It’s a Windows 7 computer so it doesn’t have Secure Boot in BIOS or UEFI as most (maybe all) Windows 8, 8.1 and 10 machines have that I’ve learned can mess things up.

So instead of keeping struggling around I gave up on it and reinstalled Windows 7 and gave it back to the owner who was happy with it.
Next I’m gonna fix a Dell machine with Windows Vista-garbage in it. This guy has no knowledge of computers what so ever, he just want something maximal simple. So I plan to install Windows XP (a SP3 version I have that I’ve peeled down with nLite) on it, if I just find drivers for XP at Dell.


#12