STABLE update: no more access to HTTPS trueos, freebsd


#1

My STABLE boot environment of January has no problem connecting to websites like freebsd and this very forum. But the STABLE boot environment with the most recent update does timeout while trying to connect to such hosts.

There’s no problem connecting to many other hosts (e. g. google, duckduckgo…)

You guessed it… I’m currently using the previous BE.

What should I check out to fix this? Thanks.


#2

Check if the ca_root_nss package is installed and up to date. It shouldn’t have been affected by the update, but have a look anyways.

Is your host actually sending out traffic on port 443 if you try to establish a https connection? (tcpdump is your friend). Try disabling the ipfw firewall; it has caused me some headaches in the past by blocking traffic despite allow rules being set (it sometimes needs a swift kick to apply all rules after boot…)


#3

Is your time correct?


#4

You both may have a point.

I’m unable to check for updates. Update Manager shows nothing. And sudo pkg update -f shows access repo file(/var/db/pkg/repo-trueos-base.sqlite) failed: No such file or directory and stucks.

My system has multiboot with Windows 10 and Linux Mint, boot by Linux’s EFI boot loader. System clock is set to local time, hence the file /etc/wall_cmos_clock exists in both BEs.

My current BE boots just fine and everything works: no clock skew detected, system time is correct, and all hosts related to TrueOS are accessible (trueos, freebsd, freshports…).

My updated BE displays “clock skew detected” on boot, although system time is correct, and I have no access to TrueOS hosts, and I cannot even run Update Manager.

I guess I have to check the clock settings, but I have no idea where.

And I’m sorry it’s hard for me to post info about that other BE’s settings, since I cannot post them here from there directly.

Thank you all.


#5

Out of curiosity, what is the output from the command
route show default
?


#6
  1. Go to the updated BE and in a terminal type the word “date”
  2. if the time is off type the correct time in, for example if you want to change the time to 3:20pm type “sudo 1515” and push enter.

#7
   route to: default
destination: default
       mask: default
    gateway: 192.168.0.10
        fib: 0
  interface: re0
      flags: <UP,GATEWAY,DONE,STATIC>
 recvpipe  sendpipe  ssthresh  rtt,msec    mtu        weight    expire
       0         0         0         0      1500         1         0 

It’s the same in both boot environments.

One more thing. The failed boot tells that if failed to start lo. Service manager shows that network.lo0 is not running. I try to start it, but it does not start.

In the working boot environment, that service is running.

Does it help?

Time is OK.


#8

OK, that’s a different problem than what I’m tracking.


#9

No access to Bitbucket as well.

That’s what I get when I try using git pull:

fatal: unable to access 'https://bitbucket.org/<whatever>.git/': LibreSSL SSL_connect: SSL_ERROR_SYSCALL in connection to bitbucket.org:443

What can I do about it? I have no problem in the previous boot environment (December STABLE).