[Solved] Tried dual boot with Win10. Reboots back into Win10 after installation. No rEFInd boot menu shown


#1

Tried to get TrueOS to dual-boot with Windows 10 today. After the installation when I rebooted, it rebooted back directly into Win10. As per the documentation, I should be presented with the rEFInd screen to let me choose which OS to boot to right?

  • Laptop: Thinkpad x230, EFI only mode, CSM disabled in BIOS settings
  • Shrunk Win10 partition and created 80GB unallocated space
  • Selected unallocated space during installation, install rEFInd option was ticked

Stepped away for a while to return and saw a successful installation message. Clicked finish to reboot. After the reboot, I wasn’t presented with a rEFInd screen, it booted directly into Windows. Also tried selecting boot device on bootup. I can see an entry for Windows Boot Manager and my HDD (Intel foobar-xyz). Selecting Windows boot manager obviously boots me to Win10 and selecting my HDD just brings me back to the boot device menu again.

Any ideas what I can do?


#2

Well, I’m not sure but maybe you installed TrueOS while using CSM mode and you only changed it to EFI after install… That could have provoked your issue.
If that was the case, just reinstall TrueOS making sure you do so in EFI mode


#3

Thanks for replying. I’m sorry I forgot to update the thread. I got TrueOS working!

I tried another install but still had no luck. Then I booted into Win10 and updated the BIOS and tried again. After that I got the rEFInd menu when I selected my HDD as the boot device. Apparently My BIOS was dated at 2013. After applying the latest update and installing, it works fine! :smiley:


#4

Thanks for posting back on this.
Was going to post a thread on this until I saw yours,
and previous one being from 2015 Feb.
went looking for videos “Duel boot TrueOS”, and found zilch.

I am trying to Duel boot a 3Ghz, 8GB, Thinkpad x260 with 260Gb,
100GB for win7, & 250 for TrueOS.

My first few goes did not work. Being a long term Open-Suse user(now using Mint allot), I thought
TrueOS had a boot menu installer as an option, and was surprised to discover not.

I got as far as installing most of TrueOS, but could not finish out install with
clean exit, so that any boot loader, pointed at partition could load, TrueOS(or Win7).

Bit disappointed, as I want to use TrueOS for 90% of the time.

I have downloaded the recommended rEFInd, and reading up.


#5

@sparxz, you don’t need to download rEFInd, the TrueOS installer has it. AFAIK, If you aren’t seeing the option to install rEFInd, it probably means that you haven’t set your laptop to EFI mode in the BIOS settings. During the installation, in the Disk Selection screen, you’ll need to hit Customize Disk Settings > Basic and in the next screen you will see drop down menus to select the disk, partition and a checkbox whether to install rEFInd or not. Screenshot from the handbook


#6

Thanks so much for pointing this out.
I missed the “rEFInd” tick box, as I was distracted by the ominous “use entire disk” (as I interpreted warning).
That is where I stopped, worried it might do exactly what it said, if I misinterpreted the dialog box.

Should it not say “use entire selected partition” ?
I had already re-partitioned the SSD to give majority to TrueOS, through leaving the maximum "unformulated space, I could,
leaving the minimum needed for functional Win7 at the front of the SSD(as is the duel boot convention).
I made sure I had identified all partitions to be left untouched, before I went any further.

I realize since SSD, the technology is in reality ‘not’ a 2disk", but large storable memory.
But the terminology for “partitioning” has stayed the same.

I hope TrueOS rework clarity on the dialogs and terminology to better guide the person installing,
that they can more ‘confidently’ safely achieve their aim, and not risk existing partitions, a
unbootable machine, a desperate partition recovery session, and a bitter horror story to boot !

Thanks