Slimbook computers + TrueOS?


#1

Hi there,

does anyone have any experience with any of those https://slimbook.es/en/?

This guy here (https://euroquis.nl/bobulate/?p=1656) dual-boots FreeBSD 12-CURRENT on a KDE Slimbook, so I guess TrueOS will also work.


#2

quick readthrough, it should just works , as 2nd link described


#3

If you end up buying it, let us know how it works. I was eyeing The Slimbook KDE 13 KDE II Intel i7 and really liked it. I’d rather have a disk drive, but that may be too much to ask for in a slim. The price of it isn’t bad either. If TrueOS works for you on it, I know what my next laptop will be. :smiley:


#4

Thanks guys! Sadly, my T520 is still working really well. :wink: But I promise I will let you know when I (hopefully) get one of these.


#5

I think I have exactly the same under a different name (Tuxedo InfinityBook) and it runs well with TrueOS, but suspend/resume does not work and the battery does not last for long time (max 3h).
I would like to give this one a try: https://www.gearbest.com/laptops/pp_651829.html?wid=4


#6

If you are not squeezing enough power, try power tuning options described in Lounge section here (a must for laptop) - your battery should last longer.
I am squeezing a decent amount of battery from all of my TrueOS and FreeBSD laptops (and OpenBSD too, but that is a bit different). Methods for TrueOS power tuning are the same ones as used in FreeBSD.

Kind regards,

D


#7

reply to myself:
I have played with the suspend/resume issue and found out, that it works fine (at least better) with
sudo echo ‘hw.acpi.reset_video=1’ >> /boot/loader.conf
Caveat: the screen stays locked by xscreensaver and sometimes stays black so the unlock-window is invisible, so I have to type-in the password without seeing anything.
Unfortunately it seams to be impossible to prevent xscreensaver from locking the screen. Tried to uninstall xscreensaver but this seams to be impossible too.

pkg-static: trueos-desktop is locked, cannot delete lumina
Cannot perform request


#8

You can probably disable the password on Xscreensaver. Just run xscreensaver-demo


#9

There is no password within the xscreensaver settings. Have set “Mode: Disable Screen Saver” (for I don’t need/like it) but even then it keeps on locking the screen. It’s the user’s password it is asking for.
=> Looking forward to Lumina 2.0


#10

I believe the setting is called Lock Screen (at least if I am reading the man page correctly. Sorry don’t have a machine in front of me.


#11

DesktopSettings-SystemSettings-Screenserver-ScreenserverPreferences-DisplayModesTab


#12

Thank you @twschulz @bsdtester
I have tried all of what you suggest. My experience is that xscreensaver isn’t disable-able. But I don’t care for I have read that xscreensaver will be eliminated with Lumina 2.0
There are another thing much more interesting: TrueOS seams, on this laptop, not to be aware of battery-status respectively not to care about it. So it runs until the HW shuts the lights. But I want to experiment before posting.

Setting Lock-Screen: time (1…720 [min]) until the screen gets locked, greyed-out when
DisplayModesTab is set to “Disable Screen Saver”


#13

Look into “Autostart”, too.


#14

I added ‘hw.acpi.lid_switch_state=S3’ to /boot/loader.conf but it does not take effect. Isn’t /boot/loader.conf the right place?
#sysctl hw.acpi.lid_switch_state=S3 works fine:
hw.acpi.lid_switch_state: NONE -> S3


#15

In loader.conf, try …=“S3” (Double Quotes!)

I would do this:

Temporary test:
# sysctl hw.acpi.lid_switch_state=S3

Permanent, if test works:
# echo "hw.acpi.lid_switch_state=S3" >> /etc/sysctl.d/my_suspend_to_ram.conf

Then, reboot.


#16

Thank you - that helped! I am happy now with this solution for the suspend/resume issue on this laptop:

#/etc/sysctl.d/my_suspend_resume.conf
#suspend/resume
hw.acpi.reset_video=1
hw.acpi.lid_switch_state=S3
hw.acpi.sleep_button_state=S3