Settings Lumina Text Edit


#1

I would prefer a certain syntax and another font. How can I make settings in lte permanent, does anybody know? A look at lumina-textedit.conf did not really help for the settings look mostly cryptic to me.


#2

You should never need to adjust your .conf file directly - that is just used to save/preserve your last settings in the UI between sessions. If you change the font you use for a file, it will save that new font into the settings file for the next time.
The exception to this is when a particular file-format requests a “monospaced” font. In that case it will try to use the monospaced version of the current font family (if there is one), but might have to change to a different font completely in order to ensure a monospaced font is used for that file.

The syntax highlighting rules are all listed in the “View” menu so that you can switch between the different rules as desired. If you have any questions about the syntax files and how to add/remove them, take a look at the README in “/usr/local/share/lumina-desktop/syntax_rules/README.md” and the associated “.syntax” files in that same directory. Those are the ones that are distributed with LTE itself, but it is very easy to generate your own if you like (you can even place them into your personal “~/.config/lumina-desktop/syntax_rules” directory.
For a web-based version of that README file, you can read it on the Lumina GitHub repository HERE.


#3

Lumina text editor has never saved font settings here.
lumina-textedit-1.2.2_201706211636


#4

It should be:

In my conf file I have something like this:

[General]
lastfont="Noto Sans,9,-1,5,50,0,0,0,0,0"

#5

Thanks.
I have:

[General]
lastSize=@Size(1366 718)
lastfont="Lucida Sans,9,-1,5,50,0,0,0,0,0"
wrapLines=true

And it never changes.
No Noto installed here, though.
Edit: I forgot to add that write permissions are properly set to the user on that file.