Setting up a printer


#1

I have a Brother HL-1210W printer, and I cannot get it working. .PPD from “Brother HL-1230 Foomatic/hl1250” is recommended but does not work, and neither does the .ppd from the linux driver .rpm. The one from the .rpm is here: https://mtl.zone/~mtl/brother-HL1210W-cups-en.ppd

In that directory there’s also a script for Linux from the .RPM, but putting it to a directory what showed up in CUPS’s job section when trying the Brother’s official .PPD resulted in one empty page printed, when trying to print a self test page.

The error message was: Idle - “File “/usr/local/libexec/cups/filter/brother_lpdwrapper_HL1210W” not available: No such file or directory”

This is all the information I can think of now.


... my printer installation
#2

was trying to help on IRC, this is where we’re both stuck


#3

I have a Brother HL-2030 and I was able to get it working OK with FreeBSD using both the driver from OpenPrinting (didn’t try the foomatic version). I suspect it shouldn’t be that much different with yours.

The driver from OpenPrinting works fine, you need make sure you set the paper size correctly, but it’s “good enough” for my purposes.

If you want to use the Linux driver, you can, but you need to jump through some hoops and get things put into the proper points in Linux emulation. Someone wrote up instructions to do this a long time ago. I tried this with PC-BSD 10.3, it worked, and the output was a little better than the openprinting driver. But I ultimately felt it was too much of a hassle and just used the OpenPrinting driver.

Granted this is for the the HL-2030, but I can’t imagine the process would be much different for this printer. Just keep in mind that the instructions are from 2007, so some things may have changed (i.e., just use the standard linux_base-c6 or linux_base-c7 package, don’t use the linux_base-fc-10 that is recommended in that article, you probably don’t need to mess with the linux sysctl either).

Good luck!


#4

Most Brother printers can emulate a PCL4/5 HP LaserJet and will work just fine with that driver.
We’re running several HL-2250 on a FreeBSD CUPS server this way and IIRC my HL-2030 at home (TrueOS/CUPS) is also configured as an HP LaserJet (was set up long time ago and never touched it since…).

edit:
These are the settings for our HL-2250:

Driver: HP LaserJet Series PCL 4/5 (grayscale)
Connection: socket://10.50.55.128:9100

#5

Thank you so much!
Brother DCP-7055W working perfectly well with HP Laserjet 5000 pcl3 configuration. (Did not test any other HP printer config.)


#6

Maybe it was the update to TrueOS 18.03, maybe something else, but said driver did not work anymore. I tested a lot and finally found the driver
HP Color Laserjet 5500 pcl3, hpcups
to work with my Brother DCP-7055W printer. Do not forget to set it to grayscale.
The connection is socket://printer IP:9100


#7

I usually have to put the full ip address into that field


#8

Thanks @RodMyers, it was not visible until I exchanged the “<” and “>” for a “*” each.


#9