Second display is shown when nothing connected


#1

I am attempting to disable a monitor getting created because of a faulty HDMI port on my laptop. When I was using Linux I could append video=DP1:d to the boot options and it would prevent the fake monitor being created from showing up. Is there a way to accomplish this for TrueOS?

When looking at xrandr, it looks like this:

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
eDP1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 309mm x 174mm
   1920x1080     60.02*+
   1400x1050     59.98  
   1280x1024     60.02  
   1280x960      60.00  
   1024x768      60.00  
   800x600       60.32    56.25  
   640x480       59.94  
DP1 connected (normal left inverted right x axis y axis)
   1024x768      60.00  
   800x600       60.32    56.25  
   848x480       60.00  
   640x480       59.94  
HDMI1 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)

From the display section of lumina I can verify that eDP1 is my physical monitor, but it is very clear there is nothing connected, so I am unsure where DP1 is coming from. 20171201_204138_HDR

Ultimately this issue is more of an annoyance than anything, but it would be really nice to have my login screen not stuck at 1024x768. Thanks for any help that can be offered!


#2

BIOS or UEFI?

type about, and post here.


#3

I’ve run into this on a Linux system; check what Xorg.0.log says. If I recall correctly, the workaround was something in the xorg.conf, an extra device section, that would say “disabled”.

Edited:
Take a look here; this is talking about internal LVDS devices, but should apply to your HDMI inputs.


#4